Very unsatisfying printing results


i know what you mean by unsatisfying results, i had them until recently, I loved the flux too much, it was the only printer i had and still is, i worked days on perfecting my print quality and problems, i tried everything i could think of, and now i have it! the perfect printer, apart from some dumb software bugs which destroy my prints… posted about those today! they wasted 100 grams of grey filament! the PIP works good though, just not as how it was intended to cuz of the bugs! hope this helps too!! just spend some more time perfecting your printer, you will eventually get it, put down the speed settings, they often cause alot of trouble.


Yesterday I tried to print a Simplify 3D generated Gcode for my box. There were no feeding issues, no clicking sound and just minimal warping. I begin to think there are mechanical issues which cannot be solved with changing settings. Maybe the printer was dropped during the transport to Flux, I don’t know. I didn’t have this kind of problems before I sent my printer to Flux.

If you check my picture the lines are not precisely straight but crooked. Like if they were drawn by hand. And there are still gaps. But I increased the outline overlap to 50% in S3D. And you will also notice the gaps on top of the walls.

Sometimes the printhead is scratching on the surface. I did the calibration very often. I also noticed a left/right “wobbling” of the printhead and the carriages (I don’t know the exact name) during the print:


if thats what you think then you can submit a ticket to flux support… they will give you replacement parts or a new machine if all fails i guess… good luck!


I’ve already submitted a support ticket a few minutes ago… Waiting for reply.


Adhesion/warping is caused a first layer won’t adhere to the bed ( When the bottom layer warping, other layer is also “bad”. I had similar problem in the past, then I have a glass bed with glue; it works best in comparing with others. Lastly, too much tweaking on S3D fff profile is a problem too since S3D already has some optimizing under the hood in my experience in the past. Trying my setting and let me know if that works for you. However, I don’t think you have a hardware problem that is based on your print.


I tried your profile which was posted here on March 15th: Simplify3D fff profile

Have you changed something in this profile?

I never had bad printing results like that in the past. With every PLA filament I got decent results. But since I got back my printer from Flux every print is horrible. Please check the gaps and crooked shapes of my prints in the screenshots. I tried Slic3r, Cura 1 and 2, and S3d. With S3D I got the best results, but it is still far away from an acceptable quality.

I tried glue on metal (in the past I had the best results with that) and the new Flux magnetic print plate.


The print head on my flux has been moving like that from the beginning… I always though it was normal it being a delta but who knows.

Ooohh and about goldensnakes profile I use that too but… with changes default print speed is 50 mm/s,
x/y axis movement is 70 mm/s, fist layer speed is 40% and well my outline overlap is usually more than 35% but I forgot to change that… running some tests now.

printer in PLA is 12 x 12 cm no warping

but I am recently fighting some layer shifting :frowning: no matter if I use the glass plate or the original metal plate and no it is not lubrication missing this is the 2nd printer after the maintenance.

how can I check if the belts need tightening and is that possible on the flux?


infill overlap test in S3D

@Tyrolean as you can see the square as not really straight on mine either and the square corners are not really “sharp” :frowning:

not sure if it is “norrmal” the x and Y are no the same… the cubes are supposed to be 5mm

everything in mm

top cube X is 4.97 on the 50% one and 5,09 on the 80 % one
lower cube X is 5,08 on the 50% one and 5,09 on the 80 % one

top cube Y 4,9 on the 50% one and 4,95 on the 80 % one
lower cube Y 5,09 on the 50% one and 4,99 on the 80 % one

should perhaps mention geometry correction in Flux Studio was on and the default 0.125mm

I think it was that one but I got that file quite a while ago so not 100% sure


@Tiwaz Looks like you’re experiencing the same issues :unamused:

I changed the S3D settings to your settings. At the moment I’m printing the lid of my box again.

And I have also enabled the geometry correction with a value of 0.125mm. Question is: Do I have to disable the horizontal size compensation in S3D (-0,01mm) if the geometry correction is turned on in Flux Studio? Or has it nothing to do with it?

I attached a pic of the current status: The slit at the bottom looks completely different then the other ones.


I am not sure… I just did the same little print with geometric error correction set to 0 and it does not seem to do a difference on S3D gcode or not a lot… about 0,05mm in x and y or is that perhaps just “normal fluctuation”?

The lines are still as “crooked” as before.

Good luck on your print.


Thank you. I did a lot of amazing prints with the Flux in the past. Perfect layers, top adhesion, no warping, no clicking, no gaps, straight lines. And I printed and sliced everything with Flux Studio. Here are just a few of them:


Guys, I promise you are not alone in trying to figure out why your machine that used to make beautiful prints suddenly cannot manage to get the infill to meet the walls on simple boxes.

It is 1:30am here and I am reading your posts and trying everything and testing and doing everything I can and getting the same results you are seeing.

Something is wrong in FLUX Studio or all of our machines are collectively wearing out at the same time.

I wish I had answers but I don’t at the moment. I’m trying everything I can. My old faithful leaky printhead died. The new (rebuilt) one I just got back from FLUX a few weeks ago is already melted and starting to leak, and I’m struggling to get any kind of consistency in good prints.

I get one good one from FLUX Studio, then it goes to crap for no apparent reason. I switch to S3D and it works great for a print or two, then just turns to a mess. Then I switch back. No consistence at all. I’m currently in the middle of the ‘pancake’ testing that was written up in another post.

Needless to say, I am extremely disappointed too, and I don’t have any idea what to do to make this machine work like it used to.

If the pancake test and remedy works for me too, I will post again.


@BoozeKashi Good to know we’re not alone. Is it possible to bypass/replace Flux Studio completely in our printing workflow? Maybe print directly via S3D? Is there a generic USB driver which can be used?


Yes it is possible via flux_robot from the SDK, but it isn’t easy to set up and won’t exactly work native with S3D like you would expect without some coding.

@pfeerick and I have both looked at it, but speaking for myself, I haven’t had time to go much further than just checking that it was possible when he stumbled upon it. I am not sure if he has explored it any further either.

Jim (Proclaim) has mentioned that they are ‘working on something’ similar when we inquired but he couldn’t elaborate yet. This was actually fairly recently, so pure speculation, but I suspect FLUX is going to give us a direct print capability or something closer to it soon.

Edit: some linkage if you want to play


Yes glad I am not alone.

I would have a look at the SDK but my programming skill are close to non existent.

So I suppose the upgrade kit usb cable does not work with S3D? I did not try that yet…


I tried the upgrade kit usb cable with S3D. It’s not working, the printer is not recognized. Only COM1 and COM2 can be chosen. But I expected that before.


Current result of my print. It doesn’t look much better.

Could the STL file be the problem? It was my first attempt in Tinkercad. But I checked the file with S3D, no repair required.


Not sure if it is the STL file.
From some of the problems I have seen with models on my Flux I would guess more hardware or software issue.

I have a feeling that it might be related to some firmware / software setting which are acceleration and jerk related.
I am not sure if we can change them (at least I never did so far) but I will have a look tomorrow.

However if you want you can share the file and I will print it on my to see if I have the same issues.


That would be very kind, thank you! Here is the link to Thingiverse:

Printing just the lid would be enough testing imho.

Thanks again.


Using my main in vain again Booze? :laughing:

Yeah, I look at it, and was thinking about playing with it further to make an uploader script thingy… but as you say, Jim said they have something in the pipeline… so decided to not bother with that for now… be different if nothing happens and six months goes by… but I doubt it will take anywhere that long.

I’d take wear out of the equation… my baby hasn’t had anywhere as much use as yours or Luans, and it spit the dummy after the upgrade kit was put on… and I do point the finger squarely at the extruder motor settings not being dialed in as far as under/over extrusion related problems and artefacts. Bed calibration / pancake is another issue, but that may be more machine specific?