Version 9.4 released for Flux studio


– Add support for Color Seperation Mode
– Add support for SVG Clippath & Symbol
– Add support for laser path optimization
– Improve toolpath calcuation performance
– Reduce and remove unecessary 3rd-party javascripts

– Reverse layer orders in laser mode
– Change default speed in laser mode

– Fix loading large bitmap
– Fix SVG parser dependencies
– Fix support for OS X version below 10.12
– Fix loading flexible filament
– Fix reading Coreldraw SVG size
– Fix other bugs


This version runs on MacOS 10.13, yeah! the clear scene menu options is still grayed out, but at least the delete key removes the imported item.

There is also new printhead firmware. No change notes that I could find.



The error when changing slicer engine from cura 2 to any other still exists.


yup I went back to the stable versions as the new 9.4 studio is buggy as hell! Also the new firmware update 1.6.86 is also buggy from what I can tell and currently trying to go back to 1.6.75. Not a fan since after both these updates the print head is having major trouble with first layer adhesion when I’ve never had issues before. I have over 500 printing hours on the toolhead per the studio info. I gave up on the magnetic build plate as the temp they have preset at 170 is still TOO HOT for leveling and its damn frustrating that you cant change these settings under the advanced tab. Ive been using a boro-glass 3mm thick disc with some bed clips I made with some Elmers purple glue stick which I was happy using, even though the magnetic surface mat “worked” like a dream it doesn’t last long. So after many attempts of changing the Z offset from .1 to .09 and .15 and .2mm nothing helped. I can literally see the nozzle raise up ~1-2mm on the right side of the build platform as in the toolhead is NO longer linear like it used to be. This causes the delta radius to be much smaller and not usable for me any longer. Flux better figure this crap out and fast. Also not quite sure how the machine can all of a sudden support flexible filament without modding the extruder. I modded my Creality CR-10 heavily in order to support flexible filament and part of that was installing an all alum extruder and upgraded the filament gear itself so theres no chance of flexi binding up in the passage of the Bowden tube and filament extruder gear. I know this post is long but seriously this machine was working great until two nights ago when I installed the new firmware and studio 9.4…so If you havn’t updated them yet…good! I wouldn’t advise it just yet especially since they havnt listed what the heck the new firmware “updated”


Hello - Did you go back to the previous firmware and 9.1? Are you back to being functional? I have to go back just because I periodically change the slicer engine depending on what I’m printing. I have not had a chance to test the new system firmware after I loaded it.


I’m using 9.4 on Mac and Linux with no issues. However. It seems export has been disabled - so no printing from usb stick.


I did go back to stable 9.1 however still having issues that were not present before using 9.4 and updating firmware. For some reason It had screwed with my Z offset which was .1mm and I have to change it to 0 or -0.1 depending on the print which is super frustrating to say the least as I had zero issues with prints adhering previously. Switching firmware back and forth didn’t seem to help either way so I went back to the newest 1.6.86 firmware for now.


Hi Michael, What about changing slicing engines? Do you get any errors on the Mac? I have not tried.


I don’t change often. I did and got an error, but just resliced and was golden. That was on the Mac. I am also running Flux Studio in a Samsung Chromebook 3 that I installed Ubuntu on. It’s slicing nicely. I’ll try to change slicers on it a few times and see.


Nope. On Linux, changing The slicer is unrecoverable. Other than that, it’s all gravy.


Thank you Michael, so it is a consistent error across all platforms…


There will be a new version targeted for next week, 9.5 that is supposed to fix the slicer issue.