USB device not found - SOLVED WIN7


#1

USB Device not found.on starting flux studio 0.2.5

installed driver (can see a com5 in device manager)
Where to start troubleshoot?

win 7
32 bit

Changed USB cable…

Many thanks

Bart


v0.2.9 Alpha - Thank you
#2

I would start by upgrading to the newest Flux Studio - 0.2.7


#3

I’d also check that the driver installed properly in Device Manager. Might as well download that too, while you’re at it.


#4

Thanks for the messeages.

@milkdog: Update done, still no connect

@Jimustanguitar: I have a Silicon Labs CP210x USB to UART bridge (COM5) in my list.

edit:
tried on my mac. same problem. 0.2.5 and 0.2.7 can’t connect
Can I connect to flux by serial terminal to see it’s reacting?

Bart


#5

You are not alone.

I checked everything on the list, still doesn’t work.

I am using Mac though, and I am waiting for their reply.

They’ve been pretty busy, last time they replied me after a week.

TAT


#6

hi @studioblabla,
Right click on FLUX Studio and run as Administrator might works for you.

hi @Chen_Shin_Jih,
I didn’t see your support request, can you tell me where you sent it to? For Mac, kindly check if your OS version is 10.10+


#7

@Simon
Did support request too.
Flux is running as admin.

Bart


#8

@studioblabla

I will need your help doing following things.

  1. The following program might not installed correctly. Try to install again:
    https://www.microsoft.com/en-us/download/details.aspx?id=48145
  2. Do you have other com port simultaneously connect to the machine?
  3. While you are using v0.2.7, I will need you press Ctrl+Alt+D, click console, and take a screenshot.

#9


#10

@Simon
This is my mac console The errorcounter is increasing like a fast clock.

Bart


#11

@Simon
I manually deleted all flux entries in the register. (quite a lot!)
I deleted the flux folders in the programfiles directory.

went in safe boot
in device manager hidden devices, delete the silicon UART driver.

Booted normally.
Installed flux drive
Reboot
Installed flux 0.2.9
Rebooted
Connected printer
Wait a long time till the driver is installed
Rebooted
opened flux as admin
Clicked connect printer, and EUREKA!!!

(did the wifi setup, could not connect to printer, restart program and all OK.)

Me Happy! :smiley:

I bought this printer for his scanner. Will try this feature first, than the laser.

My mac can wait.

Bart


#12

@studioblabla Thanks for the update on how you solved your issue on you Windows 7 machine.

I’m having the exact same issues as you, but I’m still unable to fix it yet. I’m running Windows 10, so that might be the issue there. I’ll be investigating this part and will post a solution if I find one for the Windows 10.


#13

Finally fixed my connection problem. Here’s what I did.

  1. Uninstall FLUX Studio (0.2.14) using Revo Uninstaller to remove all directories/registries
  2. Uninstall Silicon Labs CP210x USB to UART bridge from the Device Manager
  3. Install an older FLUX Studio (0.2.12)
  4. Reconnect FLUX to my PC and it automatically installed the driver.
  5. Start FLUX Studio as an admin and ignore the newer version update.
  6. Device finally connected.

#14

Similar to dr3amr2

Same fix worked for me. Could not get 0.2.14 working, uninstalled.
Installed 0.2.12, connected said firmware was out of date.
Copied updated firmware onto usb stick (fat32) renamed file,
inserted usb into device, power cycled, waited for firmware to update.
Device found by software.
Updated to 0.2.14
Seems to be working.


#15

Had to do the same thing last night. .14 seems to be broken.


#16

Here is a solution i found for Win 10, it may help someone!

  1. uninstall flux studio and delete it’s files from program files and program files x86
  2. install THE OLD flux studio version. the first release.
  3. run it, skip the update, and connect to your printer. it should work.
  4. if your wi-fi is not detected, as someone helpfully suggested here, create another hotspot (with your phone or something). it would make your other wifi network appear on the list for some reason i do not understand.
  5. turn it all off and run the updated version installation file.
  6. make sure that the directory is the same as the old version. it does not work as a standalone! (for me the first one was installed on program files x86 and the new one in program files. so i had to direct it to the right folder.)

this seemed to have solved it for me.
i hope it helps someone

gl, gonna test it now for the first time ^^


#17

you can easily fix the problem if you worried how can you do this so, don’t worry
you can go to site given below