USB-C cable replacement


#1

Hi All,
Due to a small misunderstanding on my part when I was returning my printer, I have ended up without a USB-C cable to connect the printer head. The cable seemed to be a standard USB-C, does anyone know if this is correct and any USB-C would work?


#2

i will be try this item.

http://www.aliexpress.com/item/Hot-selling-USB-C-USB-3-1-Type-C-Male-Data-Sync-Charger-Charging-Cable-for/32579086360.html

i had to order at Feb. 23 2016. but not received. aliexpress is very very very very… slow. ‘_’;;


#3

I tried the cable that came with my nexus 6p and it didnt even spin up the fans. Flux also gave “toolhead not detected” instead the other 2 errors i usually get. So i would assume that you need a special usb-c cable that can handle the 25v its driving.
So unfortunately it looks like you just have to wait for them to send you a replacement.


#4

hi there . my understanding of usb connectors is that they operate at 5v or less , it is baisecly just used to send a signal for the head operation . i have at least 4 different cables for my iphone and some work and some only charge and one does nothing at all . i am pretty sure that flux did not go out and design there own cable . just my thoughts .


#5

Hi All,

This cable works with flux

http://uk.farnell.com/roline/11-02-9000/usb-cable-3-1-type-c-plug-0-5m/dp/2484312?ost=2484312&selectedCategoryId=&categoryNameResp=All%2BCategories

I think the 3.1 bit is important as USB-C 2.0 cable won’t work.


#6

You can also try ESEEKGO USB type c cable helps you charge fast. I am using it and feel very well. You can get it on amazon. Hope this helps!


#7

ESEEKGO USB type c cable: https://www.amazon.com/ESEEKGO-Charger-Dirtproof-Braided-Charging/dp/B01JAAK57S/ref=sr_1_6?m=A2PQ5VQHSRWEC5&s=merchant-items&ie=UTF8&qid=1486518531&sr=1-6&refinements=p_4%3AESeekGo
There is sale on amazon. You can get it easily. Hope this helps!


#9

I’m losing the will to live trying to pass the money test… Is the farnell or other 3.1 usb c cable better than the one supplied? I cannot believe how something so critical to the machines operation is so BL£#&Y USELESS…

Anyone got any methods that actually work? Having to bend and flex for 40 minutes before each print is beginning to suck huge amounts.


#10

Huh? I’ve never had to flex my USB-C print head cable since the day it arrived - and that was just to remove some of the ‘folding’ kinks from shipping. I initially had a 3d printed part stuck on that acted as a strain relief, and then when I got the upgrade kit there is a rubber piece that seems to do the job just fine itself. Then again, IIRC, there was some change in the cable from what was supplied in the first gen model, so maybe that is the cause of the issue.


#11

Mine is the delta plus… Supposedly the latest model (back then) it’s a total disappointment. I could never rely on it like the zortrax m200. The USBC cable was developed to be used either way round. It would seem flux have truly messed up specifying the critical component. But then again the scanner doesn’t scan anything properly the laser cutter will take eternity to “engrave” something.
I just feel our friends in China need to clean up their act. Promise one thing and deliver trash.


#12

I also have the delta plus. Followed the initial directions, flexed the usb for a few minutes, installed it and have never flexed it since and I’ve been printing with the delta plus for a year and a half now.

This sounds like either you got a faulty cord in which case put in a ticket, get a replacement. Or something else is “actually wrong” then gets fixed when you remove and reinstall the cord.

What actual error are you getting if you don’t “Bend it for 40 minutes before every print”?


#13

Sorry just re-read my post. It fails the movement test. I have better things to do with my life than beg my printer to print. I could buy an infinitely more reliable printer for £200.00 its sad as this printer could have been a game changer if it actually worked.
Scanning 1/10
Printing 0/10
Laser cutting 2/10
Vinyl cutting… Why bother with the above marks so poor.


#14

Well then best of luck with future endeavours.