Unabled to connect


Hi everyone,

I’ve receipt my new Delta+ yesterday, but since, impossible to connect her at my PCs.

I follow instruction BUT i’ve always a blue blinking light slowly… not in instruction.

I try to install :

  • usb drivers : OK
  • Software : OK
  • plug usb connector, drivers recognized : OK
  • i launch software : 3d printer no found…

I try to push 3 sec th button for wake up : great i’ve an alternate blue/white… read instruction : updating ??? why not…

I wait… 5 min, 10min 1 hour, 1 day !!! always !!!

I try to reset but for that you need white light on button… not blinking or alternate… so fail…

I try tio create usb key with firmware in fat 32… 1 key,… 2 keys… 3 keys… !!! Nothing. No sequence

i’ve try to remove all (software, drivers, reg base entries…), try to install old version (0.6.0) and newt (0.7.0), submit a request to support who say : follow guide and try last version of software. Same.

I’ve no wireless network, impossible to connect to my 3d printer, impossible to update…

Since i’ve an totaly useless 3d printer… :smiley:

Someone can help me ?


All Flux app and discover port are authorized in windows firewall and drivers are present :


You are in new territory for us there. Direct USB control was mentioned in FS 0.7.0 's change log - “Supports direct USB connection for FLUX Delta+ and Upgrade Kits”. It was not available to the first Delta and is still not available until we receive the upgrade kits with the special USB cable in it.

On my Delta, when clicking the “Connect the Machine Using USB cable” button, Flux studio is looking for a connection to the MICRO USB port to set the wifi password only. I could then turn the Delta off and on and if the green flashing light stopped flashing and stayed solid it meant it had connected to the Wifi and Flux Studio would then see the machine on the Wifi network and connect.

On the Delta+ we don’t know what happens as you’re amongst the first to get one. On my Delta if I stick a standard USB cable into the standard USB port, nothing happens. Windows does not see anything. If I plug in a micro USB cable I get a different driver pop up - “Silicon LabsCP210x USB to UART Bridge”.

So, as I said the “Connect the Machine Using USB cable” for me is only for connecting with the Micro USB port so I don’t know how you tell Flux studio that you want to connect using the new USB cable.

@proclaim, Some specific instructions from Flux about how to use the new Flux cable are needed I think.


Derp! I missed the line where you said you don’t have a wireless network.

So, the Flux Delta has (had?) the ability to configure via the microUSB cable, but the help center article warns that they were going to remove that facility, probably since they added the ability to configure over WiFi, so it no longer needed that duct tape solution. However, since the Delta+ has come alone introduced being able to print via USB, that is new territory for us all.

But it does sound like something is going on with the Delta+'s first poweron / update sequence… maybe power cycle it a few times… I know I had a similar problem at one point with a failed update and just had to try it again and let it work it’s way through. To do the factory reset, you power off the machine, hold the button down, and then power it on, holding down the button until it starts flashing red-white. It should settle back into a white-breathing and green-breathing sequence within five minutes… indicating it is ready… if not… follow up that support request!

Just skip to the next post as it doesn’t apply since you don’t have a wireless network…

So are you not able to see the Flux Delta’s wireless access point? Is the green light next to the button not coming on at all?

The Flux Delta (and Plus?) only support 2.4Ghz WiFi, so if you’re on 5Ghz… no cigar. Otherwise, some more guides / links to look at are… the WiFi Setup Guide and possibly the original guide on how to upgrade the delta to support wifi setup also may help, as it works through the upgrade process also.


HI , you say you do not have wifi , if you have a smart phone you should be able to connect with it and maybe get your setup to run . just a thought


hi , i also forgot to mention that a lot of users were not able to run their machines with the new version of c+++ and needed to download the early version of c+++ , i believe they have the early one on their download site .


Thx for you back !

I’ve try by micro-usb without any success, and in guide of delta+ (and 7.0.4), you need connect by USB cable.

I’ve try a many time… without succes except spark when i plugged her !

I’ve try many usb keys (with different size) nothing !

I’ve try by a lot of terminal (smartphones, notebook, tablet, pcs…) : not viewed ! no wifi network !

Do you have a link for a good version ?


And since my request two days ago, flux not answer me ! (request 16501 if you read this message)


So what exactly happens when you try a factory reset? You connect the power (and get a spark)… but what do the LEDs do? If it is stuck at the red/white blinking… you won’t get any sense from the printer as it’s stuck trying to update or something.

As far as the USB key, if you have a smaller one (say an 8gb one), it might be worth formating it again, and making sure the file system type is FAT32 (or FAT/FAT16). I made the mistake of inserting a larger one which windows had formatted as exFAT… and the Delta wasn’t happy with that :wink: I seem to remember it being fussy about which USB drives it worked with also, and stuck with a sandisk cruzer switch as it worked fine.

The Visual C++ redistributable runtime which spiff was talking about can be downloaded from the Flux download page -> https://flux3dp.com/downloads/


I’m sorry for the trouble you’re experiencing. Our goal is to make things simple for users and this is definately not what we want.

as for the information for everything, we’re shipping Delta+ with direct USB cable (not micro-USB) that you can control your Delta with (if you don’t have Wifi). Our goal is to remove micro-USB in the future.

Here’s what I would suggest

  1. restart the machine, ( and un-plug the USB) and wait for it to boot up
  2. start FS
  3. navigate to the setup page, where left is Wifi, and right is USB
    4, plug the USB cable

if you’re updating firmware through USB, use FAT or FAT32, and remember to rename the file to autoupdate.fxfw (this is important otherwise you won’t be updating anything)

Let me know how it goes. (or you can fire a support ticket at our support center)
good luck!


Thx for reply but unfortanely i’ve already test your manipulation : ths problem is simple : she never boot up !!!

When i plug power, button start by an alternaly light blue and off… if i wait one day, it’s same.

When i push longer the button who alternaly light blue and off, button alternaly light blue and white… i can wait one day enterely again, flux always light alternaly blue and white… no boot up.

I’ve remove c++ studio 2005 and try reinstall it from your website version but impossible because windows say at me it’s already installed in different version (i’ve 2008, 2010, 2013, 2015 installed too)


I think you do have a hardware problem on a main control board after all troubleshooting steps. Basically it should be connected via USB right out of box; it doesn’t in your delta printer. I’ve been testing on all Flux Studio and firmware versions, it should work on both WIFI and USB communication. Hopefully Flux support will give a solution soon.


Just a thought, did you try a different USB cable?


Hi, thx for answers.

I’ve try 3 differents micro usb, but i can’t test antoher usb because is an double type A male for each side.

I’ve buy 3 others usb keys, format in fat 32 and fat… nothing change.

Always blue and white alternatly…

Support from flux understand after some mails (same content as this topic) and 48h later :


Do you mean that every time you plug in the power, the machine always go to blue-white flashing status? Let us know.


I’m desperate…

If i need to reship her, i hope i’ve a payback for tax import because at 172 € tax import for each shipping… and the price for test usb keys… It’s a beautiful useless 3D print in gold at this price !!!


If I am not wrong you cannot use the micro-USB connection, you have to use the regular USB connection.


I use it.

A movie for see the problem (available in 40 min) :

Flux Delta+ Problem


Did you try to update Flux printer firmware 1.6.25 at the end of your video and still not working? Flux logo and WIFI indicators is still breathing after an update?


Ok support give me the solution : open the delta+ for replace SD card on raspebrry mothercard !!!

I’ve broken my warrantly and open, effectivly SD card is completly out.

Iv’e re-insert her, Delta+ is connected !!

But some problems come with :

  • I’ve updated my delta+ and setting her (wifi) but she boot in ap mode, not connecting to wireless router and when i try to connect to her directly in ap mode, no password (include serial) working !
  • Other problem : when i try to calibrate here, toolhead go out during calibrating. Impossible to use here (error) :
    Calibration Fail


I test without filament, same !


The printer is detected an error before calibration; making sure all ball joins are well lubricated.