Trying to decide if it's worth it to try to get original Delta working


#1

I haven’t used this printer for something like 3 years. It has been kept in the attic in fairly good condition. I got it out and cleaned it and was hoping to print off some stuff since after 3 whole years I now actually have some stuff that i’d like to actually print. I was worried about the condition of the filament, but I now realize that is definitely the LEAST of my concerns.

It does the following:

Upon power on, it will move the 3 arms upward until hitting the limit switches, and they stop. Stays with both button breathing white and green LED breathing. This is definitely expected since after 3 years I’m in a new house, I don’t have the same wifi SSID anymore.

So I have done the step where I hold the button while plugging in power and continuing to hold until the button starts alternating white and orange. I released it then. Subsequently I’ve been hoping to spot the flux broadcasting its own WiFi SSID, but I haven’t seen it. It behaves the same way as before… green breathing, white breathing on the button.

I’d be totally happy to have to load USB drives with a file to get it to print from the file. But… I think I have to find a way to get the flux software past the “pairing” state in order to be able to “Export FLUX task”, right?

I’m pretty ready to order a new printer. Hope someone can convince me one way or the other what I should do.


#2

I am pretty familiar with raspberry pi’s. Is there some way I can mount the SD card from the pi inside and inject my wifi credentials into it? That’d be nice.

I’ll try (based on the hint in one of the setup guides) a USB ethernet dongle. hoping that USB-A female port is jacked to the pi inside, hopefully it checks this and allows things to work if it can be placed on the network directly like this.


#3

Great, so the USB ethernet adapter lights come on and I now have an assigned IP address reported by my router, and I can also see the MAC address of it, as well as its self reported hostname of “raspberrypi”.

I had FLUX Studio 1.0.0-beta.1 open along side. Noticed that it now prompted me for Name Your Machine. I set it but the spinner is still going and it’s been a minute…


#4

Alright well it is clearly connected so I’m gonna see if i can get stuff going, seems like the firmware is really old.


#5

I believe the alternative way to sync it is with the USB cable to your PC.
Here’s the link to the site describing the WiFi setup:


#6

And here is the USB setup guide:


#7

Yeah, I don’t think i have the “special” usb cable that I was reading about on this forum. Not really that interested in something weird like USB -> serial -> USB to communicate, seems not worth the trouble.

So far I was able to stumble across the flow in FLUX Studio to assign the Wifi network for the Flux Delta to connect to, and I attempted to use it to connect to my network, which has a SSID with an emoji in it, so (as expected) that doesn’t work. I was even able to download a network log from it, which states very clearly that it failed to connect, and so this thing is just in AP mode for now. Which I quite like, actually, since that way I don’t need to have an ethernet cable that it’s using up.

But yeah I was pleasantly surprised that the USB3 ethernet dongle I used worked so well. Turns out, though, that it wasn’t even necessary, since even though it got the studio connected, it wouldnt let me do anything and told me to update the firmware, and once I did that… it’s now in AP mode and properly broadcasts an SSID and everything. Seems like I might be back in business… Even the camera works! I may be able to make this thing into a workhorse yet.


#8

I doubt this is worth mentioning here since I don’t know who is still sticking around looking for anecdotes on this discontinued printer, but…

I’ve been having problems with the first support layer being skipped when printing on a raft (the raft, which is so crucial on the ice cold plate it is a necessity), which as you might imagine imparts huge risk on the success of the part when the support material is hanging on for dear life.

I believe as of now that this issue of a Cura bug causing this missing layer is responsible, and the timing of the discussion indicates it’s plausible. https://github.com/Ultimaker/Cura/issues/1754

As such I could probably look into slicing with modern software that hes less bugs, and importing G-code somehow to use on the Flux Delta.

I should probably also want to print a spool holder to reduce the strain on the feed gear. That thing starting to click was giving me a lot of trouble before, and I hear it happening periodically now too.


#9

I completed a usable part, by far the most challenging thing I’ve ever attempted on this printer. And that’s in spite of the largest issue so far, which is the bug with first layer of support being drawn in the air. Will test settings next to work around this.

The other main annoyance is a periodic (every 5 to 10 hours?) the printing stops with toolhead not connected error. I want to try some other USB-C cables. When I tried (once) with an iPad Pro (thin) cable it did not work, but it may be direction sensitive maybe… Hopefully the cable is not a special cable. It’s rather stiff. I have no clue why it would produce this error though and it may not be the cable because each time I simply retry and it restarts again! It even stopped overnight one time and luckily could resume the print without introducing any quality issues.

The wifi also loves to disconnect (am using AP mode via wifi from my pc), but i may be able to work around that using the ethernet dongle.