Toolhead 1.2.1 Update Failed


I have updated to Toolhead 1.2.1 but only after changing the filename from “fluxhead_v1.2.1.bin” to fluxhead-1.2.1.bin".
Has anyone else had this problem?

Here’s what I did>
I updated FS 0.3.8 to 0.3.9 on Win10x64.
I tried to update the Toolhead to 1.1.2 to 1.2.1 but after the flux button went orange, the message “Update Failed” came up and when I tried it again it still said I needed to update for the “Improved compatibility in summer” and failed again.
I tried the previous version 1.1.2 and that updated fine.
I tried downloading the 1.2.1 file again and that failed again.
Then I renamed the file “fluxhead_v1.2.1.bin” to fluxhead-1.2.1.bin" and it worked!

Now if I try and update the firmware again to prove it was a file name problem, it says I already have the latest version and it won’t let me update again so I don’t know if it was a fluke or actually a problem with the file name.


I don’t have update problem with “fluxhead_v1.2.1.bin” using FS 0.3.9.


how did you update the toohead firmware when it was installed already? If I try to reflash the toolhead, it says already on new version, and does not allow me to reflash?


I did once. Install update FS 0.3.9 and update tool head firmware 1.2.1 on both print and then laser heads.


As it said there was a new version available it let me update with the old version file. Once I successfully updated to the new version I could not update it again.


I have the same problem
FS 0.3.9 update OK
But Tool head firmware 1.2.1 update give me the message “Update Failed”…

has anyone had an idea ?


Does changing the file name, as above, work?


No it does not work…


So maybe it was a fluke that changing the file name fixed it. Try downloading the file again and updating a few more times if you haven’t already.


Thank you for the answer

I would retry later, I do not think whether it is an important update…


@proclaim Hi Jim

I have always the same problem
FS 0.3.10 update OK
But Tool head firmware 1.2.1 update give me the message “UPDATE FAIL”

Have you a solution for me ?
Is it possible to update by USB key ??

Is this update very important ?



Hi, Mike,

  1. try unplug the type c, which is connected to the print head
  2. turn power off
  3. turn power on
  4. plug type c back to the machine
  5. try upload again

if this problem still exist, try submit the bug report and we’ll take a look


Hi Jim

With the new softaware version 3.12 I have exactly the same problem !!!
Please give me a quick solution to upgrade toolhead firmware !!!

No answer from support from 2 Weeks !!

Thanks in advance


I have the same issue too.
I am trying to update the Engraving Toolhead to fluxhead-v1.2.18.
FS: 0.9 on macOS 10.13
current toolhead firmware: 1.1.2

I tried USB and Wifi. The result is the same:
I can see an upload dialog that doesn’t pass 0% then another dialog with the message “Update Failed”.
Can I provide any logs thats helping finding and solving this issue?


I’m not sure if you can update the engraving toolhead. I think the update is only for the printing toolhead. Does it work to load the update when the printing toolhead is attached?