Stuck uploading code when trying to use laser head


Have not tried to use the FLUX in a couple months. Got the newest version of the software and did a firmware update.

Trying to do some laser work on wood.

PNG file
Connected by the USB cable. Seems like the printer connects fine as it ran the firmware update.

Stuck on uploading code for over an hour. Status bar was at 99% I think.


I am also having issues with the Laser tool. I tried a small PNG file, just 2 short black lines, to test the laser since I had not used it for 10 months, but it did not work. The head comes down starts to drift slowly towards X-min and hits the limit of the printer but tries to continue. I think there is something wrong with the Software. I was also using the latest versions of Flux Studio and Firmware.


I grabbed the 0.9.0 version I had on my other machine and it is now running a test with the laser. Code uploaded fine I think.

Seems 0.9.4 and 0.9.5 will not run the laser???


There are a lot of bugs with 9.5 and 9.4. I use 9.1 and have not had issues.