Something wrong with first layer!


It’s happened on my printer as well. I’ve been trying many things such as calibration, different plate (metal with new Flux plate and glass), over extrusion settings, z offset and etc). Any ideas?!

@proclaim and @Simon
I found a SERIOUS BUG on the firmware on the first layer problem above. I roll back to the firmware 1.6.4 and FS 0.6.3 and the result is fine as comparing the problem on 1.6.51.

The same print is printed from the firmware 1.5b13.

I don’t know which firmware is the most reliable. Now I can live with 1.6.4 Delta firmware. My best guess is CALIBRATION problem. Please advice.


Check your magnetic sockets (twist a finger nail in each socket to see if it catches). Mine has been running nice and level again after I sanded the sockets. While I wait for new sockets the old arthritic joints are holding up well.
That had me scratching my head for two months, swapping around ball joint rods, flipping my glass plate around, trying different glues and different Z offsets when all along it was the chrome flaking off the sockets and giving results like you’ve got.


Thanks. I did replace linear bearing and the magnetic rings might be mis-alignment.


What you say puzzles me, if it is a misalignment issue, you should not have a good 1st layer even with older firmware/software, as seen in the 2nd picture!

I gave up on my 1st layer issues long time ago! Since day one, the 1st layer on the left side of my platform printed as if that side was higher with occasional clicking, right side was good. It did that no matter what I did or used as base-plate; glass, steel, PEI did not matter. I gave up and now compensate for it by always giving 0.1mm Z0-offset. If I make my 1st layer .35mm thick, I don’t need any compensation but I keep my 1st layer same as the print layers, in general 0.2mm.


I disagree with you on this subject. If you print only one part that is ok but with multiple parts, it’s no easy to fit them together without filling. However, the point is there is inconsistency between the firmware itself, which shouldn’t be. I always expect a printing model as close as gcode file. Here is another print infill doesn’t look like a honey comb pattern to me.


I roll back to firmware 1.6.51 and FS 0.7.7. I test a first layer with several settings on S3D as following:

  1. Z-offset = -0.15, first layer height = 200% and first layer width = 80%, extrusion multiplier = 0.9.
  2. Same as above and extrusion multiplier = 0.5.
    I notice that there is over extrusion on first setting, a nozzle is scratched on a thick layer while movement (see RED circle marks). I print the other half on second setting and over extrusion is reduced (see YELLOW circle mark). Why the printer is over extrusion on some small areas of a print? Please advice.
  3. Same as above and extrusion multiplier = 0.4 (Change filament on lighter color for more contrast on over extrusion on some parts of the print. I’m puzzle?!?! Hardware problem ?!?!
  4. Same as above and extrusion multiplier = 0.2.
  5. Same as above and extrusion multiplier = 0.9, upgrade kits extruder is disable.
  6. Default setting on FS 0.7.7 and firmware 1.7.51 with Cura slicer. Nozzle is still scratched on first layer surface while travel move. It’s over extrusion.
  7. Same as above with Sli3r default setting. Nozzle is still scratched on first layer surface while travel move.

    What’s your opinion on this? Thanks.
    However, I thought I have a perfect profile on S3D after a year of printing quest. Now I’m back on square one with the problem.
    Import S3D gcode file and translate it to fc file print not as same as Slic3r/Cura in FS. Here is my S3D profile and the testing stl file.


It’s almost a year now that I have this problem. Sent 3 tickets but never got a solution. I changed some days ago the linear bearings with the new ones but it didn’t really change anything…
For the first months I never had this kind of problem, then in april/may of last year I upgraded the firmware of Flux/toolhead and the problems arrived.
In my case, at the center of the plate the head is almost touching, the more you go away from the center the head is lifted (and becasue of this most of the time I have warping problems). I can’t really play with z offset because if I fix the center the boundaires will be too high, if I fix the boundaries the head will touch the center.
In my absolute ignorant opinion it seems that it’s more a firmware problem than an hardware one.


I think that too, which are based on the result of my testing. I can’t be over extrusion some spots on the first layer. In addition, when they convert a gcode file from S3D to fc file that shouldn’t be any difference from Slic3r/Cura. Let wait and see how are they response on the problem.


Damn. I just found this thread.

I thought it was just me and I had somehow screwed up my S3D install.

I have had just about the exact same experience, and have gone back and forth between S3D and FLUX Studio and Glass and Magnetic plate and just get really weird almost (but not quite) random over/under extrusions on the first layer. Exactly like your photos. Some places print normal, some not at all, and some too much. I’ve even had a few prints where it all printed and looked fine, but then the first layer just peeled right off after printing. Completely peeled off, like a banana. Strange. I think it started around 0.7.6 or so maybe?


I thought that the one has the problem since @Beganio . Even Flux team or @proclaim has no comment on the issue too.


No, something definitely weird going on. I actually took a photo of the weird layers as I thought the replacement print tool-head I just received was still defective. Seems it isn’t the tool-head, but something going on in FLUX Studio.


Nobody said anything from the flux team, a year has passed now…

I was thinking to open another ticket (4th) but the fact that nobody is commenting it means that they don’t have a clue.


Can’t explain why, but I have a similar blemish(s) on my print to your fist picture with circles, specificlaly the right red circle on the main part of the vise (which funnily enough I am printing from thingiverse also). I am printing the bases one at a time, and I just reset all the advanced settings in 0.8.0 to default, and changed my infill to 35%. No raft, no brim, no supports… just the print.I didn’t take a picture because black filament on a black build mat don’t turn out that great :wink:

Edit: Second layer was perfect though, and smoothed nearly everything out. :confused:


I’d be hesitant to blame a slicer for this. An overall difference in first layer thickness would definitely be a first layer height setting, but height inconsistencies across the same layer probably are slicer agnostic. Generally, the only Z information in a sliced GCode file is a layer change. A high or a low spot seems like it would be a hardware/firmware calibration issue.


I agree completely Jim, however, there are several of us seeing the exact same “patchiness” and the common denominator is the FLUX Studio update. To be technically correct, not saying the blame is in the slicer per se, (at least in what Luan and I are seeing) because we are using S3D as the slicer. Something in the gcode to fcode conversion is the more likely culprit, and that is certainly where an issued with a hardware calibration issue bug could have been introduced.

I’m still seeing the same issue. What I’ve figured out for a workaround is to just double or triple up on skirts in S3D. It basically puts them down like a powder and they stick to the magnetic plate for quite a while [Sidebar: Care Instructions for Mag Plate?]

If I load up 0.6.3 the same skirts actually extrude as, well, as extrusions, not powdered lines. Nothing else changed, same gcode file. The only difference is the version of FLUX Studio. “Patchy” is the best description I can give it, if you don’t do something to counter it, the first layer will look like a mangy dog’s butt.


Well, here is something strange to add to the mix. I just started printing part B of the vice base, and saw a bit of first layer patchiness. After it was finished the skin, and just starting to process the infill, I noticed that one side was starting to lift off of the buildtak mat, so I stopped it as I know it was going to go wrong big time, as the part A started curling it’s toes up at me halfway through, and was slowly but surely lifting throughout the print… but held out till the end.

So I shoved my glass bed back on, removed the 0.1 z offset that I had added to try declunk the print (and added a couple layers of brim to make doubly sure ;)), plastered it with glue, and set it off again. Perfect first layer this time, and it isn’t clunking anywhere as much as it did before when doing infill.Maybe my guess before about the magnetic bed being a bit spongy and not calibrating quite right was actually right, but isn’t responsible for detaching rods! Funnily enough, I left the steel plate in this time… I used to remove it completely, and sit the glass directly on the calibration rubbers, but didn’t bother this time.

Anyway, maybe this will mean something, or maybe I’m confusing… more info can’t hurt right? :laughing:


Calibration and calibration! Some part a nozzle is so closed to a glass and can’t extrude a plastic.

Now I know what’s exactly a problem since a nozzle is so closed on a glass; a melting plastic is built up inside a nozzle and it extrude more plastic on a part where is a nozzle is at higher position that is caused under/over extrude on the first layer. The first layer is critical on some model has some mounting holes or integrate with other part of multiple prints.



strange. i have a different Experience.
When i got my Flux (some month ago, one of the first) it worked fine (ok bad USB-C Cable), but then it is going worse. I added a heat bed, a glas plate, blue tape, etc. but in the end nothing helps. So i change some weeks ago the bearings. Now it works a “little” bit better but not good. Last week i got my upgrade Kit. I install all the parts and change the settings for the machine in the studio. And what? Now it works as expected!!!
The first layer sticks on the magnetic plate like it was glued on. :slight_smile:
The calibration takes sometimes 3 to 5 rounds to get success. But thats ok, it works now.
Even parts with a small footprint (2cm diameter with a high of 10cm) will print with no Problem.
Multiple parts, print at once: no Problem
“Big” Parts (10 by 10 by 10 cm): no problem.

I used the actual Studio Version with cura3. Default settings. No changes except infill.

Edit: cura2


I use Simplify3d as a slicer that’s a problem on the first layer but Slice3r or Cura.


Yeah, my experience when using somewhere around 0.7.4 with the magnetic build plate was something like that… it has been fantastic up til the last couple of prints. So either there is something going on in FS as far as the geometry calculation, or the mat is starting to play up a bit after several prints, or the monkey running the show is doing something wrong :wink: Obviously isn’t my day today for printing, as glass plate, perfect calibration in just two passes (as I’d changed the build plate - has normally been one pass of late) and near perfect first player. But the quick release on the print head released about four hours into the print, so I was greeted by a spaghetti mess when I went up to check it a little while ago.

Thankfully I was able to roll the filament back onto the reel, and will set it off again tomorrow. I’ve trimmed the offending end of the filament tube, so the quick-connect has something to bite into again :wink: Just have to double check the nozzle wasn’t blocked.