Scale axis doesn't rotate with object


I imported an object that was laying down, so I used the rotate feature to stand it upright. After doing this I wanted to scale it to be a specific height, and I noticed that the XYZ dimensions in the tool didn’t rotate with the object. The height of the object still lined up with the Y dimension instead of flipping to Z like the way that I had the part oriented.


I’ve found the scale function to be really buggy as well. Sometimes you grab something and accidentally scale it, and the numbers just don’t make sense at all. A 100mm part, once moved or rotated a little, may end up saying it’s only 3.7mm. The only other thing I REALLY really want is a scale percentage. I can’t reliably scale multipart prints when I have to guess if the scale is correct. It’s all kinds of messed up most of the time. I’m honestly just trying to be patient though. I’ve got a growing list of prints that I’m awaiting more features before printing.


@Jimustanguitar when the file is first imported, the xyz is set with the object. let’s say your object is first imported laying down, with z as the height, when you rotate, are you expecting z is still the height of the object?

@AmnNate is it possible that you can record a video for demo?


The other programs I use orient the XYZ scaling to the build area regardless of the object’s orientation. That’s what I’d consider standard for 3D printing programs. Z should always be the Z axis of the machine.


I see your point, then in that case, there must be a point where y becomes z axis, maybe at 90 degree it’ll automatically switch, perhaps? what program is this “other program”?


Everything I’ve used. Cura, Slic3r, Mattercontrol, Repetier Host, NetFabb, Simplify 3D…


And thanks for all of your help and hard work!


@proclaim To be honest, I haven’t seen it happen recently. It must have been an older version of the software.

My big complaint right now is that the software seems to freeze when trying to slice multiple objects or very detailed objects that happen to be large file sizes. For example:
The stl file is very large. The slicer just seems to break. Maybe my computer is just not up to it? Also, when loading multiple stl files onto the plqate at once, the slicer just seems to break. It sits and sits and sits until I just give up. It’s getting there, but I have to play within these confines for now.


@AmnNate I did encounter the same problem as you did. that could be annoying =( I shall whip up the console and start investigating =)


Some times, few 3D models which download from Thingverse site have problem. I did face the slicing process that seem freeze; then I use the Windows 10 3D Builder to repair it then Flux Studio has no problem on slicing process. Here the object is repaired.


NetFabb Basic (executable program) or NetFabb Cloud (online tool) are the industry standards for repairing STL meshes. I haven’t been impressed with 3D builder’s facet cleanliness. I’d be curious to see the triangles of an object before and after.


Thanks fore the help. Does Windows 10 3D Builder tell you what was wrong with the model before it was repaired? Or is it just automatic? I’ve tried Netfabb on a couple things, but I’m still learning the modeling lingo to figure out which things are actually wrong. I also learned that the automatic repair can sometimes alter a model in unexpected ways that can eaither lead to different problems, or just change the model so it doesn’t look as you intended. For example, was the problem with the ring model that it had holes in the mesh? Incorrect manifolds? Incorrect normals? Duplicate vertexes? Also, did the file come out any different in size than the 85mb or so that it downloads as? Flux Studio was super slow for me on this model before, even trying to move the model or rotate it caused significant hangups. This is all on my mid-2014 Macbook Pro. It’s not exactly a weak machine, so I would expect better performance than this.

My latest example (and other complaint) has more to do with multiple files trying to be sliced at once. I made a wonder woman headband for my wife, but I really wanted to print all the parts at once after organizing them on the build plate. The software would just seemingly freeze when I tried to slice it with all the parts imported. It has no problem at all when I did them individually though. It also has no problem when there are multiple parts in a single stl file. It should be pretty similar, I would think. I don’t understand why it would have trouble with multiple individual models, but I’m still learning how all this works together.

The files can be found here:

Still, it would be nice to print several parts to make each print job as productive as possible. Also, having several parts can sometimes make each part turn out much better since each layer has more time to cool between layers. I’ve run into this issue a couple times with smaller parts where it would have been better had I printed 2 copies at once to increase layer time. I can’t seem to get the layer time setting to actually slow down enough. The small perimeter speed has been helpful though.


I rotated the part and it turned in Flux put when printing it was still in the starting position. Tried restarting Flux, the printer, and then both. And how do I start it again from when it is aborted?


Double clicks Flux button on a printer and check Flux status is idle in Device monitor on Flux Studio. If not, try it again.