Printer sent back but broken



After several months fighting with the Flux printer, we sent it back to Flux for them to fix lost of broken and not working parts.

Finally we have it back and the USB connections ar still broken, so we cant do anything with it (the wifi connection never worked).
The only thing they fixed looks a 3dprinted black part that is glued in the top USB-c cable connection. I think that the printer doesnt need to travel half the world for this small part.

Any one having the same bad experience with this machine and this comany?
We have more than 10 3D printers in the office and this is the MOST BAD printer.

Please any suggestions about how to be able to receive a goos dupport (not only the smae repeating email and forum answer saying that everything is wonderful)

Thanks in advance


So you joined 12 minutes ago, but have been having trouble with the printer for the last several months? I don’t know how you went the flux’s support team (who have been very slow at times) although I haven’t had any issues with them for the problems I’ve had.

How about you start from the start, and actually explain what problems you’ve had with the printer, and what you’ve tried to fix them or diagnose them? And the part they glued on to the top USB cable is not 3D printed AFAIK… it’s almost like lead or some other stone… very solid and heavy.

I sympathise with you for having issues… but you haven’t gotten off to a good start. We’re not saying that things are perfect… but I think most of us have had good experiences with Flux and their support.



Sorry but we’re really angry with this printer.
We sent it to Flux as there were several problems (lots of them in the support forum):

  • Wifi not working
  • USB middle connection down Broken
  • USB-C cable connectors moving (from printer to head in both parts)
  • Some othe minus problems

After more than 20 ideas from the Flux team (change the cable, check your wifi connection, print a 3D support part, etc) we send it back to flux for them to fix everything.
Finall y we have it back but:

  • Wifi desnt work (we have checked it with 4 computers and 3 different netwokis)
  • USB connection is missed.
  • USB-C is the only thing thats looks “fixed” by a black plastick part in the top (not sure if it will working as we had already tried something similar)
  • Our team is really pissed off with this machine.

Any idea of how to get a real solution from Flux?


Well, as a guy that had A TON of problems with my Flux, I’d advice you to first try here at the forum. 90% of all my issues were solved here. I had to send my machine back once too, but your problems I believe that can be solved here!

Starting by wifi: I’ve struggled at first to connect my machine too. Have you tryed using the notepad way? Creating a notepad on your pc with the commands, name of your connection and password and then plugging it into Flux? That’s the way that worked out for me at first. On their support page there’s a tutorial explaining how to do it.

What do you mean by USB connection missing? The port doesn’t work? How did you check that?

The USB-C issue has a long history of problems, mine had a lot of “toolhead not detected errors” (and still has), but with this 3D printed support, the problem have been reduced significantly!


It’s sounding like you really need to keep working with the flux support team, and potentially have the machine sent back if it is as faulty as it sounds to be.

WiFi, firstly it’s 2.4Ghz only, not 5Ghz, so keep that in mind if you have 5Ghz only networks. So you don’t see the “Flux Delta” access point for you to connect to to configure the Delta? Have at look at this guide on setting the WiFi up and this troubleshooting guide also. Make sure you read it through properly as sometimes it’s the silliiest of details or steps you miss and kick yourself afterwards for missing.

I’m not quite sure what your second is in relation to. If you mean the USB for the delta, unless you have the upgrade kit USB cable, the microUSB connection on the printer was only for configuring the wifi, and you may have needed to have drivers installed for it to work… although I seem to think that flux studio did install them itself.

If your third point is in regards to the USB-C toolhead cable being loose, then yes, the part at the top will stop that end from moving, but you probably still need something on the toolhead as well. There was a rubber mounting thingy that is supplied with the Delta+ and in the upgrade kit, and it helps hold the USB-C connector on the toolhead in place.


I’ll try the notepad option.
Anyway the USB IS BROKEN. The machine came like this at the start.
The WIFI is 2.4ghz and sometimes works. No we are able to start trying to print a smal figure. The upper motor that moves the PLA in the machine sounds like crazy and doesnt move well it, so the material is lost at more than 80% of the paths.
After this try, the wifi went out again. We have 5 other WIFI 3D printers working in the office.

Also, at this try, even with firmware and softwares upgraded, the machines stops sudenly after 10second, for at leat half a second, and the back again working. In some parts, it works 1 second, stops, and bacjka again 1 second for more than 20 times. It is a very very simple piece that we have printed thousand of times to check.

Now we have to wait again until the wifi decides that sun and moon are in the right position.


Ok, so lets focus on the other problems:

  • Wifi: If it already connected once, the machine have already registered the network on it. The problem must be somewhere else. Maybe too many connections on the router? You could try to change the connection protocols (WPA, etc) to see if it makes any difference. Obviously, there is a chance on being the wifi receiver from the machine, but this chance is so low that we need to try out other solutions first. Also reducing the number of devices connected at same time too would be a point of start.

  • Noise: As far as I can see, there are 2 first thoughts: the nozzle could be clogged. When the machine is printing and not failing, can you observe the plastic melted from the nozzle getting out in a constant way? The other option could be on the feeder mechanism. The spool is Flux’s or a third party (1.75mm, just in case…)? Make a try on removing filament and inserting again using Flux Studio, and let it roll a time to see if it pulls in a constant way.


I was about the say the same Alan: Noise makes me think the print head is blocked, or the filament loaded properly into the print head, and is jamming on one of the the two quick release joints. I’m wondering if the extruder is left in a semi-stalling state if the electronics shut down to protect the Delta until the error is fixed?

I would reload the filament manually by pressing down on the filament release and feeding the filament by hand, and making sure it goes down the PTFE tube, and fully into hte print head… not just to the top of it… you should be able to feel it go 1-2" further than the quick-release connector on the top of the print head. Then in flux studio, set the temperature of hte tool-head manually to 200c, let it warm up, and then see if you can push the PLA through the tool-head manually gently (again, release the extruder by pressing the lever down).

And what do you mean by USB is broken. Do you mean the USB socket for plugging in flash drives doesn’t work? You do realise that that will only print a correctly named file? And I repeat, the micro USB socket is only there for WiFi config… nothing more.


Hi, I think the wifi probably works on you machine, maybe you don’t know how to set it up, check this out: First time wifi setup

and this: Why am I having wifi connection issues still?
hope this helps!

psst: were better than the flux team


thx but not working

trying to do it with the cable but cant find too much instructions about the FLUXDeltaConnector.exe and Ethernet #X.

Any help?


It is difficult to help when you are not providing answers to what you have already been asked.

It appears you are back to attempting to make or use some sort of USB connection or Ethernet. ???

You have been asked what you are trying to do, which connectors you are using, and provided instructions a couple of times already about USB connections.

Unless you are using a Delta+ or a FULLY upgraded Delta with new cables that came with the upgrade kit, it is not possible to print directly via USB. The mini-USB is ONLY there for setup of WiFi. You can ONLY print from the USB port from a thumb drive/USB stick IF the file is properly named.

The FLUX Delta was designed to connect via WiFi. You are not the first user to have trouble connecting, it happens and it can be tricky, but it is resolvable. From what we are able to tell, you have managed to connect via WiFi.

We are trying to help you, but stay focused and let us. If you tell us it is printing but making noise, then we are going to help you with that. But then you are back to USB connections and ethernet?

Focus on WiFi. One computer only. Get it connected. Several links and methods already posted, the answers are there.

From there we can work on print quality and noise issues.



This is the reason why we finally had to send it to Flux company.
Anyway, when they send it thep roblems are the same.

The sound in the PLa entrance motor is really strange. Even with the original material from FLux, there were a lot of problems to have a continuos line of material. And the noise gets more and more loud.

As we mentiones before, we have a lot of 3D printers, and even desgined and build our own ones, but this looks like a motor problem for sure (it has been cleaned seveal times also)

We have the original one, with usb-ethernet-usb cable and also the small usb connection that never worked.

We have tried with the net and wifi complety empty, but sometimes it works, sometimes note (mostly).

It has worked with the Surface 4 pro, surface 3, Asus laptop, HP workstation and laptop, but not continuosly.
Thats why we sent it to Flux, but they send it back looking similar.

Sorry not answering all the suggestions, but we’ve tried everything that is in the forum and nothing works.

Flux looks like having more holidays than any company in the wold…


Well…try on scientific way: go eliminating all the options one by one ultil you find out the unknown problem!

I’d suggest opening the upper part of your machine and look directly at the feeding mechanism working to detect exactly where the noise comes from. There’s a chance on it being misaligned! Considering the clogging on toolhead is not the cause, of course. Using default parameters, try this on an easy to print piece, that don’t require too much retraction on filament.

In relation to WiFi I don’t have any more suggestions that have already been said. Maybe trying in another place / router. Bring Flux home or at a friend’s place to test it from 0.


Ok, before anyone else starts guessing… (I’m looking at you @aw1 as you tend to!) the USB to Ethernet that @JAMh is referring to is this one. I do remember some mention of it… I just can’t remember if it was available for purchase or had to be requested or something. I don’t fancy your chances of finding much out about it… I haven’t seem too many references to people using it.

It’s good that you’ve tried everything that is on the forum. You should be able to give us a list of all the things you’ve tried, so that we don’t re-cover the same ground then. Or, you could humour us, and see if we can get to the source of the problem, or you can use the Delta as a paperweight.

Assuming you don’t want a paperweight, regarding the extruder noise… what is happening with the filament… is the filament being pulled in, and then jumping back when the noise happens as if something slipped. Could you perhaps record a short clip of it in action, so we see/hear it for ourselves, as we’re more familiar with the Delta and all that?

Did you try what I asked you to try… a manual load of the filament, and heat up of the head to check the filament path and print head for clogs? Or are you stuck at actually trying to connect the printer in order to actually control it?

With respect to slow response… things certainly seem to have gone quiet in the last few weeks… but I don’t know if that was holidays or just busy getting stuff don.


At the risk of jumping into this fray… JAMh, I’m going to be flat out honest with you on a couple of things right off the bat (consider these disclaimers) oh… And this will be long. And there will not be a tldr I don’t believe in them. Sorry.:

  1. I can not help you with your printer woes. Don’t have mine yet. Not even going to try. That’s not why I’m jumping in here, if you are willing to listen though I do have some advice on moving forward - provided a couple of the other disclaimers here are heeded. Because you may be “pushing away” the people you seem to want help from.

  2. Accept right now that you may have to send the printer back. Exhaust all other options first, but accept that it IS an option. You may not like any of your choices in life but that doesn’t mean you don’t have them. If you accept that fact first, it makes it easier to deal with if you end up with your “as a last resort” option in the end.

  3. I’m going to “call things the way I see them”. What that means is the following - the entire extent of the information I or anyone else have to make a judgement call for you or about you is what is here in this thread. Because that is the entire extent of the information available to us. And we are all “random strangers on the internet” (see point 4). So a lot of what I’m about to say will be flat out blunt. You may think it’s rude. It may even be rude - but none of us are psychic. So if that may bother you I’d recommend reading no further and just keep trying your luck.

  4. We are all pretty much here because we want to be. Booze, Jim , Patrick and the rest aren’t paid help. They aren’t here to make your life better. They are here because they want to be, they see some value in being here. And right now they are being very patient. I’ve seen so many people over the years fail to achieve their goals in groups like this because they don’t understand the culture they are walking into and they end up “offending the natives” and then “blaming the natives” for not treating them like special little snowflakes (and yes, forums on the internet exhibit culture that are unique to them, there are computer scientists who spend their entire careers studying the phenomenon, I’ve had the privilege of learning from some of them who I greatly respect). Please don’t make this mistake.

Because you don’t actually have any real effect on any of our lives so getting upset with us is more likely to make people just ignore you which isn’t going to help you. It’s a harsh reality, but it is reality. We can all just log off.

  1. It is clear you are frustrated. No one here misunderstands that. And no one is mitigating the fact, and in fact from what I can tell - everyone can both sympathize and empathize with that fact, however that fact is currently irrelevant to your current started goal which is “to make it work”. If your actual goal is in fact to “somehow get validation” that you are “right” and Flux is “wrong”. I’d recommend looking elsewhere - this isn’t really the proper venue for that and you aren’t likely to succeed.

And by now (if you’ve gotten this far) you are going “who the heck is this {word that rhymes with hitch}”. Newish member of this forum - however I joined up the second I hit preorder and having been a lurker of this forum since the kickstarter of the original because I watched that campaign but wasn’t ready to make the leap at the time - and just as I got ready they discontinued the original to focus on V2 - so then I patiently stalked every tid bit of news I could get on that for awhile until I was finally able to preorder and mine should be here this month and I suspect I’ll spend the next year asking these amazing people for help over and over.

I will answer one of your questions though - I have dealt with support already even though I don’t have the printer. Because I kind of broke their website when attempting to preorder (oops). And we tried for days to find different ways to pay them but the website was having nothing to do with it. Support and the people on this forum were terrific in both helping and keeping me company while we waiting for coordination from the proper team at Flux to get my money half around the world where I wanted it to go. So in answer to one of your original questions - no I haven’t had the same “bad experience with this company”.

I’m a computer scientists and project manager in Canada. I have a comp sci degree and an English degree and enough art and art history credits to have a fine arts degree if for some reason I ever had so much money and no new toys to buy that I lost my mind and wanted to pay the University more money for no particular reason. Why? Because it means I can converse with clients easily and come back and have an equally engaging conversation with my devs, sys ops, and visual designers - and everyone is on the same page so I know a bit about communication break down.

Why is any of this relevant to your immediate issue? Because now you have some reference to who you are talking to.

So let’s start over - hi I’m Alicia. And you are? What is your technical background? What does your team actually do (seriously I’d love if my company had that many printers kicking around in an office! As it is my CEO had threatened to just borrow mine when it gets here…)? What kind of “shop” are you (windows, Mac, Linux, Android, “yes”/aka all of the above)? What is your position with this company?

This will help people help you. Just trust me. Otherwise there are too many assumptions floating around here and the air is getting thick with them.

Next I know you feel you have “tried everything on the forums” but we have no basis for that assumption. So as painful as it is - please please help us get on the same page as you. List them. Walk us through your aggrevation. It seems weird and annoying to do so - but it will achieve two things. Anyone who isn’t already empathizing with you will likely find a commonality they can relate to (it’s 3d printing - things go wrong! We know this), and someone may see something that went squirrely that others missed and throw out a suggestion you haven’t tried. You have a lot of willing extra eyes here. Don’t blind then needlessly.

It’s a forum - things get cluttered, they get lost or they never get posted because not everyone always mentions every thing they’ve ever done unless asked a direct question (it’s not Instagram after all…).

Next. Because I tell stories… Story time. A rather large company here in Canada has a tech support form that has a rather odd question on there. I know because I have a relation who works in this company and they phoned me one day to help them “answer their stupid ITs stupid form” (because “I’m good with computers right?!”). The question reads as follows: “tell me how I can help you today, don’t tell me how to fix it”.

My relations complaint was “you can help me by fixing it”.

I told them I was going to ignore the form for a moment and ask them some questions.

Question one: what did you do - in exact details - walk me through the whole thought process, every step so that I on the other end of the phone 1500 km away from you can “see it” in my mind’s eye and feel like I’m there. What were your “inputs”?

Question two: what happened? What was the direct results (in exact details) that the computer then output to your inputs?

Question three: how (in exact details) did the outputs in question two different from the outputs you expected?

After they answered all three questions I said - write exactly what you just told me to all three questions in your “stupid form”.

They phoned me back two days later and told me their IT fixed their problem perfectly, thank you!

It was a stupid form, the question was stupidly phrased for the result IT wanted, but the form was written to solve a problem. The problem was "to many people are telling us “how” to fix something without telling us “why” they want it fixed that way or “what the actual goal is” so we spend to much time fixing the wrong problem… And they built a form that also solved the wrong problem.

Go figure.

So now that story time is over - pick one of your problems and answer the three questions. If you tried 41 different solutions, give us the three questions for all 41 different solutions. Put us in your shoes so we can try and help. Otherwise we’re throwing darts into the dark and just hoping there is both a wall and a dart board over there to actually hit.


We have tried 14 differents wifi conections with more than 10 computers


Have you ever been trying on testing your Flux printer in other setting environment such as at home?


@JAMh We totally understand that you’re very frustrated at the moment, and we regret to hear that your company is still having trouble using your FLUX Delta. An 8-hour printing test is required in our RMA process to make sure that everything is functioning before sending the machine back to users. Theoretically you should be able to connect to the machine via Wi-Fi like our repair team did, however, when it comes to Wi-Fi connection, it can be really tricky sometimes. Please work with our support staff in our help center, we will do our best to figure out the problem and get your printer working.

To everyone who helps out, you guys are absolutely amazing! The team is working very hard to improve our product and service, thank you sooo much for your continuous support. :heart_eyes: :heart_eyes: :heart_eyes:


The problems started 11 months ago.
The first id error is 3592 and the last has the number 20792.
18 requests detailing all the errors in the Flux Help Center.
Finally you asked us to send the printer to you and closed all the request bu yourself.
You returned it but it still has the same problems.

The last unutil response is:
“W will send you an USB cable so you can build wired connection and wireless connection.”
Can you detail it more, please?

I do it here because the responses in the Flux Help Center are similar to:
“This request was closed and merged into request #…”

Thanks in advance.


Yes, the latest reply was ticket #19931 regarding the USB cable.
We tend to keep the tickets simple so we can discuss the issues efficiently and not spamming you with emails. Sorry for the confusion.
Please provide more information by replying to ticket #19931, thank you!