One year anniversary of my Flux-Delta and I get Error #164 : UPDATED


I guess every good thing comes to an end sometime!

I was printing daily until today and suddenly the machine decided to send me #164 errors, which means “abnormal temperature detected” according the code and it has nothing to do with the printhead since I get the same error also with a brand new spare head. The printer responds to Movement commands but not to Temperature commands. I opened a ticket, waiting for the response.

UPDATE: After some discussions with Flux Support, they mentioned that the cause of the problem could be the USB-C cable connection to the toolhead. I tried my other toolheads, Laser tool, my spare 3D-printer head but none worked. Each time I unplugged and re-plugged the USB-C cable many times, turning it around, twisting etc but nothing helped. Finally, I ordered locally 2 cables from different places but they did not work either. After all that, I was desperate and ready to disassemble the PCBs to send them back for repair, as suggested by Flux Support. In a last-ditch effort before disassembly, I tried the original USB-C cable again, the one giving me the #164 errors and this time, suddenly, no more errors, no more #164 !!! The toolhead started to respond to Temperature commands and it started printing. I probably plugged and unplugged that cable over 20 times and it only started to work after I tried the locally bought cables, which did not work at all. I am happy my Flux Delta is back to life!