Issues after not using FLUX for awhile


I recently came back after not using my FLUX Delta (the original, not +) for some time, and I have a few problems so far.
The calibration chart in the advanced engraving menu doesn’t load, and I have no idea what to do.
When I try and load an image for the engraver, the image preview shows up, but nothing happens when I click start.
Another issue, so far, is that whenever I try and import svg. files for the drawing head, it goes into a perpetual loading, and doesn’t even get to the preview.

Any help would be greatly appreciated, and I’ll post more questions as they occur.
Thank you


Try importing a bitmap file (jpeg, png, etc…) for engraving and see if that works. From my experience, if the vector svg file has too many nodes or is too complicated, the software can’t handle it. Decide if you want to do scores or engraves… I know that engraves take longer, but if it’s a matter of the file working or not working, you have to take that into consideration. :wink:


Snap, also just resuming after a long hiatus.

Did a couple of successful test prints yesterday, but haven’t tried the engraving yet.
Did you upgrade the Delta and Toolhead firmwares to the latest versions?
I found I had to do the Delta firmware update via USB as I just couldn’t get the Flux Studio to authenticate with my Flux for the wifi based upgrade process.

What version of the Flux Studio are you using? I have elected to remain on v0.7.8 as a cursory examination of the forums seems to indicate that to be the most stable version. I tried the v0.9.x series, but it couldn’t see my Flux and rolling back to v0.7.8 identified it flawlessly.

When I have some more time, I think I’ll give the v0.9.x series another go.


I’ll try that when I have some time and post the results. Thanks for the info.


I updated everything to the most recent version but I haven’t tried printing yet. I have the feeling that something will go wrong there, but I’ll try it and post the results when I have a chance. Thanks for the help.


Don’t worry, I was equally apprehensive, but I experienced no problems
However, I did do a full re-lube of all the ball ends and cartridge uprights as a precautionary measure before starting since the machine had stood so long unused and some of the previous lube had hardened slightly.