Flux Version 9.11 posted


I just noticed a new version of Flux, 9.8 I’m at work so cant try it now, there are no notes in the blog about it.

Wanted to let the community know.



They removed it, it is now gone…


The file still exists on AWS.


It has some bugs…delete

  • Dragging in gcode, hit start, but don’t start… gcode visual representation disappears, settings remain grayed out, need to refresh the app.


There’s also now a Flux Studio 0.9.9 up on AWS.


Flux 9.9 now on the downloads page, I’m downloading. Here are the notes from the blog:

  1. Added layer repeat option for Beambox
  2. Text edit feature for Beambox
  3. Clear preview mode button for Beambox
  4. Logging into FLUX Cloud will improve connection stability now. FLUX Studio automatically syncs the local IP address of FLUX Delta (Firmware 1.6.88+) with cloud.
  5. Fixed memory over-allocation on Windows X86.
  6. Fixed machine configuration in File > Preferences.
  7. Fixed importing GCode to printing interface.
  8. Fixed engraving, drawing and cutting feature for Delta series.


I printed yesterday, and had no issues. I did not have the corrupted file error, yesterday, so hopefully that bug was squished.


Are you able to scale objects with version 9.9 I am trying to type in 20% and nothing happens. I hit enter/tab and it just takes me to next X,Y,Z field.



I just tried that as well,

scaling is not working



– Force convert text to path when parsing fcode
– Set Beambox as default machine if user setup one
– Preview mode picture mistaken
– Wifi setup complete page



Scaling does not work in 9.10 as well


9.11 posted, have not tried as of yet. Will this evening. I’m hoping the scaling problem is solved.


Manually entering numbers to change the scaling still does not work in 9.11


Also wasn’t there a slider for the preview to step through the layers? I do not see that now, so do not know how to step though the layers.


So… I should stay with .8 if I want to maintain scaling?


I would, until they fix it.


Yeah, the slider is missing in 9.9, 9.10, and 9.11.


Thank you, I was looking at it, wondering how the hect do you step through the layers. :slight_smile:


I created a support ticket for the three issue I know

  1. Scaling issue
  2. Slider for previewing not there
  3. Still get CRC errors with this version when sending files to printer.


This post was flagged by the community and is temporarily hidden.