FLUX Studio v0.3.10, Delta Firmware 1.1.7 Released


#1

FLUX Studio 0.3.10 Changelog

New Feature

  • Laser load image size with default dpi in laser mode for displaying correct size

Changes

  • will still allow firmware upload after warning that the device has the newest firmware.
  • Print out of bound object will not be sliced / preview
  • Print Cura is now included in Flux Studio, path to Cura is set to default path (no need to set Cura path, hooray!)
  • Print support .obj file type

Bug Fixes

  • Scan stuck at second point cloud export
  • Scan fix undo in edit menu
  • Print corrupt .stl file that cause program crash
  • Print un-supported file type will cause program hang at drag and drop
  • other minor bug fixes

Other Improvements

  • Device when authenticate successfully with device, touch connection will be closed (reduce traffic)
  • Device display version when updating head firmware
  • Device double check on missing head tool

[Download Link] (https://flux3dp.com/downloads)


#5

Thanks for posting this change log…it really helps to understand what to expect from the new release.


#6

A quick note, the download link appears to be for 0.3.0 but the build number is higher than 0.3.9, so it’s likely that it’s correct download and incorrect text on the web site for the download.


#7

Link sends me to the download page correctly. You need to see “FLUX Studio - Latest” for 0.3.10


#8

I was wrong on so many counts. Thanks for the clarification. I’m going to have to get my eyes examined and maybe an MRI to see if there’s anything between my ears!


#9

Just got some new :eyeglasses: myself… LOL


#10

I have installed it, and printed, so far so good. I’m doing a longer print-run right now. We still need the log of job hours, so that we can know when to do maintenance!! @Simon


#11

@Simon and @Jim
The error is popped up on every Flux Studio version. I submit request for fix with error log and … it’s still there.


#12

mind if you let me know the steps to reproduce this error? I’ll take a look


#13

If you uninstall cura and install the new version which installs with a different directory name, flus studio doe snot use cura engine. The latest cura is 15.04.06, so the directory name would be the same. I removed Cura, installed old version then installed the new version into the .5 directory and it worked… I think we will still need the directory option if we want to install newer versions into directory with version names that make sense.


#14

It’s randomly. One of example on the screen capture above, I prepared upload a gcode file to SD folder and error message popped up. Sometimes after the PC woke up from sleep and printing task is completed and the error pop up. I already submit the bug report logs on help desk web site.


#15

I just have had the same thing happen. Printing a storage box, and in the middle of the printjob, the print hard stopped, and had the same error.


#16
  1. Start to print from gcode and shown no printing status.

2, Closed a dialog box; opened it from device monitor and it was OK.


#18

@proclaim
I received the Flux printer since Feb 22. It’s working fine and several add-on items on it like a glass plate and holders, spool holder, and USB-C strain relief.

Yesterday I have my best setting on Simplify3D for Flux and Flux printer has shown its performance on the test models.


One of the important factor on the 3D printing is a slicer, I already have Simplify3D. It works great.

Worst of all Flux Studio is nightmare to deal with “Uh-Oh” message. As you know, we can’t print without Flux Studio interface. I can save gcode file to USB flash drive and print manually. That’s only way that I can use Flux printer to printer.
Software team, please working on the CRITIAL bugs that I already submit on your help desk like:
1, “UH-OH” Application handled error.
2. “UH-OH” Device Disconnect.
3. The current task on the printer embedded software is never clear after receiving abort/stop command from a user. I have to switch tasks to Scan, wait until a camera is on, and go back to print task.
Problem 1 and 2, I usually reload the app to clear the error. “UH-OH” is need to be gone on Flux Studio.


#19

Upgraded from 0.3.7 to 0.3.10 running under Windows 8.1 and Flux Firmware 1.1.7

Scenario 1

  1. Powered on evering new (PC and Flux)
  2. loaded S3D sliced file (gcode) to Dashboard.
  3. Printed it - fine (was missing rest print time)
  4. got “completed window”
  5. clicked to “folder Button” and got the UhOh Appplication error
  6. Closed the PopUp Window vie the “X”
  7. Going back to devices/FluxName/Dashboard I still get the “completed” picture
  8. Reloading the same file again from dashboard brings the “completed” picture again but the start button is greyed out.
  9. Importing the GCode File ends also in a “Completed Message”

Scenario 2

  1. Powered on evering new (PC and Flux)
  2. Imported S3D sliced file (gcode) direct and all good.
  3. Klicking Start and the Uh-Oh unhadled Application Error shows up.
  4. Immediate loading from Dashboard works and Flux starts heating.
  5. Stopped after warming up (Screen shows aborted)
  6. Loaded file from Dashboard, and again Start Button greyed out.

Everything is reproducable.

0.3.0 was (and is) the stablest version right now, none of the above accured.

What I still do not understand - as I have a broken USB connector (used USB to get in touch agein) and Flux SW gives me the option to set Flux on a permanent IP Adress
(File/Preferences) which is set, but on Device Info it shows one out of my DHCP Pool ?


#20

To switch status from "Completed"to “Idle” just doubleclick the Flux button on the machine, this is new since 3.10

I only have UhOh messeages when my computer comes back from power save.


#21

That’s good working around the FS bug tip. Thanks.
@proclaim
This is a bug on all Flux Studio version. We need to force to close the current complete/abort task is still running on Flux embedded software by cancelling task on the printer or switching to scan mode on Flux Studio.


#22

Hey thanks for the tip…I was getting around this by unplugging and then replugging. This is much faster.


#23

I bought the remote power switch that is much easier than unplugging and pluging a power plug.


#24

I bought this from ebay, and love it