FLUX Studio 0.8.1 Change log


FLUX Studio 0.8.1 Change log

Bug Fixes

  • Fixed continuous alert messages when USB cable connection is abnormally closed
  • Fixed support on/off not properly set, or affected by other factors
  • Fixed dashboard stays in idle mode with all buttons disabled when error encountered
  • Fixed possible error when retrieving slice result (command sent before slice is complete)

Known Issue

  • Several users reports CRC32 error when printing. This is caused by nwjs and we’re currently investigating and finding solutions. Most of the time, users should be able to resume printing by clicking start again

Delta Firmware 1.6.58 Change log

thanks for killing the support on bug, i got unremovable supports everywhere.



has the autolevel level issue fixed in the meantime - I am still using 0.4 Z offset when sending S3D gcode to the printer (with using Lokbuild on the metal plate)?




I looks like this has been fixed, just printing a test cube with no Z offset (S3D gcode) on the Magnetic Plate - gcode uploaded to flux - jist in the middle of the print, but looks very good so far


I have frequently the errors.


I also had a FILE_BROKEN… error with 3DBenchy but 2nd time restarting FS cured it.


the FILE_BROKEN problem was the CRC32 error that I mentioned (known error), we’re still trying our best to provide a solution, which was related to nwjs.

to fix it, just press “start” again.


@proclaim I started getting those “tilt error” magnetic rod disconnected messages again. Not sure if it is something in 0.8.0 or firmware.

Nothing is disconnected, and it is usually right at the start of a print. The toolhead goes straight to the front position (like load filament position) and waits. Clicking Retry and then it’s fine.

At first I thought it was just a one-off, but it’s happened about a dozen times now.

I’m going to upgrade to 0.8.1 so will see if it goes away.

SO glad you fixed the Support On and Slice API errors :thumbsup:


Saving a click or two…


the tilt error that you mentioned, also the “toolhead goes straight to the front position”, is this in 0.8.1 + 1.6.58?
in what stage is this happening?

  1. right after you clicked “start”
  2. after temperature reach 170
  3. before calibration
  4. after calibration
    5 other


Yes, 0.8.1 & 1.6.58

  1. right after you clicked “start”

Every time it happens, it’s always right from the beginning.

It has not happened at all since I changed to @mc_ott Cura2 settings though, which did include modifiying gcode start commands, so there might be something in there that was triggering this error?

I can put original gcode back and test for a bit or you guys can take a look and see what you think.


Couple of bugs using Winx64 FS0.8.1, FW1.6.58

  1. There is still a “Support bug”. If you switch from CURA2 to Slic3r then Supports turns ON. But more interestingly, if you switch back to CURA2 then the Supports status turns to OFF but the sliced preview still shows that Supports are still ON.

  2. The IOS app connects to the printer while it’s “idle” and continues to be connected once a print starts but while printing, if I close the app and then re-open it, the app says I have “no machine connected” until I stop the print. Then I can connect again.


I also have all bugs :ant: above too.


@BoozeKashi, in my setting I have the “detect_head_tilt = 0”, 7 lines before the end, set to “not detect the tilts”. I guess I forgot to mention that before, sorry! I set it to 0 because since the last 2 or 3 versions, I was getting random Tilt-Detect errors which were driving me crazy.


Thanks @mc_ott, yes, I just checked, following your list I switched it off too and have not had that error since.

@Proclaim, I was getting the error immediately after clicking Start. FLUX Studio would process and upload, then the toolhead would start to lower as if it were starting, but then move straight to forward position and FLUX Studio would pop up the error.

By turning off tilt detection it has not done it again, so that is where the issue is. This is with 0.8.1 FS and 1.6.58 fw, toolhead updated to 1.6.18 also.

Unlike the random tilt error from a few versions back that would happen at anytime, this one IS happening right at the start, clicking Retry made it continue as normal and I never got another tilt error during a print.


@proclaim, for your records, I started getting the Tilt errors I think with FS v0.78 or the one after it and the corresponding firmware, can’t remember the version. They were happening at random and usually after doing 200-300 layers, mid-print. After hitting Continue, it would go again a number of layers and stop with the same error. This happened for almost every print 50mm and taller. I switched the Tilt detection after 3 prints and have it off since then.


what version of toolhead firmware are you using? (NOT the FLUX firmware)


also are you using imported Gcode?

here’s a possible cause: at that height you travel, if the temperature is too cold, or somehow twisted, the head might be hitting the print and causing the tilt error. try adjusting the travel height and give it a try.

or maybe try using an older version of firmware


@proclaim: I always update the toolhead firmware as soon as they are released, now it is 1.2.18. I don’t use imported gcode, I use Cura or Cura2 engine, I am very happy with their results. Also, it showed the error with different prints. I was paying attention to the print a couple of the times and it happened without hitting anything at random, which made me think maybe the sensor was going funny. Since then, I had tilt-detect switched off (about 8-10 days ago) but I will switch it back on tomorrow, to see if the error still occurs at random.


it kept on giving me the same error so I turned off error detection!


There is an error in the error detection? Surely not… just worry when there is an error in turning off errror dection… then we know skynet is upon us! :laughing: :laughing: