FLUX Studio 0.7.7 Change Log


#FLUX Studio 0.7.7 Change Log

  • Fix scan issue related to upgrade-kit



Have a low res scan in progress to test this, but there is something resembling the ornament I am scanning, so I have to say that it looks like you squashed the bug! :wink: I had trouble getting the printer to calibrate, but that could be user error… have to try again. It does also help if you have the scanner heads up when you try to calibrate… just in case anyone else was wondering! :blush: :angel:

Edit: Ok, after calibrating properly (probably for the first time ever… this dufus never read the instructions properly, and didn’t realise the notch in the bed is for a small tongue sticking out of the ‘bottom’ of the calibration plate… he always set it on the bed thinking it had it’s own stand!!)… A draft res scan completed well, and gave some interesting results. A normal scan was reasonably, and I’m now running a ‘best res’ scan for giggles :wink: All working well so far. I really like how the preview(?) actually looks like the model… even including colour… but the conversion output of the draft left much to be desired! :stuck_out_tongue:

Not bad considering lighting and draft resolution… I can actually see the rabbit holding the cake :wink:

But what is this mess? :stuck_out_tongue: :laughing:


Link to download page for convenience.



:stuck_out_tongue: That’s a nice scan for a “startup”


It’s a nice scan for draft mode… that’s what it is! :wink: The fact that it even resembles the object in any fashion is itself an achievement. I think that mode is simply to give you an idea of how well the object will be imported based on current configuration and lighting… it gets a lot better when you go into normal mode, and from what I’m seeing of the best mode (there’s 5 quality levels if IIRC - can’t see that menu when it’s scanning), it will be very accurate. This is without any special lighting or backdrop.


You inspired me to give it another try.


Could not calibrate. It seems the camera overheats after about 15 seconds.

So I said the heck with it, scan anyway. Go for the Full Monty, High Res. 30 Minutes. I can wait. 19 minutes in, it was actually looking half-arsed decent in preview, and then the turntable started binding up and popping. 6 little steps forward. BANG. a big step back. Erring on the side of caution I shut it down. Perhaps something misaligned from the laser pole fix way back when, so better not to force it.

I’ll try again after the upgrade kit is installed.

I would normally be a bit concerned about the inability to calibrate, but since the camera will be getting replaced too, we will see what happens there.

I will say, out of the 3 scanners I have, FLUX was the big letdown, but maybe that will improve after upgrading and I figure out whatever is binding the turntable.

Post your results though. And some time in Meshmixer is completely normal for ANY scanner so no harm no foul with that.


Eek! Doesn’t sound good.

I had problems trying to get it to calibrate until I turned a light on… it looks like there was too much background light where the printer is located, and needed some light behind the camera, and it calibrated instantly.

I didn’t get any popping or issues from the scanning, and no issues with rotation as it was able to do a full draft and normal scan, but the high quality scan gave me a black screen on flux studio and I don’t think the scan finished. Then again, I was doing other stuff on the machine, and think I crashed a few things whilst I was at it, so might have fubared flux studio also… or maybe it broke! :open_mouth:


During calibration, camera definitely froze. Kind of strange, it started working the first couple times when I was just playing with it, then when I decided to actually go ahead and let it run, that’s when it stopped working.

The HQ scan it was building was surprisingly looking pretty good at about 3/4 completion with a single backlight behind camera. My Delta is in a nook on 3 sides surrounded by white/off-white so that probably helps too. It might have done quite okay but after the turntable popped the second time I stopped it. The first time I heard it but was not looking, so then I started to watch and sure enough, about 6-8 micro steps and the POP. about a a .5cm jump backward. That’s all I needed to see to know something is in a bind and not right. Since the base has been opened a couple times to replace laser poles and boards it is possible (though not likely) a wire is in the wrong place. I say not likely because there are only a couple wires that go that far and it would be very hard for them to get that far out of place. I have not had time to open it up yet (Songkran Festival here! Woo hoo!), but I suspect it may just be bits of old filament that have worked there way down into the mechanism.

In any case, I will post back with my findings, and maybe with should move these posts over to the Scanner section for future reference.


Well, I updated my linux (Ubuntu Mate 16.10) Flux Studio install to 0.7.7, and it don’t wanna play scanner. I haven’t used the scan feature on linux in ages (if ever)… but just gave me a an uh-oh error, and calibrated the printer home/origin and that was it. Tried several times, nothing happened. Tried deleting and ‘reinstalling’, nothing happened. One or time times it did several printer homes in a row but still nothing happened. Back to the windows version…