FLUX Studio 0.7.4 Change Log


FLUX Studio 0.7.4 Change Log

Bug Fixes

  • Fixed: Import button malfunctioning in laser interface / draw interface
  • Fixed: Message display of “Machine Commands / Run Auto Leveling”
  • Fixed: Message display of “Machine Commands / Run Auto Leveling with Clean Data”
  • Fixed: Dialog infinity loop when using “Machine Commands / Turn on Scanning Laser”
  • Fixed: Not displaying dashboard when establishing first connection to machines without password
  • Fixed: Default machine / Tutorial won’t force you to connect with FLUX USB Cable.
  • Fixed: Message display of failing to connect specific SSID
  • Fixed: Assigning default support pattern / infill pattern when switching slicing engine


  • Slic3r / Cura / Cura2 default parameters



Is the Delta Firmware 1.6.25 safe to install as well?


Seems fine I did the update and it still works. Trying a small print now.

@Proclaim Whats up with the new print start routine? The head now moves in circles at the very beginning, then heats up and does the calibration. Why the circular motion?

Mmmhh interesting is that new or a Cura v2 feature…

edit: Well it does the priming circle in both cura versions
The tilt errors are still there using the latest toolhead firmware.


@Tiwaz the circular motion is for movement test, to make sure the ball joints are well connected ( and lubricated ).
@Matfink I’ve been using it for more than a week now. Sorry to make you scared… ( I’ll make sure it’s not a horror story =P )




I uploaded the new firmware - strange behavior when flashing . All is fine, and it worked. When flashing the orange light which usually stays on when flashing new firmware, was blinking between white and orange. Usually I have a steady orange light. Then after a few moments, went to white, withe a corner that had a orange light. Did not know if you guys changed anything.

I like the new firmware. The calibration seems to go faster…


A few items that I’ve noticed with Windows x64 version of FS0.7.4:

  • The Ctrl+D to duplicate an item imported does not work - I have to keep using the ‘Edit’ menu to select duplicate
  • If you scale one item that was imported (for example enlarge it from 100% to 110%) and then you duplicate it, the duplicated item shows it to be 100% while the original item shows 110% when you select them. I’m guessing this isn’t a problem since the duplicated item is 100% of it’s original size where the original one was the one you scaled. Something to note for folks.


@proclaim Is FLUX Studio 0.7.4 or Firmware 1.6.25 going to address or counteract the tilt/magnetic detach issues we are having with Toolhead firmware 1.2.13 ?

Several of us have had to roll back to earlier versions or disable the tilt sensor because of excessive false positives.


Quick and fast responses are on the latest updates. I feel my one year old printer like new :+1::smiley:. Kudo Flux team.


What do you mean? Just general movement is faster?


For me it’s optimized routines before printing. Secondly, I change back to tool head firmware 1.2.13 and so far it’s no tool head tilt error…


@Mattman thanks for reporting, I’ll check on that
@BoozeKashi I believe these’s something interesting going on after talking with the firmware co-worker. I think it’s better to use toolhead 1.2.10 for now


@goldensnake Okay, I understand now, I look forward to the upgrade then.

@proclaim Yes, ‘interesting’ is a very polite way of phrasing it. The last print I did with 1.2.13 was a small 1-hour model and it stopped 5 times during that print. I have rolled back to 1.2.10 and the errors have completely stopped.

I tried to watch for any kind of sequence or pattern that triggered it, and nothing I could see for sure, maybe movements toward the outer edges of the build plate but I could not verify that.


Not only you guys, we’ve also experience tilt as well. A new toolhead firmware has been in work (before 1.2.13) and it should also include more parameter adjustment to prevent this problem. Sorry for the trouble guys~


@proclaim, last night I was printing “1950s_spaceship_v1_gcreate_logo.STL”, which is about 200mm tall, and I started getting many “Tilt detected errors”. In all cases there was nothing wrong, when I hit continue, it continued printing until the next error. I noticed the errors started at about 100mm high and where the x-y diameter was 100mm. I had about 10 stops until 80% done (where print body gets narrower) then continued without any error.

I did not notice any toolhead errors when printing smaller volume objects, even now.

I also have latest FS and FM v1.2.13.


I can’t get 7.4 to upload. Is the problem the unsigned drivers I’ve been reading about?


Which OS are you using?



  1. macOS Every time you go into Advanced Settings and exit back out, regardless of whether you made any changes or not, the status indicator for support changes to ‘ON’ I don’t know if this happens on other OS’

  2. Unable to upload gcode files larger than 10mb directly to SD card. FLUX Studio stays at Processing 0% for a very long time, then sometimes moves a little and then freezes around 30%. I gave up waiting after an hour. Other times it stays at 0% and never moves. I have checked for network activity with a Network Monitor, and it is not doing anything, no data being sent to the printer.


I noticed if I choose Cura2 slicing engine and set Skirt to On, automatically the Support is set to ON. This does not happen with the other engines whic is the way it should be.
@proclaim, I think this is a Bug, the Skirt ON setting in Cura2 should be Uncoupled from General Support. Most of the time, I want a skirt to prime the nozzle but not other general supports.


I agree. It strange behavior how Support On just flips itself on all by itself like that.

@proclaim @Wei-Zhong The other issue I mentioned with 0.7.4 and uploading to the SD card is definitely a bug. I have found that it is just FLUX Studio that is not updating status. Generally anything over 10-15Mb. It just stays on processing at some point, but if you wait long enough the file actually does upload.

I just waited about 30 minutes, then exited from the memory card and reopened it. The fcode file was there and I was able to start and complete the print even though FS never said it had finished processing.