FLUX Studio 0.7.3 Changelog + Toolhead Frimware 1.2.13


I have a similar problem when it’s homing before starting a print. What i do is that pushing down the linear actuators with a distance from home position then titling error is gone when it’s home. @proclaim you should look into the issue since other users also has the problem. I’m sure recently update that has to do with it.



this one was when it did the homing at the end of the print.

I would like to add it did not actually do any tilt errors while printing but I only have been doing small tests at the moment.


I am using slicer and having no z-offset setting that is accepted.


Different scenarios it’s same problem when homing in my opinion.


After coming back from work, the print was stopped with same tilt head problem… Any idea @proclaim


I also had tilt head issue, so is good to know that is not just my printer


On both Windows and Mac, I no longer can import a .svg (for laser engraving). When I try to do so, a spinner starts spinning and never stops.


I roll back to tool head version 1.2.7 and test it. I will give an update.


I now have the same problem with Z offset not working in FS 0.7.3 !
Having said previously that I did not need to use an offset now with FS 0.7.X , suddenly my calibration has gone crap again for no apparent reason. I have reloaded FS 0.6.3 and FS 0.7.1 and in both I still have the same poor calibration but I can offset the result by -.15 to fix it. But in FS 0.7.3 I cannot offset it so now I cannot use FS 0.7.3.!

I have tried the “Run auto leveling with clean data” but there are two problems with this>

  1. I have the problem in FS 0.7.X that items in my “Machines” menu do not respond so I have managed to get it to work only once in FS 0.7.3 after many many many many tries but it made no difference.
  2. When the “Run auto leveling with clean data” does run in FS 0.6.3, FS 0.7.1 and FS 0.7.3, it is useless because the machine does not “home” before the auto leveling sequence so the axis start below the home position at a random point causing either the head to crash into the bed (very hard if you start with the head half way down) or it causes an “Uh-Oh” error presumably because the new calibration result is too far away from an expected value.

I have wasted an evening wondering why my prints were failing and now most of this afternoon *ucking about trying to get a decent calibration and I am really annoyed by the fact that Flux have put a command in the menu that will crash my machine hard!


I’m testing with 1.2.7 tool head firmware and no more tilt head error during printing.


Z0 issue: In v.073, if you choose Cura2, there are 2 entry lines in Expert settings for Z0_offset. One a at the end of the parameter list and one about 15 lines above that. Did you set both to your Z0 value?


I have been getting a lot of the Toolhead Tilt or Magnetic Rod disconnected issues recently too.

I never got them before, I did not even know that was a thing. Now I get that error about 1 on every print on average, sometimes 2 times on larger models.

I rolled FLUX Studio back to 0.6.2 so I don’t think it is related to 0.7.3 FLUX Studio, but quite possibly the Toolhead Firmware update 1.2.13

I do not know if it is even possible to roll-back tool head firmware, so I do not know how to check that.

Anyone else seeing Tilts or Mag disconnects after Firmware update?


Nice catch! I hope that fixes the problems for Matfink & Haggard

I’ll cc on the FB post.


Oops, just saw your post after I responded to @Tiwaz

So how do you rollback the Toolhead firmware?

It’s getting annoying. Can’t leave a print without babysitting it because it’s going to just stop for no reason at random times.


I will upload the 1.2.7 tonight if you need it.


I deliberately avoided using cura in case it was an issue with that. I used Slic3r.
I might try Cura2 tomorrow. Some Cider and a bit of TV are my fix at the moment.

Oh and by the way, I haven’t been able to do the toolhead update beyond 1.2.7 and I haven’t had any tilt errors either and I’ve printed a 210cm tall Eiffel Tower, a big black crow and a rabbit face on FS 0.7.3 before the calibration changed.


I did not try Cura2 either and in all honesty I don’t see what improvement it will bring to Cura. I am quite happy with Cura for my prints so far. In my opinion, Cura2 with all the new parameters, is getting very complex for Flux Delta, I cannot see yet what practical improvements it will bring.


Here is a tool head firmware 1.2.7 which has no tilt head issue.


The CURA 2, Z offset at the bottom of the list does work but the one further up the list does not. If you enter a value of say 20.0 into the Z offset at the bottom of the list then you can see the offset applied to the preview and the print.
So at least I can use CURA 2 in FS 0.7.3, Thanks.

The CURA 2 Z offset does not have any effect on a gcode file from S3D though. I also tried inputting a 20mm Z offset into the S3D settings but when the gcode is loaded into FS using either the IMPORT button or direct to the SD card the 20mm offset is not there and the print starts at base level. (Maybe a G90: Set to Absolute Positioning, inserted into the start code would work?)


Thanks Luan, I have all the prior editions I just wasn’t sure you could roll them backward. I guess it is more like flash firmware than actual hardcoded then? You can just roll back to whichever previous version you want? I have 1.2.10, I might try that first.

I had it stop 3 times last night with magnet end detachment errors while I was literally sitting right next to the machine. There is definitely a serious bug in 1.2.13 firmware.