FLUX Studio 0.7.1 Change log


Sorry about the frequent update. This update is mainly for new users, where we found there are bugs in some edge cases. However, it is still recommended to use FLUX Studio 0.7.1 instead of 0.7.0 to get a better printing result.


  1. Add movement tests to device menu

Bug Fixes

  1. Fixed latest tutorial hanging in spinning animation when there is no default machine
  2. Fixed machine dashboard displaying
  3. Fixed geometry correction value displaying in machine settings


  1. Tweaked Cura2 default print settings for a lot better print results

Note: We’re fixing Cura 2.4 compatibilities for linux users, the cause is missing library



Hi, I am having the same library problem on windows 10. I got this error when I installed flux studio 7.1 :
I can not slice with cura 2, I have to set it to 0. (I tried running the wizard again and it did not do better)


Thank you - We still need the maintenance meter - it would be nice that a report can be generated that has all the jobs you printed, with date printed, filament used, time to print, and that it can be reset if wanted.

I get the same result with the driver fail to install.


Just tried my test box, Slicing with Cura will not work, but with Slicr selected works fine… Here is the error when cura is selected.


UPDATE*** It will work, if I disable cura 2


Same problems here on win10 x64. libusb-win32 not installing and Cura 2 not slicing.
Agree with pmbroth about a maintenance meter too.

Also there a lot changes to be aware of in the expert settings. I have made a log of the changes here>

  1. The First Layer height slider, although by default it is now set at .4, the slider will only go to 0.35.
  2. Default fill density is now 10% instead of 20%
  3. Retract length is now 8 instead of 7
  4. Retract speed is now 80 instead of 70
  5. Travel speed was 80, it is now Default=80, Low=120, Med=100, High=80
  6. Bottom layers was 3, now default 3, Low=3, Med=5, High=6
  7. Top Layers was 4, now default 4, Low=3, Med=5, high=8
    8. Bridge speed, was 60, now default=15, Low=60, Med=15, High=15
  8. Layer heights were .25,.15,.05, now default=15, Low=.3, Med=.15, High=0.0.75
  9. Retract Lift was .24, now default=.15, Low=.24, Med=.24, High=.24

Also, I like the new skirt routine but disappointed that the skirt distance has no effect.


And another thing, now I have the problem of things not working under the “Machines” menu. The only one that works consistently is the machine firmware update. The toolhead firmware update just shows a waiting circular symbol and all the other commands may work once after restarting Flux Studio but not again.
Anyone else got this problem or is it just me?


You should try to reset FS after number of times install over previous version The reset function is under File->Preferences->General tab->Reset FS; it’s below Default Model.


Thanks goldensnake, good idea. But, I’ve just tried it and it did not make any difference. I did get to see the Toolhead firmware update option work once though so if we ever find out if toolhead 1.2.10 is safe to use, I should be able to update it if I try enough times.


I did update tool head 1.2.10 firmware and it works fine. I couldn’t find any description about what’s new on the version even though on github.



Just wanted to ensure you are aware that CURA2 has to be disabled on Windows as well, so that the Cura slicer works.


I tried tricking the system to load unsigned drivers, and it still does not work (Windows 10)


I managed to install the driver - see topic “Failed to install driver”

But it did not change the problem I have with the “Machines” menu items not responding. It is the same in FS 0.7.0 .
I installed 0.6.3 again and the menu items worked again but when I try to update the toolhead firmware to 1.2.10 I get an “Update failed” message. If I try again in FS 0.7.0 or 0.7.1, I just get the circular busy animation and I cannot update the toolhead firmware.

Edit: Just tried updating toolhead to 1.2.7 and that worked OK (using FS 0.6.3) but it refuses to upload the 1.2.10 file saying “Update failed”.


I got the driver installed, but the cura 2 error still persists.


I just also noticed with the cura slicer, preview is not working.


I import a gcode file and the preview doesn’t work as well.


Note for windows users:

This version will include the USB driver for the brand new USB cable ( not Micro USB ). However, if you’re using the latest windows version, you might get an error due to the unsigned driver by Microsoft. You can read more on how to install unsigned drivers:


Hi, Thank you for the link. I just tried it and I successfully installed the drivers, however Cura 2 is still not working. I still get the “UH-OH Slicing engine exited abnormally” error


After a print is completed. And start a next print then “Start” a new import gcode file won’t work. Reload the FS and it’s ok.