FLUX Studio 0.6.3 Change Log


Nice feature, and also it would be nice to add to the Temperature setting an optional command to extrude “xx” mm of filament, to try the filament flow at different temperatures, etc…


I still would love a log that shows the prints/laser engraving/ etc. you have done and the runtime, so that maintenance can be performed, and you do not have to keep a manual log.


@mc_ott Michel, as one of the regular Mac users I see here (anyone else feel free to chime in too) I wanted to ask you about a difference I’m seeing between Slic3r and Cura.

Using Cura, the FLUX will calibrate then pause for final heat up about 8cm or so above the bed. For me I use this time to ensure any filament ooze is cleaned up and the bed is ready.

Keeping all settings the same, but switching to Slic3r, the FLUX calibrates, but then pauses about 1.5 cm above the bed to heat the nozzle, leaving me stuck with whatever it wants to ooze.

I have no idea why it does this only when I use Slic3r, and I am not entirely sure if it is a Mac issue, I don’t have a PC to check otherwise.

Any idea what’s going on here?


Happens to me to on Windows10 64bit, FS 0.6.2. Not tried 0.6.3 yet. So it’s not just a MAC thing.


@BoozeKashi: It is my experience also, FS v063 on Windows behaves the same as OS X.

I also think there are slight differences in the way the Expert mode settings are being used by both slicing engines. With my start_gcode settings, although Slic3r behaves slightly different than Cura, it comes to the front and stays about 8cm above for the nozzle priming. I should also add that I almost exclusively use Cura engine because I have more experience.

If you want to try it, the following is my start_gcode for both engines, my end-gcode is the default one:

start_gcode = G21; metric values \n; start of purge line \nG1 Y-80 Z150 F6000.000; move to front of build plate \nG92 E0; zero the extruded length \nG1 E25 F240.000; extrude 25mm to purge line \nG92 E0; zero the extruded length again \nG4 P10000; wait 10 sec. for inspection \n


Thanks for replies gentlemen, good to know it isn’t just a Mac issue then.

Definitely a specific difference in the gcode implementation in use for Slic3r that is different than Cura then. @Proclaim, might want to take a look at what is going on here for a future build, it has been this way for a long time. I think it has just been overlooked, but really both slicers should be expected to behave the same way at the beginning of a print.

I’ll give that gcode a try @mc_ott, seems like that is where the difference is. I use mostly Cura too, but every once in a while I find that Slic3r will generate supports better or it ‘sees’ small parts better or has a faster print time. Not often, but once in a while, it’s just that priming so close to the bed that drives me nuts.

Again, thanks guys, the support and creativity of this crew always amazes me.


I notice that flux team fix the percentage printing problem, now when the printer finish to print, the percentage is correctly show.

Also like other mentioned before if flux team can make a log of how many print hours have passed since last maintenance will be great.


@proclaim : I also noticed the change in temperature hold at pausing. As mc-ott says, I would also like the temperature to stay hot while changing filament and also move to the front of the machine to make it easier to prime the filament and wipe off any oozing before continuing.
I was confused at first because after I pressed the flux button to continue, nothing happened. There was no indication that the head was waiting to re-heat. When it suddenly continued, a pile of oozed filament was dropped on my work which I had to surgically remove before the nozzle came back to knock the whole thing off the plate!


thanks for the suggestion. Note it down for our meeting discussion

@mc_ott regarding the screen issue (too bright where you can’t see things). I’ll have to find someone with older mac models to test that case, because ours were working fine.


Jim: I tried FS v0.6.2 again and the screen shows OK with anti-alias on or off. I am sure something was changed in v0.6.3 which makes the screen brighter.


I ran 0.6.3 on Ubuntu and noticed some differences to the Windows version - its main window is even still titled “FLUX Studio 0.6.2”. That only changed after I ran the “install.sh” script as root … but FLUX Studio does not get past the circling something (i. e. hangs indefinitely).

I guess it needs some more maintenance … and while I’m at it: Would it be asked too much to have a neat *.deb package that makes advantage of the package management?


Hey pmbroth,
I’m Having the same issue and can’t seem to fix it. The issue where the slicing engine exits abnormally. I’m running 0.6.3 on a Mac late 2012. Ive been discussing it with a flux representative but he can’t answer my question and i haven’t been able to print anything for a week now. But would you mind telling me how you fixed the issue so i could give it a try, if you were able to fix it?


The issue was that the slicr engine cannot do 100% infill with a particular pattern, I changed that and it worked.


Slic3r can only do 100% infill if you use Rectlinear Pattern. Anything else and it will crash out.

I’m still standing by on 0.6.2 Keeping an eye on this thread before upgrading this time.

Especially that temp drop at pause issue you guys caught. That’s a deal-breaker for me.


@BoozeKashi oh my bad I read and disregarded the fact he was using 100% infill. I am using 8% infill and I’m running into the same problem with Slic3r. Im trying to switch up some settings to dog out the problem but i have not had any luck so far. I am using the Slic3r slicing engine and using 8% infill with a honey comb pattern. I get the error “slicing engine exited abnormally, kindly slice again” when i put ANY .stl file into flux studio, i have flux studio 0.6.2 running and i have tried it on 0.6.3 and it didn’t fix the issue either.


Not sure what’s going on there.

I generally much prefer Cura (and now Simplify3D) over Silc3r. Only rarely do I ever use it when I run into some weird model that Cura doesn’t like.


When I used load/unload a filament, some times the carriages return to home position too quickly and hard and it is generated an home positioning error. Slowing a speed of the carriages while homing would help.


Recently, I run into the problem after finished printing that I have to power cycle/abort a task from a printer. Do you have any idea?


I try to use to reset function on FS and I have learned a few changes on FS.

  1. WiFi setup routine is intuitively easy.
  2. FS is also asked user to change a new password which is more secure.
  3. Start printing task also have to select a active printer before printing.

    However, I should manually reset FS after installing an update version to access any add-on and new improvement function on FS.


the reason you’re selecting device after you clicked start is because you’ve reset FS and there’s no default device (printer).

go to devices (menu) and select a printer, click set as default and you should be back to business. In our office we have thousands of devices… um, I mean lots of them, so we don’t usually set a default printer =)

thank you very much for the feedback!