FLUX Studio 0.6.2 Change Log


FLUX Studio 0.6.2 Change log

New Features

  • Added geometric error correction options in device settings


  • Rework on background slicing logic to prevent slice error which might cause go button unclickable from slice error or out of bound

FLUX Firmware 1.5b13 Change log

New Features

  • Added support for geometric error correction options




Hello the firmware is not a BIN file or .f… FILE, it is downloading as a zip file.


just noticed if you rename the extension to what it should be (FXFW) , it works.


What if it will be bricked, it did to me once; but it worked after rename a file extension like @pmbroth has done. @proclaim, Should you check a file before upload a new firmware for beta tester?


you mean when you download the file, it’s a .zip file? I just tried it and it’s downloading as .fxfw extension


@proclaim I just tried to downloaded it again, the same thing - see the screen shot.

Update** I just noticed that it only downloads as a zip in Internet Edge, chrome works fine.


Microsoft browser is automatically zipped an unknown download file in purpose. If I used third party download manager, then it keeps original file extension.


Is there any explanation for the new error correction in 0.6.2?
How does it work? What would id correct?


Dear Flux team, before updating the firmware, can you please give some examples of what kind of geometric error correction options are now available?

By the way, can we work with 0.6.2 without upgrading the firmware to 1.5b13? (not using the geometric error correction options, of course!)


Flux Studio and printer are unresponsive. All have a latest beta revisions. Here a bug report https://www.dropbox.com/s/m6g6i7ykweuuvuz/bugreport_1483815527.txt?dl=0
Restart printer and it works fine.
Another FS error log. Start printing without reload FS. https://www.dropbox.com/s/2kjql1jfm231l1d/bugreport_1484410462.txt?dl=0


it looks like you were uploading a file, and the machine becomes unresponsive (from the bug report). I’m wouldn’t say it’s the new FS that’s causing this but rather a more device side problem. (like you said, restart machine worked). Sometimes it may be the cause of PI board, or the cause of the firmware. if this problem is repeatable, please do tag me again.



I just used the laser the other day, and noticed within the application the help for the “Object Height” is incorrect - The help states “A raft are layers built under your part and help it stick to the base plate” obviously this is incorrect.




That was one of error. I’ve printing one big print as chess set in many days and hours; FS and printer are working with one recoverable error; that is rock solid performance.


thanks for reporting, will be fixed in the next release =) hooray!!!


After I installed the new version of FStudio, the update firmware dialogue told me that I had the newest version. It still let me do the update, but the warning message was incorrect.


The progress bar also seems to be incorrect. My first print with the new Studio and firmware completed at 37%.

The print looks amazing, though. Definitely a visible improvement!


Since FS v0.6, my prints terminate 15% to 10% sooner, although the prints are completed the “%completed” estimate never reaches 100%. Also the original time estimate follows that trend, the estimate is longer than actual printing time.


I agree on the printing status has not been corrected until now. For now, I mainly focus on testing the reliability of FS and firmware. One more note that when I import a slight out of bound gcode file; FS detects with no warning message and it won’t allow to start a print task instead.


Couple of things I’ve noticed and I wonder if anyone else has the same problems too>

  1. Since updating to 6.2 (win10 64), everything I print comes unstuck from the right hand side of my build plate. It’s not the plate as it’s a circular glass plate that I have tried rotating round. It’s not different length magnetic rods as I’ve tried swapping them round. It looks like a calibration issue as it looks like the plastic is not being squished down as firmly on the right hand side as on the left. I am at the point now of wanting to downgrade the software because I can’t see anything else wrong and it was working perfectly on the previous version. I’ll have to wait 7 hours though because I just started another print. I will downgrade once it’s finished. Has anybody else had this problem of the calibration not being right on 6.2?
  2. I am trying to print the Baby Groot from Thingiverse but his hand on the right hand side of my printer came unstuck. I’ve just started it again and sure enough it’s come unstuck again but this time I have stuck it in place with a dab of super glue. But anyway, on restarting the print I used the recent.fc file in the printer memory to save time. It did a calibration but then it went up to the home position and bounced off the switches before going to the start point ! This clearly would cancel the calibration data if it really did re-home it’s self. So I had to restart it from scratch by uploading the model again and this time it worked without doing two homing sequences. The model was processed by Slicr. So has anybody else noticed this problem of two homing sequences on starting a saved .fc file?