FLUX Studio - 0.3.4, Delta Firmware 1.0b20 and Toolhead Firmware is out!


#86

Can we make file associations with STL to flux studio, as well as a drag and drop feature


#87

If you are using windows, just right-click on the file and choose open with “FLUX” and make it default…


#88

Did I miss a step-back post? Post lists 0.3.2 but version on downloads is 0.3


#89

Likely because there have been some issues with 0.3.2, so I think they rollbacked to 0.3.0. The software especially is a beta product, so expect things like this to happen frequently.


#90

I notice that flux team upload a 0.3.3 on the download section, have anyone have tried this new version, and if it works better than 0.3.0 or 0.2.16?

I also would like to know what new features this version have, because they are not listed here on the thread.


#91

I have Windows 10 64bit, and Flux Studio v0.3.2.
And for twice now i notice that once my print hits 30 mins mark, i will get the error “something went wrong with the toolhead, please reattach module cable”, though i can just hit retry and the print will continue without fixing anything else, is it possible this is a bug with the toolhead firmware or the delta firmware?

So far the longest print job i had was 46 mins, so i’m not sure if the error will pop out every 30 mins,
1st error >> 30 mins mark
2nd error >> 60 mins mark??


#92

Maybe you have a problem like this one:

Some users found that printing this stabilizers help the usb cable to not disconnect and produce this error.

Also you can try to contact flux team using this form (This was posted on the same thread by Simon member of the flux team):
https://flux3dp.zendesk.com/hc/en-us/requests/new


#93

has anyone updated the delta firmware to v1.0b18?
Flux website has v1.0b18 as the latest but when i tried to update it says i have the latest firmware with v1.0b16


#94

It worked for me. I can’t print anymore now than I could before since I can’t get past self-leveling.


#95

Do you know what’s changes on the new firmware? Thanks.


#96

For those wondering:

0.3.3

  1. New: Using ssh key to establish connection
  2. New: Javascript error handling
  3. Fix: Blinking video in scan

Installed the new version but can’t update the firmware either… tells me that v1.0b16 is the latest.


#97

I had the same problem with the software and used the USB key install method to update the firmware.


#98

Managed to update Delta firmware through Flux Studio

Now for toolhead firmware, got an update notification with changes as follow

  1. reliability improvement
  2. fan control improvement

however i get “upload failed” everytime i tried to update with v1.1.2 toolhead firmware through flux studio


#99

@Jun_Yan

You got an abnormal usb-c cable & connector, kindly contact us with subject USB Type C Error.


#100

I should’ve known “toolhead firmware” means the “laser toolhead” firmware, that i need to have the laser toolhead connected in order to get updated, i was connected to the extruder that’s why i had the error.

But it should be made clearer of which toolhead is the firmware for, since the extruded is also considered as one them, and we might have more toolheads in the future.

user-friendliness wise, i think there should be instructions during toolhead firmware updates, asking user to switch to the corresponding toolhead for the updates.


#101

0.3.3 seems to have limted measurements?

I have a print which is about 151mm wide. The File is sliced using Simplify3D (with limits set to 165x165x180 for the Printerbed)

Using Flux Studio 0.3.0 I easily could import and print it, with 0.3.3 I do get the warning that this file is out of measurnements (exactly the same file).

I have switched “support on” - as having some overhangs on this print.

Anyone knows about changes here?


#102

I had this problem with the version 0.3.2 and reinstalled after backwards to 0.3.0 again. Just tested the new 0.3.3, and it works this time. Maybe it helps, if you reinstall it?


#103

I have come from 0.3.0, upgraded to 0.3.3 but now backinstalled to 0.3.0 again and it workes again fine.

So for me no other experiences in the next time, but many thanks for your note which I will keep in my “toTestList” for future


#104

Correction, i was able only for importing the file, but as soon as i click start, it will decline because of the “out of range” error.
back to 0.3.0 again :disappointed:


#105

Just got my Flux up and running two days ago. I notice that it takes a LONNGGG time to connect to the network. Once connected, it works fine until I need to “turn off” the printer. (Why is there no power switch on the device?) Then once turned back on, I have to wait a long time for that blinking green light to go solid. Like a couple of minutes. Is this just me? I’m not right next to the router, but I show full bars on my laptop at this location.