Flux Delta Upgrade Experiences


wow I was losing the train! I just ordered my free upgrade kit. :smile_cat:




Any other updates on the knocking noise? I did not have it anymore before the upgrade. I upgraded, and the noise is back with a vengeance. I tried the following with no help:

  1. Higher temp, lower temp
  2. Material flow - 95
  3. Different filament brands, which I never had a problem with such as Hatchbox, xyz
  4. Tried slower printing
  5. Oiler/filer

What I notice is that when it makes the noise the filament is being kicked back

Any Ideas, the noise is annoying, and sounds like something is going to break!


Do you get the knocking noise at all layers or on the first layer only?


All layers… unfortunately


Same here I have more troubles than before. I did try all of these too…

Does aneyone know what enabeling the extruder upgrade in the software does?

One thing I have yet to try is diabling that and keeping the upgrades…

All layers here too

Unfortunately I can’t go back to my old extruder gear as I shortened the spring when I was trying something:(



I may have to open it up and put back the old parts…


I will if I find a spring that works


Could the knocking be due to the set-screw of the gear on the filament feed stepper motor hitting the metal frame every rotation? I noticed that if the gear is put to far forward on the shaft, the set-screw hits the frame (I cannot remember exactly the frame or other fixed part, the top of mine is closed now and I don’t exactly remember the mechanics). I noticed that issue when I was upgrading my feeder and if you don’t install the gear at right spot, the set-screw does not clear the frame.


I got it fixed!!!

I opened the unit up, and the spring that is used for the filament pressure, jumped off of the little nipple. I put it back, and all is well for now!! If it happens again, I will have to put a screw to hold the screw. I hope this helps someone else!!


Me not yet… just changed the nozzle as I am having a hard time clearing the clog in my 0.2mm one :frowning:


trying to do the extruder head upgrade and ran into a problem. My head appears to have melted. I am not entirely sure what to do about this.

Any thoughts?


Click the top menu Machine > Commands > Set toolhead temperature and set the temp to 100-120C. Peel off all the PLA on the metal parts and the upgrade kit can be installed properly.


I installed the upgrade over the weekend. The over all build wasn’t difficult. The magnets were the same as most others said. A pain to glue down, but I used the end of needle nose pliers to move in place. After a minute I used a straw to hold the magnet down while I detached the pliers.

The extruder feeder is just a problem. I had it in place and got the clicking where it was digging into the filament. It stopped feeding at that point. It was engaging and retracting but not feeding. I tried taking the top off while it was printing to work on it, but I just couldn’t get it to stop. I never had a problem with the original so I put it back on. Problem went away. I don’t know what is wrong with the upgrade, but it’s not working right.

I didn’t like the new shorter sprints for the scanner upgrade. There was no springing up with those on. I’d have to get ahold of the parts and manually pull them up until the magnets engaged for it to work. I put the original springs on with the upgrade parts I don’t believe that was even worth the effort. I hadn’t had any issues from them before. I fear putting the upgrade on may lead me down a path that leads to problems.

The USB cable is great so I don’t have to connect wifi now. That wasn’t fun since my Flux is a good distance from the router. Only issue is, the connection seems to dump with the change of the wind. Seems like a software issue. Everything is going fine, then it says no connection found. Good thing LS that the Flux keeps rolling along after the print has been sent to it.

I really didn’t notice any difference in the print after all that. I selected Delta + in the preferences and set everything up. Not really sure what exactly the upgrade did. Maybe the camera being better will work…


The weaker springs are to prevent the retainer catches from slipping, as there was too much tension on them with the original stronger springs. Hopefully you won’t need to open up you Delta in the future due to the catches failing again. As far as the scanner poles not jumping up on their own, I found that all you do is release them when under tension of pressing them down, and they sprung up high enough to catch the magnets.

WiFi not having a connection is certainly a software bug, and it seems more so on the flux studio end than on the delta firmwares, as a restart of flux studio makes it connect again without any issue :-/

When the extruder feeder was clicking… were you able to hand-feed the filament through? It wasn’t jammed at the print head? And when you say you selected delta+ in the preferences, do you mean you chose the upgrade kit options in the preferences? (as that is what you change, not the model type, as it is still a Delta but with upgrades… just checking!)


I never had any issues before with the scanner poles popping up on their own, so I never gave it any thought with the springs. But I’ll leave it as is for now and if there’s any issue, I’ve got the other springs I can easily swap out. That part wasn’t hard to do and could easily be done again if needed. The only hard part really was getting the magnets in place and that was mostly due to the magnets wanting to grab onto any metal it found.

Yeah that’s what I end up doing to reconnect is restart the program. Or wait. It did connect back up on it’s own a couple times. At least once the print starts, I don’t have to worry about it stopping due to the computer dropping the connection.

I could not push the filament to make it go or force it in any way. When I pushed the lever down to release the filament, I was able to feed it and manually make the extruder dump filament. It was definitely the stepper motor sticking or something. No issues at all with the old feeder. So for now I’ll just leave that one in place. It works, so better working than not.

Selecting Delta+ was on the left of the main screen. Should that stay Delta and not Delta+?


Yes, it stays Delta, as your printer is a Delta with an upgrade kit, not a Delta+ :wink: Instead you’re supposed to tick off the upgrade kit options in the settings (as shown below) per the installed upgrades.

Yeah, I had one of the catches on a scanner pole finally let go about 4-5 months ago, so whilst I was waiting for the replacements I pulled the springs out, and realised what the problem was when the replacement parts arrived. Then the upgrade kit turned up, so it was like the 5th time I’d taken the base off… getting pretty quick at doing it! :smiley: Magnets were easy once I stuck them onto some metal tweezers… they weren’t inclined to snap onto something else, and I was just able to hold them in place until the glue had enough time to start curing. Before that one bugger kept running way! :laughing:

With the extruder… it may be the fact that it was flagged as a Delta+ instead of a Delta, instead of an upgrade kit extruder… or maybe there is something faulty… you’d have to pull things apart again for a while to check it out… probably run it with the top off and the filament sensor disabled or tape the switch down so you can check out what is happening with the extruder.


I either missed that in the instructions or something. But yeah I know I didn’t select to enable the upgrades. Might be why it was sticking. What the feeder was doing is feeding at lower speeds but stuttered at higher speeds. Like when it was traveling or printing the infills. It was running ok for the retraction and then when it would feed back out it just sounded like the stepper was grinding. That’s why I put the other one back in. It runs fine with the original. So I’ll try swapping the part out again and select the upgrade. Plus I’ll put it back on delta instead of delta+.


My upgrade experience hasn’t been so smooth, and I’m still not printing yet. I miss the pre-upgrade days… Grateful for any tips folks can share. Here are the highlights:

  • The new print head cable shorted out the extruder board, requiring me to replace the board and cable out of my own pocket. $35
  • The laser pole upgrade was daunting. Did it twice because the latched provided for the laser pole housings were broken and wouldn’t latch. I just happened to have a parts kit that had spare latches I could use. Got really good at assembly and disassembly.
  • Got that 90º camera rotation thing going on. Is there no fix for that??
  • Now I can’t run auto-leveling because the ball-arm disconnects from the print head during the routine. Can’t figure out why this is happening now, because I was able to auto-level when I first plugged everything back in.
  • May have ruined my filament sensor cable when the wires got yanked, as the lid slipped off. We’ll see, if I ever get leveling to work again.

Overall, I felt the upgrade process wasn’t as advertised. Parts didn’t work, and instructions weren’t always intuitive. Really stuck in my craw that I had to pay for the burnt-out extruder board.


As for the camera, there is a setting under the preferences within the Flex Studio software (0.8.3 or above I believe) that you have to select (camera upgrade enabled, or something like that…not in front of me at this time). That will rotate the image for you.


I am curious did it kill your board instantly or did it take some time?

I am asking as mine is broken too after using the upgrade kit and the new cable for a bit.