Fixing bad models?


#1

I’ve been wanting to print this Samus model for a friend, but I’m having some serious issues with it. Most I think I can overcome, but the main problem right now is there are just problems with the model itself.

Currently, the main problem is that the bottom of the model doesn’t actually touch the base plate. Ideally, I would like to rotate it just slight so that one of the feet is actually flat on the ground. I’ve tried doing this stuff in Flux Studio, but it doesn’t seem to be working very well or doesn’t have fine tuned enough controls.

I’ve tried playing with MeshMixer, but am having trouble understanding all the controls. Suggestions?


#2

If you can tolerate to lose a mm or two from the bottom of the feet, you can perform a Plane Cut.
Open the model, select the Edit button on the toolbar to the left. Select Plane Cut and use the vertical arrow within the image to slide the plane to the cutting location.

Use Control and the middle mouse button (or wheel) to manipulate the “camera” for rotation. Hold shift and middle button to pan the camera. After reaching the bottom, or very near the bottom, position the camera in such a way as to be able to move the vertical arrow for the plane, while observing the cut area. You will see the color change that represents the new plane/new bottom of the model.

When you click Accept, all of the model in the direction of the arrow will remain, while the plane cut becomes a closed surface.

Export the STL when completed.

Zoom uses ctrl-middle button- mouse movement.

Following your original suggestion of rotating the model, it is necessary (or rather, preferable) to create a pivot point near the feet. Import the model, select Meshmix from the left toolbar, drag a sphere into the work area, between the model’s feet. Use the tiny white box in the center of the sphere to reduce the size of sphere. The smaller, the better.

You should see the object browser appear when you’ve added the sphere. Hold Shift, click on the model to select both items. Select Edit, Transform to get the manipulator, this time centered on the sphere.

Holding the arcs visible in the manipulator will give you rotation about the center of the sphere, and include rotation of the model. After grabbing an arc, move your mouse as far away from center as you can for finer control.

I think it’s going to be tricky to find a flat-foot in the latter method, while chopping off some of the feet will be easier, but you may have more patience and a better eye than I.


#3

@fred_dot_u - Thank you! I was actually able to use Edit -> Transform to do most of my rotation. Only needed to change it like 1 degree. I still did use the Plane Cut, which was super helpful. At that point, it was still floating in the air a bit. I used Analysis -> Layout/Packing to fix that.

Let me know if I may have screwed anything up. Thanks for the help!


#4

I’m not sure how I’ll know if you’ve screwed anything up, but I suspect that you will, much sooner than I.


#5

Hey if you’re still having issues, let me know, I should be able to fix the model for you.


#6

Yeah, it looks like there isn’t a flat spot that makes contact with the bed.


Tha “lay flat” feature in Cura lays him down on his back (which must be the largest spot where more than one triangle is coplanar).

For organic models like this, you’ll always be fighting overhangs and artifacts from support structures. You could cut Samus in half and make your own flat spots.

The other option to try might be using “tree” supports in MeshMixer.


#7

I tried the tree supports in MeshMixer. There was some issue before it even got much past her foot. Even in that little area, I noticed that the tree supports were nearly impossible to remove.

I did manage to flatten out her feet, but if that doesn’t work, maybe I’ll try cutting her in half (I feel like a magician now).