Filament not feeding


Managed to print the test with no problems

Actually the medium quality is much better than I thought it would be

I did take the cap off.

So a loop of PLA is holding the switch open and the main spool is feeding directly in

Printed the demo on medium mode with no issues

Blue tape worked really well. Not the same brand as everyone else uses but close I assume.


That is a good idea.
One of my concerns is that it might void the warranty.


Fair enough point. However the alternative would be to have a non-functional 3D printer that only does laser etchings.

My studio is small enough without something else taking up space and not being used.


You have a good point there.


Hi William i’ve the same problem, every time i get the question ,run out off filament after i upgrate to 3.4.
question, how dith you get of the cap?



If you get “insert the filament” in loading filament interface, and non-working unloading filament, try following workaround

  1. Open Device Dashboard using right-top panel

  2. Press Ctrl+Alt+D to turn on Developer tools

  3. Copy following text

var match_ws = null;
for(var i in window.FLUX.websockets){
var ws = window.FLUX.websockets[i];
if(ws.url && ws.url.indexOf("/ws/control") == 0) match_ws = ws;
match_ws.send(“config set filament_detect N”);

  1. Right click on bottom blue “>”, paste, and press enter

  2. Restart FLUX Studio

  3. Re-enter the interface of changing filament


@Simon I am currently working with @Jim at getting it resolved. At the moment, it looks like an alignment issue.


As far as i know, opening the top portion of the printer doesnt void the warranty, the filament grabbing mechanism consists of a metal gear and a matching plastic part, we’ll know what’s wrong if you could open it and take a look.


The reason of sensor failures is the sensor lever which is too narrow (or the hole is too wide) - the filament can easily pass by it (between the lever and the side wall). The lever is not stiff enough, but bows off to the side. Even if initially the filament press it down, after some time the filament slips from it and presses it off to the side rather than down.
I glued a bit of plastic to the side wall and the sensor works well now. You can do the same.
Now the Flux Team know about it and will make the hole narrower.


I only get the problem when using rough filament that pushes the switch lever to one side when retracting. It’s the switch lever that needs keeping central as well, not just the filament.
Changing the lever switch to a light sensor would be better.


Jim and Team,

I finally received the upper control board today. Thank you.

We still have a feed issue! The feed motor is on BUT not
moving in either direction. I’m NOT able to manually move the motor
while it’s plugged in BUT if I unplug the motor I can turn it freely.
While the motor is plugged in the feed motor “hums”.

What are the next steps? I would REALLY like to start
printing ASAP. Do you want to send me a replacement motor and control
board OR should I send the whole unit back???

Does anyone have a suggestion on how I can resolve this?



Please read my prior post and/or response to RM-212.

I’m asking for your help with getting this machine up and running (for the first time) ASAP. You and I started this relationship back in Dec 2014. I was very excited to receive the Delta in mid April. At that time, I was able to use the laser BUT, the printer itself was not feeding/functioning. After receiving the replacement board and installing it today, the feed still does not function properly (see prior post for details).

For almost a month now I’ve had to look at this amazing machine in the corner collecting dust which in some ways is more frustrating then not having her at all. This is like dating a HOT woman for a month and NOT being able to have sex with her. Hahaha

Can your team PLEASE rush me the parts needed to fix her OR, let’s get her replaced sooner than later.

Thank you sir. I look forward to your reply,



Sorry about the situation. I just replied your ticket.



Please see my response to the the open service ticket. In short… The issue is not resolved. Can we get a replacement shipped ASAP.

Thank you




I’ve have NOT heard a response from you or your team on the feed issue NOT being resolved! What can your team do to assist me?

I look forward to your reply and help resolving this issue…

Additional details are posted in Request #4562 UPDATED on May 11th. They read as follows:

Good morning Jim,

This did NOT resolve the problem. All connectors are
clean and correct. No issues with bent pins. Also, ALL
software/firmware has been updated.

The feed motor sits and hums while the machine is on and
will not move in either direction. I have cycled power as well as
rebooted with and without the drive motor plugged in. Nothing has

It looks like the time for a replacement machine. Sorry

Can you please mail me the replacement Delta with
RMA/Shipping label. I’ll put the old machine in that box and return it
to you the same day.



@Jim, @Simon ,

Jim & Simon,

What are we going to do about my Delta? It’s now been a month sense I received the machine and to date, I have NOT been able to print anything. Can I get a replace OR I’m even willing to replace the drive motor as well as upper and lower control boards (we replaced the upper board and had NO luck) IF that make’s things easier and FASTER on your team. I just need a response and some actions directed towards getting this resolved.




On the topic of rough filaments, I was having trouble with a rather coarse-textured Glow-in-the-Dark filament. After a lot of huffing and puffing, the printer would initially load the filament, but it wouldn’t extrude during printing, making that horrid clicking and whirring while the gear would chew a groove in the filament and eventually fail completely.

I tried a filament feeder that adds lubrication (mineral oil), and voila~! It’s printing like a charm.


Well, still expect the filament sensor switch to wear out quickly even with the oiler fitted! I now have the switch perminantly disabled in the advanced settings because it is worn out and unreliable, exactly as Goldensnake’s one has in his post> Simplify3D fff profile


HI William…did you solve this problem? I have the same issue…



My printer has been a brick for about 2 months now.

I gave up on it and the company a while ago because of the constant headache with the machine. I am told that finally a USB cable for direct connection will be coming

Honestly this machine did not meet my requirements and I have moved on to look for a different machine that will better meet my needs