Filament not extruding


Does the extruder not have any grip to keep pushing filament, or is the filament jamming in the hotend?

On voronoi style objects, there’s a crap ton (technical jargon, sorry) of retracts. If you’re printing in PLA and you retract too far or too fast, PLA that’s already hot and soft will get pulled into the cold part of the hotend and instantly solidify into a plug that can’t be pushed back down into the melt zone. Reduce the retract distance and give it another try, if that sounds like what you might be experiencing.


Does the extruder not have any grip to keep pushing filament, or is the filament jamming in the hotend?

The filament just stops coming through the hotend. If I would answer this questions, I would say it’s jamming.

Here are my retract settings:
retract_before_travel = 2
retract_layer_change = 0
retract_length = 7
retract_length_toolchange = 10
retract_lift = 0.24
retract_restart_extra = 0
retract_restart_extra_toolchange = 0
retract_speed = 70

Which ones should I change?


Try something more like 4mm and 40mm/s as a test.


@jim I’m having this same problem. What do I need to do to open a ticket to get this fixed?


one thing you can try and see if this will help

  1. click “change filament” and head up the head
  2. after the head is heated, popped the head out (remove all 6 rod, USB and filament nut/bolt)
  3. break a section of filament and manually push it into the head

sometimes I notice a gunk of oil got stucked on the head and after it squeezed out, you should be fine.

if this does not work for you, please fill out a ticket


I am having the worse time loading and unloading filament this is awful…
This is like the 5th ticket i will have to open…

this is making me very upset with this printer


I usually manual feed the filament all the way through the tube down to the extruder, Just make sure when you manual feed filament, you press the clutch button on top (Filament feed button), and hold it while feeding the filament manually


Cutting the end of the filament at a 45 degree or sharper angle definitely helps feeding issues a lot.

Manual feeding works, but takes a bit of practice to get the feel for it.

I had my first nozzle clog today, but it was not that difficult to clear. I just ran the load routine to heat the nozzle, then shut off the Flux, and unscrewed the nozzle. I did not even have to take out the screws and pull the cover. There was enough edge on the nozzle to just unscrew it.

With the nozzle off, I could see the PLA wadded up in there. I just put it on a piece of foil and popped it in the toaster oven for about 25 minutes at 230C and cooked it all out. Took it out of oven with pliers and pushed a short piece of filament into it. A bit of black gunk and then clean PLA!

It cooled off quite quickly too, then screwed it back into the head and I was printing all day again. The whole process took probably about 45 minutes start to finish.

Most feeding issues are solved by cutting that sharp angle to feed, get the feel for manual (if it feels stuck don’t force it), and run the unload routine when you finish printing for the day so filament is not cooling off inside hotend (preventative measure).


In my case the filament isn’t in the nozzle, it broke off at the feeding end. I can see it in the housing where the filament tube nut screws into the head. I’ve tried running the loading routine to head up the nozzle and then tried to push the clog through, however, that didn’t work. It seems like this part of the filament is at a part of the head that doesn’t heat up and is stuck. Is there a way to take the entire head apart so I can pull the stuck filament out? I’ve removed the top cover of the head where the filament loads, however, I can’t see how to remove the circuit board safely to get to the heating element.


That’s a little too intrusive for my comfort, what I did was take the head off the ball supports and disconnect the feeding tube, set the machine to load filament, then when it was at temperature I tried to take the broke end out or feed it further in with more filament


Yes, in my case I could see it on the back side of hotend too, at the feed tube entry.

That tube is a straight shot through. You shouldn’t have to take the whole head apart, or even the covers. Just run the unload routine to warm things up, then remove the head so you can work on it. Take the nozzle off the other side and you should have a clear path to push that clog right back out of the feed tube. I didn’t measure it, but the diameter is comfortably bigger than 1.75mm and a straightened paper clip fits easily.

Just make sure to take your time, things can be hot so handle from outside. Whatever you use to back the clog out just push slowly and it should work out. If you can see it from the back, and you have any small tools like a dental pick or a sharp fine-point awl you might be able to loosen it a bit from the backside before you push from the front.

It’s a small area and a straight bore you should be able to see it all without taking the head apart. While you’ve got the nozzle off the front though, look for any signs of oozing at the threads or overheated and deformed plastic. That has occurred to some users and been fixed.


Thanks for the suggestions. I had made a little progress with the clog using a paperclip, however it still wouldn’t come out no matter how hard I pushed from the bottom. In the end I resolved the issue by using a small Dremel drill bit and drilling the clog out. I made sure that there was no residue in the hole afterward and was able successfully print again after everything was resembled.


hi, Jim, i got my flux delta+ on the 12th of march 2017 im having the same problem in this post, im hearing knocking and the filament is not extruding. please help, support team not replying for 2 days.


First thing to try is a few Load & Unload cycles. As in several times. Quite often that will resolve it by itself.

If it is extruding filament when you Load, then the problem is not a clog, and there is something else in settings causing the knocking, and we can dial in on that.


hi, im not able to unload, tried cleaning with needle and filament.



Hey Jim,
I am having an issue with the printer not extruding. The motor will not activate at all.
Please help.