Filament not extruding



Just sent a ticket to your email.


@Jim, problem is solved. Flux is now printing his first item! thanks!



Thanks a lot, works like a charm!


hi, Jim
i just received my own Flux today.
it seems that i have similar probrem like these above.
please tell me how i can fix the alignment issue.


Just sent a ticket to your email!


@Jim, I’m having the same issue. After 2 weeks working fine, Flux stopped pushing filamento. It gets making some click-click noises and nothing happens. The printer nozzle is getting too hot too, aind with burn marks. The filament doesn’t get to the toolhead more!


Hi @Jim, I have just received my delta yesterday. I was able to load filament but when i am trying to print my first toy, filament doesn´t extrude anything… I can see that filament in its load cage is moving forward and backward but doesn´t print a thing… Can you help me please??

Thank you very much!


Hi Jim,

I seem to be having the same issues - it’s been hard to load filament from day 1 - but not impossible - but now the filament seems to not be pushed down the bowden tube any more.

Can you let me know how to fix this and void my warranty.




If you hear that “knock” sound when the filament is not extruding, there are quite a few possible reasons for that.
If you just changed the filament and you don’t have it on top of Flux Delta, check how the filament enters the feeder on top. It happened to me when the filament was tensioned and entered the feeder in a weird angle so the feeder had issues pulling the filament. I repositioned my spool and used the second tube and it feeds perfectly now.

P.S. Flux Team, I suggest we/you build a list of all possible reasons why the filament is not extruding so every time it happens to someone, it can be used as a checklist.


Hi Jim, I’ve got the same problem. Could you help me fix this?


This sounds like the problem i’m having. Been trying all the suggestions but nothings working atm. Feels like a blockage in the feeder or somethings move internally. the last print i did was getting some clicking noises from the feeder towards the end of the print. Any help Jim?


@Jim I’m also having this issue with my last print, I have a lot clicking noise, something that my other prints didn’t have, and it result with a pretty weak print.

Doesn’t seem to be blocked the nozzle because when I load the filament to the printer it loads correctly. Any suggestion?


By my own experience, I can tell you that by 95% of chance that it’s your nozzle that is clogged! I’ve been having this click-click noise for a long time and my prints were getting really bad. What I did is use an allen wrench number 9, opened the botton part of the toolhead, and with a soquet wrench, detached the nozzle. Then, with a acupunture needle (or you can use a wire) I patiently and gently burned the nozzle and the needle and kept moving it inside till all the melted plastic gets removed. This completely solved the problem.


I am also having a recurring feeder problem, the filament keeps slipping off to the side of the feeder mechanism, the only way ive found to fix it is to remove the upper housing assembly, push down the feeder button, and pull the filament back into place with my fingers.
It looks like the spring loaded feeder button is kind of wobbly, and it doesnt stay in place like it should.

anyway, id really like to see the pictures of how to fix this…


@Jim, same problema here. I can hear the motor working but no filament on the other site.


Sorry for the late reply! Let’s figure it out on the ticket.


Hi Jim, same issue here - the filament won’t load and it’s stuck. the motor runs, but the filament won’t go in or out


Just sent you a ticket!


@Jim, Hi, I also have this problem. I have not been able to print anything yet. Please send me a ticket also.


Looks like I ran out of options too.
Tried all sort of things and filament spool holders with different positions but nothing is reliable enough to say that I don’t have this issue.
The biggest problem is if I try to print a Voronol style object. For example this

I can’t get this printed. It only comes to about 1cm of height and the extruder just stops extruding. The head keep moving up but without melted filament.
Looks like extruder is clogged but how would this be possible if it has 210-220 'C?
Shouldn’t it clean itself with that temperature?

@Jim it appears I will need a ticket too?
BTW: Why can’t you share the solution here?