Failing calibration a lot


Failing calibration on second touch point. This happens on every new print calibration. Sometimes when I’m pressing hard on the rubber standoff at that location the following calibration sometimes succeeds.

It seems to me like the right pressure sensor is given bad readings.

I have checked the build plate and there is no sign of warp in the plate.
I have tried rotating the plate to see if the spot where it failed moves but the spot where it fails stays in place.

it’s the #123 error I get from the unit.

Further more all of a sudden (and i think unrelated) this morning the right laser pillar cannot lock. it pops up even though it clicks like the other one when i try to disengage it. I have never used the scanner so its the first time i’m engaging the laser pillars.

I am now unable to print due to the pillar pushing the build plate upwards.

Got a zendesk ticket on my issues #8007… I’m writing it here to see if there are others having issues with the calibration like me (where it always fails in the same spot)

… also it seems to me that tickets gets processed faster if there is a stir in the forum… :wink:


There has been a lot of discussion of both of these issues here. With solutions.

What software are you running? What firmware? The newest of these solved all my problems with the worsening calibration. Now I have no problem.

Also, there is a mechanical fix for the piping up lasers. They will send you the parts.


Everything is updated to the latest versions.

The calibrations issue has been there a while through many updates and i thought it might be firmware related too. But now that i can see and hear the calibration algorithm has been overhalled i got frustrated that the exact same thing kept happening.

When I load filament with the build plate removed so i can touch the rubber standoffs directly the left sensor responds as expected (speed control) but the right and back rubber standoffs do not respond at all…

Is there only a sensor in the left position (the corner with the button)?

great to hear about the lasers… so ill be expecting the second repair kit then…


once in a while, mine fails to calibrate, seems better with the new firmware. Make sure your print head is installed right (wire on print head should face forward), and I sometimes have to unplug and plug back in my printer.


@albertzerok I am sorry that you’re experience calibration problem, there are no sensors on the bottom of the plate, the calibration reading are done on the head when it touches the base plate. I know you probably tried a lot of things and I might suspect it could the a malfunctioned head. here are the list of suggestions ( you could already tried these)

  1. make sure there’s no left over from the extruder head ( remove the left-over when the head is hot, but be careful don’t get burnt)
  2. make sure the USB-C connector direction on the head is facing the front of the machine (where the flux button / camera side)
  3. check if there’s any obstacle on the bottom of the metal plate
  4. make sure all 12 holes / joints are popped in and moving freely
  5. manually slide all carts (3 of them) and make sure they’re moving smoothly

if you’ve tried everything, then I’ll wait for the ticket response.


alright thanks for the insight. I thought it was a combination of the toolhead and the pressure sensor… I’ll check the carts which is the only thing i’m not sure of on your list.



I have tried it all and now I am getting a Hardware error


I also did a ticket. It was working great since I got it.


Did you get yours running? If not did you get a response to your ticket?


I have exactly the same problem. When I put the Type C connector to front, it works once from Devices menu but then failed in printing calibration. Now the Devices menu calibration did not work neither. Always got a HARDWARE_ERROR. Then I can’t do calibration again until I quit and launch Studio again.

Also I have an equally serious problem:when I load the filament, the whole filament just go through without becoming a thin string. Not sure if this is related to the calibration failure. I also submitted a ticket. Please help!!!


Okay, I’m getting a little frustrated. I’ve opened a ticket to get help several days ago (as well as a new ticket every day), and have yet to get any response. I come to find here on the forum that there are others with the same issue, but this post has had no new information from anyone initially involved for the past few days now.

@proclaim Jim, my ticket # is 82666 and I’ve tried everything you mentioned earlier in this post and nothing works. It doesn’t say much because I am frustrated, that is why I’m posting here.

Here is what is going on: I’m currently using the Mac version of Studio v0.3.10 with Delta Firmware 1.1.7 and the newest Tool head firmware 1.2.1. When I tell the software to start a job the printer begins the calibration process. The printer will perform 4 or 5 passes to each of the three corner points and then fails before even trying to calibrate the center of the plate. The only error that is gives is HARDWARE_ERROR in all caps. It does this every time I try to calibrate. I then thought to try the 0.3.0 version of the software, but the same thing happens, but this time I get the #123 error. Which when looking up on the support page for this error has no info, even though there is a entry for the error.

I have gone back to v0.3.10 of the software so I could use the ‘Calibrate’ option from the Help menu without having to go through the process of getting a print ready. The same error occurs when using this option. When the error occurs the printer returns to the ready/idle position without even trying to calibrate the center.

I thought there might be something wrong with the print head, I saw a help document about the internal gyroscope needed to be re-calibrated so I was going to give that a try. I had the print head completely unplugged from the USB-C connection and removed from the support rods and wanted to see what would happen if I chose ‘Calibrate’ from the help menu. I assumed that the program would yell at me for not having the print head attached, or that it couldn’t contact the print head. In stead the printer starts the calibration process and then fails with the HARDWARE_ERROR error again. This seems strange to me, before I thought the issue may have been with the print head, but it seems more than the main unit is having the issue.

I’ve seen other people post that if they revert to an older version of the Firmware issues that they were having with the new had gone away. I had wanted to try this, however, there is no way to get the older version of the Firmware from your download page. If there are any users out there that have older versions of the Firmware and are willing to get them to me I would really appreciate it.

The printer isn’t making any strange noises that would suggest that there is something wrong with the hardware and it is because of this that I think it has something to do with the Firmware. I applied the Firmware via WiFi and the software reported that it was applied successfully. Will it hurt to try to apply the Firmware again? Should I apply it via USB?

I’m going to tag @Hunter and @Simon as well because I think this needs some visibility. I’m not the only one with this issue and need some help. You’re online help documentation is laughable.

I want to love this printer, it has been great since it arrived, and I waiting more than a year to get it. But this lack of support is leaving a sour taste in my mouth and pretty soon I’m going to loose patience entirely and request a refund. It is an expensive paper weight at this point.

I look forward to hearing something and am willing to work with someone to troubleshoot the issue.

Thank you


@Richierich777 I believe they replied you today, would you kindly check your mail message?


@proclaim Jim, Thank you for the help. Yes, I received the email and have been talking with support outside of this thread.

After sending several videos of what was happening with the printer it was suggested to roll back to the Factory firmware because there were no visual indicators as to why the unit would be failing to calibrate.

Restoring to Factory is relativly easy, just wish it was posted somewhere on the Help Center troubleshooting area so I could have tried that before going through support.

For anyone that may want to restore to Factory, but don’t know how, you’ll want to hold the Flux button for about 10 seconds as you plug in the unit. The white light on the button will turn ‘Red’ and pulse. It will take about a minute of blinking Red before it reboots and starts with the White light again. At this point you’ll need to attach the USB to your computer in order to setup the unit in Flux Studio and to set it up on your WiFi again.

My unit is calibrating successfully and printing again without issue. I’ll be updating to firmware 1.0b20 today. This was sent to me from Flux because I didn’t have a copy and you can’t download it from their download page.

Thank you again for the help. I hope this reset info will help someone else as well.


This is something that is great to note!! Thank you for posting the reset…


thanks for the information. As we’re in the process of re-working on the website, we’ll organize a better place to put useful information


I just received the replacement plastic brackets for the scanner towers (29 days after i started the ticket). It was an easy fix… good instructions provided.

First calibrations went through without error. Ill be back if it starts failing again :slightly_smiling:


I received my replacement brackets for the laser posts a month ago and replaced them with ease. At first, they did the trick. Now they just started popping up again and I had to tape them down. The Flux team is working on a new bracket. Should be out in another month or two. I sometimes get frustrated with these issues but the team is always working on improvements. I hope you get more time out of yours but if they fail later, know that help is on the way again.


So, obviously, no calibration issues any more after fixing the pop-up posts?

Since I never used the so-called 3D scanner, I taped the posts down in the first place and never had any problem with the auto-calibration procedure. Until yesterday … when my precious Flux Delta became another high-tech dektop weight, giving me UH-OH #123.


The scanner poles may gradually go up and touch the plate. Even a slightly touch on the plate will cause #123. Please check them if they sat in the right place.


After the upgrade kit, the poles no longer CAN pop up. If you don’t have the upgrade and don’t want to mess with it, and you don’t want to use the scanner, then take out the springs all together.