Endless Wifi Connection Problems on Mac


Hi everybody! This is my first post. I backed the original Flux Delta on Kickstarter but for one reason or another only got round to finally unboxing it 2 weeks ago - yep, really it’s true! Work, life, and other things seemed to keep getting in the way…

Anyway, I finally have it all setup and I got pretty excited! Amazingly, I did my first print that day (a cat!) and a few days later I printed the boat, 3DBenchy. So, this weekend I got a bit more adventurous and created my own design using a CAD program - that was the easy part…

I am now having endless problems trying to connect to the Flux. I am using a MacBook Pro 2016 running OS 10.12.6, and the latest unstable version of FS 0.9.7. Sometimes I fire up 0.9.0 too. However, the software is not the issue, but the on-board Delta’s wifi is a massive issue. Even though I can see the Flux wifi in the wifi menu, whenever I try to connect I get the message "The wifi network “FLUX Delta [xxxx]” could not be joined. Today, I have spent at least 4-5 hours trying and then finally succeeding to connect. Then, I left the printer for a while to do some CAD wrk, went back to the printer to find that FS could no longer connect and I am back to square one again. Id tried factory reset on the printer and re-installed latest firmware but nothig works.

This is now beyond frustrating really :(( Does anybody know what the wifi issue is, and more importantly how it can be solved? I have read every forum article and troubleshooting guide I can find but none of them are able to identify or address the issue.

I am really pleased with the 2 prints I have managed to get done and have high hopes to priont many more things, but unless this wifi issue can be fixed I am going to go mad with rage! Does anybody have any ideas? Thanks.



Hallo ,hast du mit dem mitgelieferten Kabel auch probiert zu installieren,mußt unten den Micro USB am Gerät und am PC
den USB anstecken dann im Programm Drucker einrichten.


Hi. Yes, I installed the USB driver software and tried using the USB cable but FS is unable to connect over USB :frowning:



I had also the same Problem, try to move the flux closer to your wlan accesspoint


The Flux is only 1 metre away from the accesspoint, so that’s not the issue.



hello, please try to reset your printer: https://flux3dp.zendesk.com/hc/en-us/articles/115009796708-Reset-to-the-factory-settings

also, reinstall the USB driver and update your machines firmware: https://flux3dp.zendesk.com/hc/en-us/articles/216251077-Update-the-firmware-of-FLUX-Delta-Family

then restart your Mac.
hopefully it should now connect through wifi or USB


Hi. Thanks for the suggestions. I have already tried these options.



Ok, so this weekend was both a frustrating and ultimately rewarding weekend with the Flux Delta.

After a lot of experimentation, I believe I have managed to identify the source of the wifi issues and based on that to be able to consistently connect to the Flux.

My findings indicate, at least in my case anyway, that the print-bed metal plate is affecting the wifi/router comms, even though the router is located no more than 1 metre away from the Flux. As such, on Sunday I was been able to consistently connect over wifi using the following steps:

  1. Quit FS
  2. Switch away from the Flux wifi
  3. Remove print-bed metal plate from the Flux
  4. Connect to Flux wifi
  5. Launch FS - I am using latest Beta 0.9.7
  6. Link FS to Flux by clicking on the ‘Machine’ icon in the top-left of the FS window - for me this usually requires 2-3 refreshes before the Flux finally appears
  7. Put the print-bed metal plate back in place on the Flux
  8. Load/switch filament, if needed
  9. Import STL file
  10. Start printing!

Note that even for short print jobs of 15 minutes or less I am finding that I have to repeat steps 1-10 above since it seems that the connection between FS and Flux is usually lost at some point. Although that’s a bit annoying I can live with it as the repeatable steps solve the connection issues for the next print.

I won’t be prining during the next few days due to work, but I will report back again this weekend when I will print something and repeat the steps above.

I hope my investigation and suggestions might assist others. Please give them a go and report back! Thanks!



I reconfigured the Flux to connect to my home Wi-Fi instead of connecting to the Flux Wi-Fi. This eliminates the need to keep switching and makes everything simple. You might want to give that a try.


That is something that I was trying to figure out to do but I can’t see how to access the Fliux wifi configuration settings to do that? Can you advise as to how to access those settings? If it’s via USB only then I’m out of luck as I haven’t been able to connect to the Flux that way.



As I recall (it was over a year ago when I inherited my flux delta from it’s original Kickstarter backed owner), I hooked up the USB cable that came with the printer and followed the tutorial using the flux studio software.

It was that easy. Maybe I got lucky, but it worked without issue on my MacBook Air.



I wonder if USB support worked with older versions of FS and/or the Flux firmware and was later removed? It would be useful to find this out, if anybody knows, and which combinations of those older software versions will allow USB access from Mac as I could (in theory?) downgrade the versions of firmware and FS to get access via USB.



So I was just looking on my MacBook Air and noticed that I had a .dmg file that installs the CP210x Macintosh OS X VCP Driver. It was in the folder where I had saved old versions of flux studio, so I believe it was required to get the flux studio software to see the flux delta via usb cable. I have v4, but noticed that v5 has been released. Here is the link to the download:


There is also a link to legacy drivers if you wanted to grab v4. It worth a try.



Thanks for that suggestion - I will give it a try at the weekend!



So, finally, I can report SUCCESS! Using a combination of Lance’s suggestion to install the v5 driver and reverting to using FS 0.7.8 I was able to connect via USB and configure the Flux to use my wifi. It may be that this will work with the v4 driver too but I didn’t test that combo. I did try combining the v5 driver with using the latest versions of FS first and then working backwards to older stable versions and in the end it was only possible to configure over USB with FS 0.7.8. Note that I was also using the latest version of the firmware, 1.6.86.

I hope this helps others having wifi connectivity issues on Mac.


PS A big shout-out goes to Lance for his suggestions! :+1:t3::+1:t3::+1:t3:


Yeah! I love it when solutions are found. Getting the printer on your personal Wi-Fi definitely makes it easier to work with.



OK, now you have to see if you can still get the Delta+ upgrade kit!
I just finished installing all the upgrades.
The FLUX team has been great about letting us KickStarter backers stay up-to-date with the best printer!
I just got started with Fusion 360, and it’s great! I export to an STL and FS picks it right up!