Constantly getting "Ran out of filament error"



After running my printer 40 hours or so, it was running ok but I’m starting to get Ran out of filament error frequently (like twice in an hour when printing) while the filament is still in the feed. I click “Retry” in flux studio and it continues without problem.

I’m not sure if it’s the sensor at the feed or anything I could check?

Stops extruding part way through printing

I’d remove and reinsert the filament as the first test. That would test the possibility of some sort of alignment issue.

If that isn’t the silver bullet, I’d open an RMA with FLUX on their support website.


I am also having this issue, and I will be trying a few different fixes for the problem. I am hoping to avoid the need for an RMA.


What kinds of fixes are you trying? Because i have the same issues in the past few days with this sensor. Its very annoying.


I’m going to try different colours because I am currently having the issue since I have switched to white. Though I have used that white in the past. Following that, I will try a system update and firmware update.


This is interesting, because i also have this problem with the white filament. Firmware and Studio are already up to date.


I haven’t updated since version 2.17 (mac) because it was working until now. I have also upgraded to version 3.0 (windows) because that was having problems with uploading. But I will be using the Mac for now. I’ve done a handful of prints in white and then I changed to blue then red and back to white, which is when the problems started to appear.


Yesterday it was becoming worse and worse, so i decided to bridge the filament sensors contact. For the moment, this is my workaround, but i guess its the Sensor itself, which is damaged, so maybe i have to make an RMA for this.


So far I have switched filaments from white to black and was able to get 3 prints off without the warning. I will be trying white either tonight or tomorrow night.

Edit: shortly after my comment the error returned and have since turned off the filament detection. Next step will be to submit a ticket for the issue and possibly the other problem I’ve had with calibration. Where the nozzle doves into the bed and misses the first few layers but no extra extrusion.


I started having this problem for the last few days. Now today it will not feed at all, just keep getting ran out of filament error. I tried multiple different filaments, did not help. Jumped the sensor pins, and now i’m printing again.


And it’s official, the bottom of my print head has melted as a result of this error.


i change my advanced settings detect_filament_runout = 0
that did the trick, however when the filament really runs out it’ll probably melt the print head


Unfortunate I made that change and the problem still appeared.


I haven’t been fighting this issue, so please forgive my ignorance. Why do you think that the filament error caused your toolhead to melt? Does it keep the heat on and stop the cooling fan or something like that?

Just curious.


The error kept the heat on and it either melted because the fan turned off or the filament didn’t adhere to the bed and stayed in the printer head. When I found it the filament was beyond a molten state.


Recently, I’m also running onto running out of filament in middle of a printing with filament spool is ok; the printing is paused but I’m able to start again.


I had a similar error, but not sure if this is the same as the other posts here. For quite some time, I would receive the “out of filament” message. I found the post that described turning off the detection in the advanced settings. That worked great until I wanted to load a new color. Nope, no can do. I had to effectively force the filament into place until it extruded. Posting a support ticket got me a new detector, which arrived today.

I was directed to the cap-opening video:
FLUX Delta Top Cap Assembly
Also note that the filament release lever has to be gently pushed sideways to get the cover off. Exercise caution when lifting, as it wants to grip securely, then pop up quickly. This may damage the detector cable, although that wasn’t an issue for me. I would suggest to stand with your face close to the back side of the top cap. That way if it does pop up, you will likely bonk yourself in the nose with it, limiting its travel.

In my case, one of the detector wires had managed to get chewed up by the feed mechanism. The replacement detector did me no good, but I was able to repair the cable.

The “after” photo, with the detector working properly again:


The video seems to indicate there is no screw removal… but I am guessing that there is before the lever can successfully allow the cap to be removed?


Hi All, I’ve had the same issue with run out of filament errors, the switch is clearly a problem.

When running larger jobs (and I’m not there e.g overnight) when the error pops up the hot end stays at temp until the error is resolved. Clearly having the hot end going all night, not printing is a recipe for disaster.

I wanted to override the switch but have some control and not drill holes in the case. I decided to put a reed switch in parallel to the switch, and then use a magnet on the case to override for these jobs. I can remove the magnet and everything is back to normal.

Works well so far :o)


Starting to have this problem now - since this looks to be the best source of info for it, I figured I’d reply here.

Started to see it on a beige filament spool after printing loooots off that spool. Going to take the top off soon to take a look, but just wanted to update the info about the hotend staying on. It seems in later versions of the software the hotend does actually cool down while it is sitting waiting for user intervention for the “lack” of filament, so at least it shouldn’t self destruct anymore, but it’s now ruined a print :\

Does anyone know how to disable the filament run out detection when printing from gcode from another app, like say, Simplify3D?