"Cannot connect to the machine" when uploading gcode file


I just what appeared to be a wifi connectivity problem for 2 days and wanted to share what I found. The short story is: don’t put apostrophes in your file names.

I’m using Simplify3d to generate gcode files. I upload them using Flux Studio (I’ve tried 0.7.8 and 0.8.3 on Mac OS). In FS, I click on the Machine button on the top right, select the printer, then navigate to the SD card, and click the Upload button. If my gcode files are simple words and spaces, I don’t have any problems (like “my model.gcode”).

I had an apostrophe in one of my files, however, and it would not upload. Every time I tried to upload it, I got an error stating “Uh-oh Cannot connect to the machine, please check your connection”

I read every post I could find about wifi connectivity. I rebooted my Flux, checked my wifi router, uploaded new firmware, tried several Flux Studio versions - all with no luck. Through blind luck, I renamed the file without an apostrophe and it worked.

So, can someone at Flux please fix that bug? :slight_smile:


Flag your post for moderation, the powerful proclaim shall fix it


And please copy this post onto the bugreport topic for fs 0.8.3 (dont know the version cuz in travelling).


I don’t see a thread for 0.8.3. Hopefully they’ll see this topic.


It’s here :wink: