Bugs in fcode compiler or flux firmware when engraving


Hi, I found some strange behavior tried when engraving our GFK logo. In the picture below I tried three different versions of the logo. All the vectors in the svg file are the same for the three logos but the vectors are sorted in three different ways:

  1. Engraving row by row, starting in the bottom left corner.
  2. Engraving column by column, starting in the bottom left corner
  3. Randomly sorted, starting with the dot on 11th row, 3rd column (close to the “G”)

In logo 1 and 2 the first row and the first column is too close to the next line, and particularly in the first logo the first dot is off but you can also see this in logo 3. Flux had really problems when the dots were randomized but interestingly the rightmost column is straight!

Why do I get these results, is this something you’re going to fix, and how should make the svg file to avoid the errors in logo 1 and 2?

I checked the gcode file and didn’t find any errors in the coordinates so the bugs are probably either in the fcode compiler or in the Flux firmware (I use the latest software and firmware: FLUX Studio 0.41, Flux firmware 1.3b2 and toolhead firmware 1.22)

The size of the the engraved logos is 12 x 35.6 mm and the svg file can be downloaded her: http://innihvalen.no/flux3d/GFK.svg


Broken picture link.


I have fixed the image now.