Bug in FS v0.4.3.0: "Pause_At_Layer" issue


I just tried to print using Cura a 20x20x10mm cube (res 0.2mm, no infill, 2 shells, 4 bottom, no top layers) layers with “Pause_At_Layer = 7,12” command. The command executes Pause at layer 7 but as the head lifts, there is a dump of filament (if you look closer where the tail starts you notice a circular dump pattern) with about 10mm upward tail following the dump. An Oh-Oh error also comes up but it is not fatal.

When the Start command is hit in the dashboard to continue printing, the head makes 1 full turn at the high level it stopped after the pause, then comes down but there is no more filament extursion. In my case it continues like that (no extrusion) to layer 12 for the second pause and the second dump.

You see 2 tails one on top each other without layers 8 to 11 in between. I stopped the print at layer 12.

What I don’t understand is, if it is not extruding after the first Pause, how it is doing the 2nd dump at the 2nd Pause!

Update: I did another run with one Pause at layer 10 but continued printing passed that layer. It took the printer 5 or 6 layers before filament started to extrude. In short, I think there is a not enough retract and also compensate for retract issue …


thanks for reporting. Let’s do more testing on this issue. =)


I have done a test of the same cube with infill at 25% this time and the Pauses were set for Layer 10 and Layer 15. The behavior is the same. At Lay10 there is a round dump and a tail of filament as in pict below.

When printing continues, there is an attempt to print at the high level the head was paused after layer 10. After finishing I think one full revolution and an infill printing at that high level the head comes down to layer 11 in my case but there is still no filament extrusion because the filament was retracted to much (I am guessing by about 1 or 1.5 layer length when 2 skirts and 25% infill is set fro this structure, one should be able to calculate how much length of rough filament that will be). Since I am printing an infill this time, the filament reaches the nozzle, I am guessing, at layer 13, as you see a layer gap in the picture. It continues extracting until my next pause at layer 15, where there is a round dump and tail again. (you see only one tail in the picture below because I cut the fist tail during the first pause). I stopped the printing after layer 15.

Now I am not sure if it will affect the outcome but I did set in the Expert mode my “retract_length” to 8.5mm, the FLUX default was 7. I attached the Expert setting I am using below.


I have some more observations from my latest try of printing the cube. This time I was printing with 100% infill to be able to estimate the extra length of retraction causing the blank printing.
1st observation: again this time there was a filament dump before the head lifts and I also hear, the filament feeding stepper motor makes loud clicking noises as if it was trying to push out the filament instead of retracting.
2nd observation: Once the head is up at pause level, it starts to print one full layer at that high level before it comes down to where it should be. Once at the proper level, it continues printing but without filament due to extra retraction. I estimated there is slightly over one full layer of filament missing before filament reaches the nozzle (this does not take into account the high level empty printing, with that it will be over 2 layers of empty printing). I think for this 20x20mm rectangle with 0.2mm layer height, it will be about 33mm of 1.75mm filament per layer.


I have noticed this. An stl file loaded will take 19 hrs 40 min with cura and 11 hours 27 min with the slicer selection - huge difference. I tried printing using the cura, and I get a gap after the 4th layer, the head moved a little up for no reason. I’m not pausing. I’m trying now with Slicer selected to see if this occurs as well, will let you know.


I notice some issues with the estimated time in Cura in FS v0.4.3. I am printing some small prints that take between 1 and 2 hours and when they finish the remaining time shows about 80% complete but in fact the print is finished. I did not bring this up as bug but the estimate and execution was closer in v0.4.1

I have not been using Slic3r for a while since I like Cura results.

As for the gap, it could be due to some “non-manif edge or vertex”, did you check the integrity of the STL file? I use Meshlab or MeshMixer for quick checks.


I tried again printing the stl I created, it failed with slicer as well. . I checked the stl with s3d, no issues. I’m going to try to print my test cube tonight. Maybe a bad desin in stl
I will follow-up .


Has anyone who has tried to use pause_at_layers NOT had a filament dump before lifting?