Beambox camera preview freezes after taking a few snapshots


#1

Hello.

Am using Beambox on Windows 10 with Flux Studio 1.2.4; tested with Beam Studio 1.1.4 also. Connected to computer via Wi-Fi. Successful connection as I can run small cutting / engraving jobs.

Am able to scan small area works with camera preview, so camera preview works. But for larger area, preview freezes.

Details: When taking preview of large work area, the camera scans part of the area in rectangle meant to be scanned and then scanning freezes with busy icon. Most often the preview freezes after taking 4-5 snapshots of the workspace.

Re starting preview or the studio software does not fix the problem.

Please share if you have had similar experience or found a fix to the preview problem.
Thanks!


#2

Hi, sadly, I’ve been there, done that, got that T-shirt. If it happens more often than not you may have a bad camera cable (easy to test with a spare cable from Flux, horribly hard to replace if that is your problem) or you could have (as I did) a bad USB 1 meter extension cable in the back & underneath to the right circuit board area easy to test and not too bad to buy locally and replace). A short commentary here… neither I, nor the folks at Flux ever thought a USB extension cable could go bad, I’m proof it happens as implausible a it seems.

But let’s look at a few easier things first and what my latest round of problems turned out to be.

First, I’ve always had problems if after I select Preview and then try and drag the camera too quickly. I’ve found if I select Preview wait for the computer to connect and let the BB home itself, and then slowly click the camera from the start and drag through the finish that in get 90% results… I can live with that. If the camera stays in the screen and didn’t move with your cursor assume you are going too fast. Slow down, be more deliberate, and don’t click and drag until the computer/machine have completed their handshake over WiFi.

Second, I had problems with the following combinations: Flux Studii Software 1.3.4.75; Firmware 2.4.1; Running MacOS (10.14.6) on MacBook Pro. Flux advised “ Please download the newest software version "Beam Studio 1.0.9 " and update the firmware to 2.5.1.” note, this was a change from “Flux” Studio to “Beam” Studio (a much better product). By the time I was able to try it the firmware had again changed and in order for the machine to work with the software I had to upgrade the firmware again. Then my preview function worked IF I was patient, deliberate, etc (as discussed above). Try moving to the Beam Studio software, latest version; and the latest firmware. Good luck and let us know if this helps.

If not… get the help desk to assist and ensure they promptly send you a replacement camera cable (test first before the angst of replacing a good cable) and ask for, our get for yourself a 1m USB extension cable. They (or I) can tell you how to test the USB extension for problems… that one is easy. And naturally, there is about 47 other things that can cause problems for Preview.


#3

Merge, Thanks for your response! Every little bit of information helps and the experience you’ve shared is very helpful :+1: Is there a way to test the cable, as you’ve mentioned? I’ll also raise the issue with the Flux folks to test the cable.

I was thinking if it was a problem with camera memory or buffer size, but cable problem and that one needs to sync (move camera icon slowly) seem plausible.
Do you know if there’s a way to connect BB directly to the computer, not via local LAN network? Would that solve some of the syncing-over-wifi issues and issue with slow speed?

Thanks!


#4

I would think there would be no problem removing the WiFi dongle and using a direct USB cable connection from computer to BBP. Never tried it.


#5

Ok, thanks! That’s an interesting solution, haven’t tried it yet. Am in touch with Flux support; will post here what comes off it.