Apologize :: Software Connection Problems


#1

Dear FLUXers,

I’m really sorry for the inconvenience you have been. We’ve found a bug in FLUX Studio V0.2.17 that is replicated from 0.2.15, due to human error. So if you were using FLUX Studio for the first time, V0.2.17 will fail on connecting. This bug doesn’t affect people who have installed V0.2.16 and made the connection with the printer.

We’ve decided to set up a more reliable software releasing convention to prevent similar mistake happens again. V0.2.16 will now be tagged as stable version as many of you have successfully using it. We were too eager to push V0.2.17, due to the connection stability issue it solved. V0.3.x will be only labeled as stable after tested with several iterations.

We still encourage you to try out the newest version if you already got the printer to work and want further features. But now new users will be encouraged using stable version to avoid bugs in new versions.

Regarding WiFi connection, our main mistake is that we’ve underestimated the complexity of wireless environments, and early users may found the machine is hard to be detected in Windows, the issue can be addressed by setting the IP address in FLUX Studio V0.3.0+.

Some of the users may found the micro-USB broke off. The good news is the feature of the micro-USB port is only for WiFi Setting, and it will be replaced with direct settings with station mode, as well as setting with USB Drive. We’ll take full responsibility on this design defect, however, RMA all these machines with DHL will be both time-and-cost ineffective, so we’re now designing a customized cable that can be attached to the extension port ( in the top cap ), which has the exact same functionality of micro-USB port.

We’ve also heard the request for printing with micro-USB cable. However, in current hardware design, the UART port is shared by both the toolhead and micro-USB, which caused a tradeoff that using micro-USB while printing becomes almost impossible, and implementing switching protocol will be limited by the transfer speed. A good news is utilizing USB Type A port may be a solution, and we’re now researching the possibility of it.

Finally, thank you for reading this long post. I admit that there is still much for us to learn, and there are lots things can be improved. The FLUX Software Team is doing the best effort to solve issues we’ve found in various system environments, we made mistakes, we fixed it. This is a product with continuous upgrades, and you can find new features pretty much every two weeks. To make the product better and better, we’ll need your continuous support.

Best,
Simon


#2

I just received my Flux and tried both version 0.2.16 and 0.3.0 on Windows 10, and both had connectivity issues.

But 0.3.0 is just unusable, always halts with an Uh-Oh message, and the error log button seems to do nothing.

On 0.2.16 the tutorial didn’t even show at first (that is the messages appeared, but images did not show), I had to reboot after setting the printer up (I first tried closing Flux Studio & restarting it but that did not work).

Feeding the filament into the printer seemed to work but one of the rods detached, and I’m a bit worried about that, because repeating the steps had the same effect (with the same rod, and if I turn it around it’s the same end that keeps detaching). edit Ok, apparently you have to lubricate the rods, I will try that and see if that helps.

But I went along,imported the model, clicked start and then I got an “Out of range - please reduce the size of the object(s)” error (I had it at the original size)…

Importing STLs (in both version 0.2.16 and 0.3.0) does not seem to work either, or at least the one I tried didn’t (Marvin - http://www.thingiverse.com/thing:215703).

Very frustrating experience so far :disappointed:.

On a positive note though : the packaging is superb! Don’t change that :wink:.


#3

Keep up the good work Flux Team, we know you guys care a ton about having a great product, a lot of the threads here prove this. Thanks for also being engaged with the community and listening to our feedback and trying to do the right things.


#4

I’d like to also thank the Flux people for the support they are providing. Some kickstarter projects never make it to completion, others take the money and run, and some take the money, provide the item, then vanish too. Flux is at the top of the good-guys list for me.


#5

I just tried importing STLs on OS X (10.9.5), 0.2.16 can not import them (no error appears, I can select a file, but it simply does nothing afterwards) and 0.3.0 crashes without displaying the main window (probably due to the older version of OS X?)…

Is this a known bug? I really would like to print something…

DOH! Apparently you have to install the Visual C++ distributable that is linked on the downloads page to import STLs (should have tried that earlier). Still doesn’t explain why it doesn’t work on OS X though… But anyway, displaying an error message if it is missing would be a nice addition in a next version of Flux Studio :wink:.

I’ll try printing Marvin now… Fingers crossed.


#6

Just got home a little while ago. I installed 0.3.0, rebooted printer and pc and installed supports at both ends of the cable. I’m 14 mins into a 12h 38m print with no sign of the “Toolhead Disconnected” error (that I reported in another thread) that I was still getting, constantly, when I got home. Looking forward to getting back to making stuff. :slight_smile: Thank you!


#7

It’s okay. I think most of us realize developing both the hardware and software from scratch is not an easy task. It can be frustrating for everyone, but keep up the good work, FLUX team! You have a winning product and it is getting better every week. :slightly_smiling:


#8

Ok, I guess most of my complaints were due to the fact that :

  • I didn’t install the Visual C++ Redistributable 2015 (as it is my gaming machine, I was under the impression that I had enough versions of it installed already, well, guess not. I remember why I don’t like Windows again :wink:)
  • I didn’t install the latest firmware
  • I didn’t use Flex Studio 0.3.0 (it didn’t want to run, probably because of the 2 things above)

Just wanted to let you know that I just succeeded in printing Marvin. Really satisfied with the result : http://www.thingiverse.com/make:209061.


#9

I am glad to see many of the issues being addressed.

I think the main wireless mistake was making it mandatory.
The second mistake is telling us we have to use work arounds and
buy additional hardware if our printer is not near our router.

Hopefully the new software works better. The Direct IP capability
is good but then the once set the UI software did not allow the value to be deleted.

This shows lack of minimal testing across the board which worries me.
I plan to play with the laser engraver this weekend. Hopefully it will work.
Then at least one of the three advertised functions will be useful.


#10

I got the same problema.out of rage with small piece.i can not print something. I presa start Butrón and nothing happens.i can not sabe the task.what can i do?.help.


#11

I was installing this software in my Apple laptop and at the same time, I connected the iPod touch in it. Since then there have been some ipod touch problems occurring when I am using it. It is popping up with some error message. What shall I do?


#12

The flux team is doing a good job. There are various connection problems that come and they remove all that and sometimes there should be data loss also by connection not secure. For more, you should visit us in Data Recovery Dubai.


#13

Some times most of the person is facing the Software connection problems. You can simply update your software. For instant support related to the Change AOL Email Password please contact our technical expert for the best solution.


#14

Our administration focus has all sorts of kinds of gear for a printer to give the best support of any degree of printer problems. We offer post-guarantee and yearly upkeep to guarantee that your printer is sufficient. printer repair services at an affordable price.