3rd Party software? What has been your experience? A Noob's point of View


In regards to the visualization, set it to 50 Major and 5 Minor. That should work.


I don’t see how that helps - the printable area still seems to be 24cm wide


Just figuring out that the specifications are all off. Looking at the FLUX, the maximum seems to be close to 160 on the x,y but the website states 170 and I remember reading somewhere that even that was wrong, I believe in the actually manual it states something else. I am actually going to print something with the x,y at 165.99 with a 1mm skirt (printed fine).

That is printing at the FLUX maximum X,Y. Therefore, the specifications are wrong on the website and the manual.

I just inputted the info in S3D and still looks big as you stated but on the FLUX, looks like it is completely maxed out.

@Jim Can you help out with the right specifications to the X,Y and Z axis because it definitely is not 170 x 210mm.



Well, once I got to the printing, Flux Studio said it was out of print area when it visually could not possibly be outside of the print area… so disappointing after spending the money. I have to hope that that we will hammer this out soon. But for now I am dealing with a failing FLUX that won’t get past the self-leveling routine in under 50 tries.


What’s going on, Michael? How can I help a fellow novice printer?

Are you trying to print the model you was showing earlier?

You are having self-leveling problems? Did you have before or is this new?


Yes. Trying to print that model. Says outside of print area. Using you FFF configure.

The self leveling has gotten worse and worse until today it took three hours of retries to get it printing.

I talk about it here.


What is the model? let me take a look at it.

I currently am using the Fleks Build plate, are you using something like that? or are you using factory steel plate that comes with the FLUX?

Are you leveled correctly? make sure the steel plate is securely in it’s place, even a tad bit off could throw the calibration off.

When the calibration is working, it goes through 4 points…when does it stop working for you? Same point or random?

The more information, the better Me or someone can help.


The model is not the issue. It’s the settings in S3D. The model prints fine in Slicer.

The leveling issue is unrelated to S3D or the model. The problem is in the printer as it acts this way at the startup self leveling no matter what model is loaded.

The plate is well leveled. The stop is random. Mostly in the first point. Sometimes in the second point. Rarely in the third point. Sometimes in the center.

I am really not sure what more information I can give.


I had this issue too once. In the end I removed the plate and cleaned underneath it. Sometimes you can get a little material stuck there (old glue or bits of filament) and it may not be easily visible if it is black. It doesn’t take much to throw off the self-leveling sequence. Once you have cleaned everything, it is important to reboot the Flux. It appears that it keeps track of it’s measurements and somehow tries to match them from previous attempts. If you try to self-level after a reboot, that will tell you if the thing is working or not. Hope that helps!


Lets start with the basics.

Leave S3D alone for now and lets deal with the FLUX directly.

Completely shutdown the FLUX. Wait a few minutes. during that time, make sure the metal plate with the little hole is aligned with the little hole on the right side (don’t ask me, it’s what I heard, don’t know if it helps or not).

Completely clean the nozzle head. Start up the FLUX and let it go through it’s process. Import your model and let it do its thing.

KEEP A CLOSE EYE DURING CALIBRATION making sure not a single filament is coming out when touching the plate.

For now, that is the best advice i have…


All good advice and I’ll second all of that. I keep paper towel around to clear the extruder head seconds before it starts calibrating. It’s all too common to find bits of old PLA stuck on the extruder, especially if you are restarting a print.


basics are out of the way and I am not dealing with S3D since I can’t even get past leveling.

I have lifted the plate and check for dust, small toys, animals, and material - it’s all good each time.

I have rebooted OFTEN. As I said, but perhaps not clearly.

I am cleaning the nozzle… I am doing EVERYTHING I can. I am of the opinion that the printer is developing the issue in the software since it is worsening no matter what changes or does not change: STL, filament, lube, reboot, etc.

And I am checking for filament and more. If this was one or two times, as it was at first, I would suspect material, filament, level plate, etc. but since it is worsening and other things are failing like the filament detection… I am wondering if it is the software or failing manufacture.


Perhaps we should move this over to the thread that I started about it so we are not high jacking the 3rd party software thread.


Ive had the same error message, to reduce the model with the new Studio version. I downgraded to the 0.3.0 and the same gcode file is accepted



Sorry that I didn’t get what you mean. We’ve tested the 170 diameter spec without a skirt and it works.


Thanks for responding @Jim. Do you have a file that we can test for ourselves, because i have tried but keep getting errors and when I try to use it with S3D, it tries to go past the boundaries but the boundaries are 170mm.

Also, can you upload the 3.0 version. The new 3.02 version is causing me problems as stated above. After an import (device monitor) and after it prints, it stays stuck in that mode. Unable to upload another file via device monitor. closed out of the program and still stays stuck and constantly getting the update that the print is complete.

Stuck is the only word to describe it.

The 3.0 version had no problems at all.


Sorry that we don’t have S3D software. Do you mean there’s a big STL can be print by Flux Studio but not S3D?

About the 3.02 problem, I will have our software engineer work on it.


The file I am using is a small print. Flux Studio alone says it is a one hour print time. It is also a small footprint on the plate. But when I slice it in S3D and port over the g-code, Flux Studio says that it is outside of the printable area.


how are you importing? Through the import feature or through device monitor? I use the device monitor, although I am unable to see the print visually, I know that it works.


@Jim What I mean is that when I configure S3D with the same build specifications of 170mmX210mm (correct??), it doesn’t work. It goes outside of the perimeter and the ball bearings knockoff (literally). I had to make the model smaller than the specifications for it to print.

I know that S3D is not anything you work with but if the dimensions are incorrect, than it doesn’t matter what 3D software you use, either S3D (or any other third party program), there will be problems.

In regards to your software engineer’s looking into the stuck after print problem, how about uploading the 3.0 version (i had no problems with that).