3rd Party software? What has been your experience? A Noob's point of View


You just can Import the .gcode files in the Studio. Save toolpath to SD and then import it.

But ive noticed, that the startup procedure is a little bit different than with the Studio Slicer. It does calibrate the toolhead only in the middle of the buildplate, the 3 columns dont calibrate separately in this case. But with the few testprints i never had problems about this, so it shouldnt be a problem.


Thanks for all your feedback and information on Flux settings and I’m able to map Flux settings to S3D FFF and tested. The test model with a broken top pillar is used G-code’s S3D and the right side is use Slic3r/Flux Studio. I’ve learned and understand all the settings during the times. Here is my FFF medium quality profile for S3D.


Nice print to test…where is that? edit…Found it.

With the medium settings, you have been able to minimize or even eliminate webbing? In the pic, still shows alot.


Next step is tweaking the settings to reduce all webbing and others.


I found one mistake on my FFF setting of “5D firmware (Include E-Dimension)” under G-code Options that should be checked; it’s as same as “extrusion_axis = E” in Flux expert settings.


I believe their might be another setting that is off. I was using your profile and caused problems. Honestly, thought it was a problem with the flux since it wasn’t extruding filament. Concluded that it was a setting in the profile…don’t know which one, might be the one you stated earlier.

Also, noticed that the measurement you are using are different than what it is stated. Flux states a print area of 6.7" x 7" (170mm x 210mm), I have been using that, but noticed that when printing max size, FLUX doesn’t like it at all. Although those settings are still inaccurate, your’s is at 120 x 180mm.


You’re right.

  1. I have to set 5D firmware (Include E-Dimension) and the extrude problem is gone. But the printing speed is fast. Then I check on Rerap Wiki, it said “FiveD is the name of the original firmware used on the Darwin and early Mendels. While it featured acceleration in principle, it was unusable for the lack of a movement buffer. It’s speciality: acceleration was calculated on the host side, so it would have been able do lookahead long before other firmwares came up with this feature. When more modern firmwares arrived, FiveD was pretty much abandoned.”
  2. I uses the formula how to calculate the print area for delta from S3D forum (x or y = 2r*cosin(45degree)). But I check the from Flux Zendesk, the print area is 170mm x 210mm like you said. I correct that too.
  3. Last night, I printed with a settings of layer 1 = 215 and layer 2 = 210 and the webbing is better (the image on left).

    S3D slicer is much better on comparing Slic3r (the one on right). The bottom of the pillar is more edge lines on the S3D G-code printing.
    However, I’m still working on it and try to make it work with the Flux printer.


Today I couldn’t make my FFF profile working right. I just play dumb and use the pre-setting profile from S3D and only enter the information in configure assistance, start and end g-code. The result is that S3D G-Code has no problem printing with Flux. I have try few models that was failed on Slic3r Flux, but it is printing fine with S3D G-code. I decide to keep S3D on using it instead of using Slic3r.



I have been playing around with your simlify 3d profile… seems not bad.

However the prints don’t stick to well on the build plate with your settings and I get some warping / lifting on the edges.

I changed the “Use Skirt/Brim” setting to:

Skirt Layers: 1
Skirt Offset from Part: 0mm
Skirt Outlines: 10

So far it looks very promising on the test I am running.

Will try to tune some other things…

Btw how far did some of you guys try to push the move speed?

With the brim settings sticks very well on the buildtak.

Yes, I am running a retraction test… this is with 0 retraction and 120 move speed.

Same speed 2mm retraction distance.

Same speed 3mm retraction distance. Looks not bad but the move speed might be to high the precision on the cubes seems not great.

Forgot something… I did change your temp settings too
Layer 1 220
Layer 2 215
Layer 3 210


At first, I thought that mapping Flux settings environment (Silc3r) to S3D is a good idea for compatibility. It took few days to learn to know every parameters on Flux and to S3D profile for Flux, but it didn’t work right. I just use whatever pre-set profile from S3D; my printing model at 0.20mm and temp 190C by using S3D is far better than Slic3r at 0.15mm and temp 215C. Better yet, printing time is also reduced significantly. When I use 0.15mm resolution is almost equivalent with Flux 0.05mm setting. However, there are many different between the Slic3r and S3D. My recommendation to you is that S3D already have the optimization in it software on the profile and there are a few things you might change are skirt outlines (my setting is 4) and resolution. You go to confutation assistance setting and enter Flux printing dimension (170mmx170mmx210mm) and nozzle size is 0.4mm and no heating bed. Next step is adding start and end g-code and save the profile as new name. Import the print model and generate g-code and print it. You will see a better result. S3D is used 190C on its PLA temperature setting that help on reduce stringing during retraction. Why don’t you print a same model and share you result. I will show my results later tonight as well.



Apparently, the FLUX dimension are wrong or S3D doesn’t understand it too well. I have had to tweak S3D’s definition to work with the FLUX. I tried printing with 170mm and the printer tried to got outside the borders in an extreme way that forced the joints to pop off.

My new diminstions are 168x210mm. I haven’t tried the Z axis yet but the X and Y should be set at 168 and origin offset to 84 (X, Y). That little tweak helped a bit for printing at MAX with skirt and raft. I will test how high the FLUX actually is.


A skirt perimeter from object setting is also counted with a foot print of an object. Sometimes I have either adjusting small or disable it, so I’m able to print with a large model.


You are right I prefer the S3D slicer output… Did a benchy it looks not bad but still some issues… Will try to take some pics tomorrow.

I managed to get some better bridging and some finer detail and less stringing in S3D but now I got some holes in the top shell…
The infill might however been too low.


I think you should do carefully check and repair a model. S3D has preview a tool path of the model, use it and check any problem spot you might have on the model before play with the settings. The features are very helpful and save your times on printing a “bad” model. I prefer you go through to tutorial and quality guide from S3D web site that help me a lot about 3D printing since I’m newbie on the hobby.


I know in this case that it is not the model as I printed it without holes before…

Yes, this is great https://www.simplify3d.com/support/print-quality-troubleshooting/

Slicer Review Video

My own experience when I do repair some model and the software create a triangle hole because it detect a bad mesh. However, the I read the section and S3D has the auto repair when slicing under Slicing Behavior /Heal that might be a case. Why don’t you try without the function enable and see the difference from previous printing.


Can someone tell me how they are setting up the printer defaults initially? I am a bit confused on the X,Y,Z Axis… if I set X & Y to 170mm its too big, but if I set it to 85mm its too small. the FFF file is great, btw. But I need the set up info. -Thanks

“My new diminstions are 168x210mm. I haven’t tried the Z axis yet but the X and Y should be set at 168 and origin offset to 84 (X, Y). That little tweak helped a bit for printing at MAX with skirt and raft. I will test how high the FLUX actually is.”
I will try this now.


Still seems excessively large. The visualization shows a grid at 10mm per square that is larger than the actual metal base as well as too large for the print area.


Are you using S3D? If so, that is the configuration that I have been using without any problems. In regards to the Z axis, I have printed out something that was just about the 210mm height without a problem. Make sure you have the setting setup as a Delta printer with the offset.

If not working, what is your error?


yes, S3D. I have not used it yet… an older print is still busy for now and I just got S3D last night. But my reference is to the screen. if I set the print volume to 168x210mm and the offset to 84… and I set the visualization to a 10mm grid… it seems that the print area is showing an area that is just not right. It seems to be 24cm wide!