Why am I having wifi connection issues still?


#1

So I have been running of flux studio 1.4 for a while now and decided it was time to update studio and firmware of the printer. I would have thought that wifi setup should be solved in these updates. I updated studio and of coarse it couldn’t find my printer on the network, so I went through the add new device in studio 0.6.0. Now both lights are breathing I cant see the printer in my router and studio will not find the router either. I do not have any security, nor firewall, not even a password and still no flux printer. I remember some sort of way I had to set the network manually with the usb but I can’t find this procedure.

I should further add in studio I set the printer name and password. studio has me select the network I want to connect to, which does show up in the list. It does show a lock next to the network even though it has no security. I can select it then the spinning ring spins and spins until it finally says cannot connect flux to wifi


#2

Nobody else got this problem, too?
I do.
After FW Upgrade to 1.5b13 Flux Studio 0.6.0 (Linux) keeps telling me it “Cannot detect FLUX Delta via WiFi”.
It is there, though - showing as FLUX Delta [6ae7] in my computers wireless network setup and I can even “connect” it using the serial number as password.
However, it shows a very weird IP address (169.254.182.117) and therefore does not connect to my router (192.168.1.1).
Is there any chance to have FLUX Delta back to using DHCP to abtain a valid IP address? I was just beginning to enjoy 3D printing with it … without connection ist completely useless now (do I have to mention my µUSB jack fell inside the housing in the first place?).


#3

So I finally got it working a while back. I had another computer with an old version of studio on it I think 3.14. I used it to connect the printer to the network, then I could see it with the latest studio version. Also I had an open network that I had to secure and set a password to connect. The machine won’t connect to an open network, the option isn’t even there. I may give the printer 4 stars I give the software and support 2 stars. I pretend the printer doesn’t have a scanner that’s why I rate it so high.


#4

So the problem may be on the side of FLUX Studio … since the green LED is steady, and FLUX Delta shows up as network device via WiFi … but it does not acquire a valid IP address through DHCP from my router. How could it? It must know the routers password - which it obviously doesn’t.

After a few attempts FLUX Delta now again states its IP as 192.168.1.100 in my systems network prefs … and i can successfully ping it!.
But even when I put this IP into FLUX Studio’s preferrences I get no connection. Sigh.
I wish FLUX Studio for Linux were upgraded and fixed this behaviour.


#5

Just another idea: SSH into FLUX Delta …
nmap 192.168.1.100 shows an open port 22/tcp.
FLUX Delta responds to ssh 192.168.1.100 and asks for a password :slight_smile:
Unfortunately, neither the Delta’s serial number nor “flux” do the trick.

ssh 192.168.1.100
The authenticity of host '192.168.1.100 (192.168.1.100)' can't be established.
ECDSA key fingerprint is SHA256:9l6FM3Lf2aDHuBp3q1ZX4kA94eaQoGoXGSYKbHnno6s.
Are you sure you want to continue connecting (yes/no)? yes
Warning: Permanently added '192.168.1.100' (ECDSA) to the list of known hosts.
in4tec@192.168.1.100's password: 
Permission denied, please try again.
in4tec@192.168.1.100's password: 
Permission denied, please try again.
in4tec@192.168.1.100's password: 
Permission denied (publickey,password).

When its IP is simply put into a browser, some “Apache2 Ubuntu Default Page” is the answer.
I still don’t get why FLUX Studio won’t connect …


#6

Reconnecting your Flux Delta printer by USB and trying access SD card in the printer, enter you password and it should work.


#7

Unfortunately the µUSB connector fell off the PCB long time ago.
What exactly is the “access SD card”? Am I missing something?


#8

SD memory card in a printer is temporarily store a gcode (fc) file so a printer can be printing off line.


#9

Is it the USB stick port you’re talking about eventually? There has been a topic about connecting the Delta via a USB to ethernet converter through this “secondary” USB, but I don’t know what the outcome was.
The saying goes that there is some Raspberry Pi Hardware inside the Delta - I guess it’s about time to take it apart to see if there is a way to interface it besides WiFi (and solder the µUSB connector back to the PCB while I’m at it).
Sigh.
I was fine with printing through WiFi until I decided to give the FW update a try.
This very moment a notifier is displayed onmy desktop telling me I’m connected to FLUX Delta.
There MUST be a way to get FLUX Studio to accept this connection somehow.


#10

Update: I finally put the Delta upside down and opened the bottom plate … how I love to void warranties. There it was - the µUSB connector! Glued and soldered back to the board, connected through a special µUSB cable featuring a magnetic pull linkage, just in case.

Guess what? UH-OH Error.
There is definitely something wrong with FLUX Studio 0.6.2 Linux.

Case opened:
http://www.walther-mathieu.de/PICS/A1023821_X.JPG
…the suspect:
http://www.walther-mathieu.de/PICS/A1023822_X.JPG
glued & soldered:
http://www.walther-mathieu.de/PICS/A1023828_X.JPG
µUSB pull linkage:
http://www.walther-mathieu.de/PICS/A1023829_X.JPG


#11

The SD card is on the small green PCB on your picture. Do you have any luck on uUSB connection after soldering back-in? Have you try this WIFI setup by using a USB port? https://flux3dp.zendesk.com/hc/en-us/articles/215394548-Troubleshooting-Cannot-detect-FLUX-Delta-through-Wi-Fi


#12

So what you referred to is the µSD card on the raspberry pi - containing FLUX Delta’s operating system. In the mean time, I had no luck connecting my laptop to the external µUSB jack - but I now have a vague idea why FLUX Delta refuses any connection attempt through user software: Its IP matches the one my router itself is given (192.168.1.1 to be precise)!
Earlier on, FLUX Delta requested its IP from my router via DHCP. This seems no longer to be the case, after the upgrade it never appeared in the routers DHCP list.
I’m now trying to get the good old DHCP behaviour back, eventually with a preferred IP reserved for the FLUX Delta, i. e. editing /etc/dhcpdc.conf.
But I’m no Linux wizard - any help with this greatly appreciated!


#13

I never successfully managed to connect my Flux to my Wifi (I am using a Dlink Wireless N150 Home Router), it just says “can’t connect to WiFI” when I do the micro USB method so what I do is I use my Andrdoid phone as a hotspot to connect my computer and mu flux and it works fine. But I would like to solve this problem though :(. I am using avast free antivirus and here ( https://flux3dp.zendesk.com/hc/en-us/articles/215394548-Troubleshooting-Cannot-detect-FLUX-Delta-through-Wi-Fi) it says it is known not to work with avast although it does with my hotspot…


#14

Would you try to set static IP for your printer? I have been using WIFI connecting to my printer since day one and latest Flux studio and firmware have resolved WIFI problem in the past.


#15

Yep, I’d love to do that … set the IP by myself - and keep it.

Out of curiosity, I replaced the Raspberry Pi PCB in the FLUX Delta with my own one, which is a Pi2 Model B 1GB RAM which features an ethernet port. But in the process of fiddling with network settings I lost the “breathing” of the green LED. Dang.

FLUX Delta now even does not autoupdate from USB stick any more … and I made me no clone of the SD card in the first place - which I obviously should have done. Sigh. Anyone willing to share a copy?
Or also interested in “upgrading” FLUX Delta to ethernet eventually?


#16

Here is a copy of Flux SD card https://www.dropbox.com/s/9xnywuw3pw0ar80/SD%20backup.rar?dl=0


#17

Great! Goldensnake, you saved my day … with your help, I’m back to white & green “breathing” now, on the original built-in Raspberry Pi.
When I swap that one for my Pi2 board Raspbian detects keyboard, mouse, mass storage devices but fails to boot into flux functionality somehow.

I’ll fiddle with this after I got me some spare 8GB µSD cards :slight_smile:

FYI: I opened a case at FLUX support (cannot reach FLUX Delta neither through WiFi nor USB) and they promised to send me a special cable that allows access through the USB3.0 jack at the top part of FLUX Delta. Let’s see…
And I was told tat they are working on a USB cable that allows to connect FLUX Delta directly, “without internet”.
KISS :wink:


#18

Still no luck … sigh.
The very moment I had all other issues solved (e. g. detaching rods, PLA not sticking to plate, elastomer not feeding through bowden hose, support not easily coming off printed parts, wrong PLA, nozzle cleaning, plate moving sideways during print, …) I got my Delta bricked with a simple soft- and firmware update.

Three different computers found and bound to Delta’s WiFi but FS does not recognize it, whatever I try.
Must be something wrong within there… is my strongest guess.

Is this “flux_config.txt” (I vaguely remember having read something here) method of configuration still available in some version-to-downgrade-to eventually?


#19

sorry to hear that the wifi is giving you guys so many troubles. I know few of the user just for some reason, tried everything, and still can’t get their machine to connect. still, I would suggest:

  1. keep your device to your router as close as possible, there could be interference
  2. try reset every setting in flux studio by going to file - reset. note that this clears EVERYTHING, so make sure you back up your print-preset, like speed, temperature… ( copy and paste them into a notepad or something )
  3. if you’ve found that the machine is connected (green light is on all the time), and you know the IP of the device, you can manually go and edit this, open FS and hit ctrl + atl + d, and look for “application tab on the top”, edit the “poke-ip-addr” field

  1. wait for the direct USB device control method in near future. this feature is in progress now and will be released soon. I’ll look for the coming release of FS and firmware. Unfortunately, you’ll need a special USB cable for this, which contains an IC on the wire. More info to be posted soon.

#20

Nice to know such a tweak tool is in existence … not of much use for me since the green light keeps blinking here.

I can rule out WiFi interference for sure - as you can see I opened the Delta top-down, and literally placed three computers on top: A laptop running Windows 10, another with Ubuntu 16.04LTS, and - out of curiosity - a Raspberry Pi3 running Ubuntu MATE. All of these said it connected to the Delta’s AP but its green LED keeps blinking…
Btw., the latter’s ARM7 architecture will not run any precompiled FS.

The picture shows the grade of intrusion I’m at … looped a USB hub into the Delta as well as a HDMI-to-VGA and USB-to-Ethernet adaptor. I can fiddle with all files within - e. g. /boot/config.txt to adjust to monitor properties - but I’m not sure if this is going to get me somwhere useful.

Any advice on how to make the delta an ordinary WiFi client obtaining its IP through DHCP from my (192.168.1.1) router instead of behaving as AP with this IP by itself from within there? That would be fantastic since I got to print parts fast.
TIA