Scan calibration crashes


#1

I can not calibrate my scanner.

If I press the calibrate button in the scan option:

  1. Table turns a bit
  2. left laser turns on and the software shows “calibrating for scanning”
  3. nothing happens for a few minutes (laser stays on)
  4. machine resets the tool head and “calibrating for scanning” dialog disappears, laser turns off

Somehow it seems to get stuck while calibrating.

Updated the firmware and software but still same result.

I can run a scan, but I get two objects in each other. --> no proper calibration

Did anyone have the same problem or knows how I could solve it?

Thanks!


#2

Got the same issue, two objects inside each other, I am sure it’s a software issue as I haven’t been able to do a calibration with both lasers working and calibration finishing either. But if I do scan, both lasers work fine.

I just did some tests, what I’ve discovered is that the position of the camera affects the calibration accuracy, I pulled the camera out all the way, then did a draft scan, then pushed the camera as far as it can in the left position, did a scan and then pushed it as far as possible in right direction, you will see that it either moves the inner object closer to outer or farther away, so basically I think the play in the camera from side to side or the replacement of the camera with the upgrade kit, affects the accuracy of the scan, of the disctance between the two scanned objects. Give it a try and let me know if you get different results.


#3

Exactly same as Gerhard.

Installed new Software Version 0.9 and also Firmware 1.6.75 but still same Problem.
Can’t do any scans this way!

FLUX Team, please help!


#4

Hello,

I’ve got a problem with calibration too. I’m not sure it’s exactly the same problem, though.
When I insert the calibration tool and push the calibrate button, it starts, with the “calibrating for scanning” message. Then the base turns, until the target is out of sight of the camera and I got the message “Calibration tool not detected” and the calibration stops…

I’ve checked that I have the last firmware and software versions too.

Any advice ?
Thanks.


#5

Sounds like your camera doesn’t see the calibration tool.
Can you test the camera seperately?
Maybe the calibration tool is inserted wrong? (That happened to me in the beginning)


#6

I think the camera is working: first, I see the image on the Flux Studio and I also did a scan, without calibration, and obtained a result (not really accurate but I suppose it should be better with calibration).
There is a slot in the base to insert the calibration tool: when the slot is parallel to the front of the printer, the calibration tool is facing the camera (as expected, I guess). In this case, the behaviour is the one I described: it starts, as if correctly detecting the target, the base performs a quarter turn and then I get the error message “Calibration tool not detected”.
After that, If I retry to launch a calibration from this position, I get this error message directly.
If I get the base in its original position again (I launch a scan so that the base turns and stop it when it’s on the position I want), I reproduce the same behavior…
The lasers are not turned on during this process.


#7

Hello I was having the issue with calibration, and noticed one of the lasers were not as bright as the other. I spoke with the flux team, and received a replacement. Once I installed the new laser, the calibration worked. So just a thought, dont know if you are having the same issue, but something else to look at…


#8

If there is not enough light, the camera has a hard time to detect the calibration tool. Maybe that could fix it?


#9

I put two desk lamps around the printer (one on each side), so I don’t think the light is the problem.
Thanks for the input, though. I’ll do some more tests…


#10

Too much light is also a problem as the camera needs to see the laser lines as well. I just tried it and with dim house lights and it worked but with a desk lamp shining on the calibration bracket it failed the calibration.


#11

I made out of white foam board, a enclosure that folds around the printer and then have a camera light on a tripod directed on the printer.


#12

I also having similar issues as described above with latest FLUX studio (0.9.0) and firmware (1.6.75).
Out of 5 times trying, only 1 time FS show calibration success.
Other times, calibration hang up or could not find the calibrator tool.

I cannot get the lasers to turn on via the Commands>Turn on scanning laser.
Nothing happens when I do that.

Without any calibrations, I too could get some kind of scan in FLUX studio.
Somehow the lasers worked and the turntable worked, so I assume the hardware are ok,
probably software issues.

No idea what else can be done.