S3D Not working in FS


#1

When I export the gcode out of S3D and import it into FS there is only 1 layer and the part does’t print, I have used the stock setting in S3D and FFF profiles on the forum and its still the same issue…


#2

Ask pfeerick, he made spaghetti with benchies pfeerick Using simplify 3D


#3

I don’t have s3D so I can’t help, anyway good luck!


#4

I’m using S3D to slice my models and for me is working, when I import the gcode generated by S3D into Flux studio it shows the whole model in 1 layer like you said, but I just click on start and send it to my printer the gcode is being converted to fcode and starting to print.

I don’t know exactly what is the issue in this case with you, but if you could give us a little more information, like share the stl or gcode that you are using or if you make a video showing us the problem we could assist you better with your problem.


#5

lol… I’m chalk the spaghetti monster benchy up to under extrusion due to too much retraction… There were gaps between the layers down in the hull of the boat as well. The entire boat printed out though… sort of! :laughing: :laughing:

@Debre I regards to only seeing 1 layer in Flux studio once creating some gcode in S3D, I see the same also. However, I’ve not seen that in the past, as I skipped that view, and simply uploaded to the Delta via the machine dashboard and hit yes when it asks me to convert to gcode to fcode. So whilst it may ‘look’ strange, it should work… as the 1 layer shows the whole print :wink:


#6

S3D stock setting is probably not going to work with FLUX Delta, you need to double check machine settings.

The 1 layer is normal when importing gcode. It gets converted to fcode as soon as you import it so there is no preview available, FLUX Studio just sees it as flat, or 1 layer. Your normal models that you load in FLUX Studio can render a preview with multiple layers because they are not converted to fcode until you click start and see the “processing” which sends them to the printer. That is when their gcode is getting converted to fcode as well.

But you are saying they do not print. It sounds like you have grabbed the .fff settings file from here but you may not have the machine settings setup right so your gcode isn’t actually talking to the FLUX the right way. Check the Gcode Tab in S3D:


#7

Hey guys thanks for the help, I managed to fix the issue by reinstalling FS, however when I start a S3D print, FS comes up with the tilt head error and pauses the print, which then I have to hit continue in FS. Does anyone else have this issue? and is there a script to initiate the Delta calibration before all prints just like if you had sliced in FS, I’ve tried G29 & G30 and they dont work, Im guessing the initial calibration will overcome the tilt head error?


#8

I’d disable the tilt check in File -> Preferences -> Machine -> [YourMachineName] by unticking it, and seeing what happens, as the Delta should automatically calibrate at the start of every print itself… it’s not really an optional extra, and doesn’t need to be told to do it. :wink:


#9

That Worked! Thanks! The setting for calibration was set to by file type so thats why S3D files were not calibrating before the print. Another question is there a way in S3d to print a test line before the print ie. how in Cura prints it starts printing a line on the outer edge of the print area then begins to start the print.


#10

You’re after the skirt I think… under the process settings, look on the additions tab for use skirt/brim


#11

Yeah I tired using skirts but for some reason the inital PLA that comes out of the nozzel bubbles and the print head would pick up the bubbling as it went to do the first layer. When I use to use cura it would conduct a test print on the outer edge of the print to get rid of any inconsistency in the first inital PLA coming out of hte nozzel.


#12

When you say the test print on the outer edge… are you referring to the 3/4 priming circle that you’d get when using the cura settings in flux studio? I don’t use the cura standalone app, so I’m not familiar with any other behaviours… but I would have thought it would still only have done a skirt as an extra in order for you to see what the first layer adhesion was going to be like…


#13

Look in the expert settings in FS and find the start code. Copy and paste this to the start script tab in S3D and that will make it perform the perimeter circle before printing.
I’ve not actually tried it but it should work!


#14

Yes it does. I am using it all the time in S3D.
It primes the nozzle nicely which means my brim is actually there if I use it

edit: but one needs to remove the \n if I remember right… posted modified code somewhere a while back.

my start script.
;G28 ; home all
G1 F6000 Z50
G92 Z49.9
G92 E0
G1 F2400 E-4.50000
G0 F9000 X85.384 Y-0.738
G0 F9000 Z0.8
G1 F2400 E0
G92 E16.55716
G1 F600 X83.693 Y16.934 E21.28723
G1 X78.383 Y33.877 E26.01807
G1 X69.685 Y49.355 E30.74862
G1 X57.975 Y62.701 E35.47929
G1 X43.757 Y73.336 E40.21008
G1 X27.649 Y80.802 E44.94053
G1 X10.345 Y84.776 E49.67108
G1 X-7.407 Y85.086 E54.40166
G1 X-24.838 Y81.718 E59.13191
G1 X-41.198 Y74.819 E63.86265
G1 X-55.778 Y64.686 E68.59345
G1 X-67.947 Y51.758 E73.32398
G1 X-77.179 Y36.593 E78.05439
G1 X-83.077 Y19.846 E82.78515
G1 X-85.383 Y2.241 E87.51594
G1 X-84.001 Y-15.458 E92.24605
G1 X-78.988 Y-32.490 E96.97657
G1 X-70.562 Y-48.119 E101.70744
G1 X-59.086 Y-61.666 E106.43796
G1 X-45.057 Y-72.548 E111.16858
G1 X-29.081 Y-80.294 E115.89920
G1 X-11.848 Y-84.570 E120.63003
G1 X-3.392 Y-85.306 E122.88852
G92 E0


#15

Yup, as Tiwaz said, it works… :wink:

I’ve also used a some different start code that I think mc_ott provided for flux studio, which instead parks the head around the same place the printer goes when it pauses itself, extrudes some filament, and then waits 10 seconds before moving on to start the print… I like it as it uses less filament for priming, and actually behaves very much like how my other printer does.


#16

That’s the one I’ve been using. Kind of nice, the printhead comes forward too.

@tiwaz You have all that in your S3D? Mine has like 1 line LOL


#17

hehe yes I do :grin:

I did try to change it once to just a quarter circle but that did not work.

I think it is possible but I probably removed the wrong part of the code.
Not sure if it would still work as well so I might just leave it.


#18

LOL,

I am so backwards now.

My S3D gcode prints drop the 3/4 circle and my FLUX Studio prints have the MC_Ott lean forward and bow maneuver.


#19

I rarely use flux studio these days, for me it is just a way to get the gcode to the printer.


#20

I go back and forth, just to keep pace with changes and to report feedback. Need to know what is going on in FS to be helpful to others and honestly for simple stuff sometimes it is just fine.

I did hear an interesting rumor that Cura / UM is allegedly working on customizable supports. Don’t know if that is true or not, but would be pretty awesome if it happened. Also heard more stories about more devs jumping ship at S3D over pay/benefits/working conditions, which seems more believable given that they haven’t released any updates since like 1988 or something… :slight_smile: