Purging Filament before printing


#1

Unless I missed it somewhere, which is possible, I do not see a method to purge the filament to make sure it is flowing through the nozzle. It would be nice if there was simply a icon to click that allowed the user to purge the filament prior to printing, thereby reducing wasted time watching and making sure the filament is flowing, even when placing a support raft. Several times I have had to stop a print because when it laid down the raft it was not coming out as it should.


#2

This is the purpose of the “skirt” - to get the filament flowing before it starts printing. I have my skirt set for 4, meaning it will go around your model 4 times. You could try changing the height too.


#3

I’d like to have a purge prior to print.
I printed something today that would not fit on the plate with any skirt or brim. The head began the wall creation and did not extrude any filament until the third pass of the outline of the part. I’ve run into similar problems with smaller parts where the brim (4) did not “consume” enough filament to allow the print to have a proper start. There is an expert entry named minimum skirt length, but it’s not clear, nor is it well covered (at all) in the slic3r manual/wiki. I set it to a stupidly high number for one test and got a huge racetrack around the part. It did allow for proper extrusion for the part, but I’d like to have a better handle on how to use that feature.

I’ve suggested before that the head move off-print after the project start calibration and pump some filament out, to avoid the filament “dot” in the center of the print and to ensure the proper feed. Perhaps a future feature for the software?


#4

Hi Milkdog, Thanks for the information, will give it a try.
CADprof


#5

Hi,
It’s possible to purge filament by changing the G-Code (variable start_gcode) using the Expert tab in Advanced menu. I did change it using the code below :

start_gcode = G21\nG90\nM82\nM106 S0\nM109 S200\nG1 Y-60 Z100 F6000\nG92 E0\nG1 E45 F200\nG92 E0\nG4 P10000\nG1 F6000\n

this is what it means :
SETUP PRINT HEAD
G21 - Programming in millimetres (mm)
G90 - Absolute programming (position absolute)
M82 - Set extruder to absolute mode
M106 S0 - Fan ON - Speed 0
M109 S200 - Set Extruder Temperature and Wait - 200°C

MOVE THE PRINT HEAD IN FRONT OF THE PRINTER
G1 Y-60 Z100 F6000 - Linear Move Yaxis -60 Zaxis 100 - set feedrate to 6000mm/min per minute

STAY IN PLACE AND EXTRUDE
G92 E0 - set extruder coordinate to 0
G1 E45 F200 - extrude 45mm of filament at feedrate 200mm per minute
G92 E0 - set extruder coordinate to 0
G4 P10000 - wait for 10 seconds
G1 F6000 - set feedrate to 6000mm/min per minute

This works fine for me, associate with skirts = 2 (also in Expert tab) the extrusion start immediately.


I fixed my clogged nozzle!
#6

A word of caution, it is my experience that when filament temperature is set in the start-gcode, it overrides the temp set in the “General” window of Advanced settings. Every time you change the printing temp in General settings, you should adjust the start-gcode temperature to the same temp.


#7

Hi mc_ott,

Thanks for your remark.
I did not notice this behaviour. I printed my pieces with a temperature between 210°C and 220°C and the temperature always match. Maybe if I’ll need to print a piece with a lower temperature than 200°C I’ll notice this behaviour.
I just finish printing a piece at 210°C and the displayed temperature (while printing) was around 210°C… Maybe it depends on firmware or Flux studio version ? or it’s the sequence of the g_code ?

Sorry I can not confirm your remarks with my experiences.

Mac OS X 10.11.4
Flux Studio 0.3.13
Frimware 1.1.7
Head firm. 1.1.2


#8

@Marxoo, I did not try lately to see if it is OK now. After noticing the problem, my workflow was modified sometime in June to include the adjustments of both Temps to the same value.
On my next print, I will try slightly different Temp values and verify again.
Cheers,