Printer makes a circle around the object


#1

Hi, my flux delta+ makes a circle around my wanted object, im OK with it but i dont want it.


#2

Are you referring to the 3/4 perimeter circle at the start or a skirt very close to your object. I don’t know about the perimeter circle but you can turn off the skirt in the Expert settings by setting it to 0.


#3

Also if is the movement test what you are referring you can disable on file->preferences/machine and the disable it


#4

hi
i mean it makes a circle of filament


#5

yup thats it!
ill try it out,
there are hundreds of settings in expert, which is the one?


#6

Go to Support pane in Advanced mode and switch off Skirt at the bottom.


#7

If you’re using the Cura slicer, this is part of its behavior and is something good to do unless you are “priming” the filament some other way. The reason it does this is to get the filament starting to extrude before it starts on your actual print. If you turn this off, parts of your print will be missing filament because it hasn’t started extruding.


#8

Indeed. I no longer have any need to use a skirt just to prime the extruder, nor have any poor extrusion which ruins the finish of the first layer. That combined with the new magnetic mat has resulted in the best first lay finish I have yet to see from my pinter… I was getting better at it with the glass and glue combo as I’d finally found some good glue, but this is a whole new level of perfection! :wink:


#9

its already off , still does that ill try turning it off and on, thanks for the help!


#10

ohhhhh, so is there anyway to make that circle smaller, btw i was using cura2


#11

@pfeerick @Milkdog ,
i dont want to use slic3r because its takes mach larger print times and more filament, i guess its the only way then, ill try turning skirts off and on


#12

The skirt is only the shape it draws around your print… this priming 3/4 circle is a different thing entirely. I haven’t fiddled it with it, but I believe it’s part of the start gcode when using cura2. In other words, part of this block from the expert settings:

machine_start_gcode = G1 F6000 Z50\nG92 Z49.9\nG92 E0 \nG1 F2400 E-4.50000\nG0 F9000 X85.384 Y-0.738\nG0 F9000 Z0.8\nG1 F2400 E0\nG92 E16.55716\nG1 F600 X83.693 Y16.934 E21.28723\nG1 X78.383 Y33.877 E26.01807\nG1 X69.685 Y49.355 E30.74862\nG1 X57.975 Y62.701 E35.47929\nG1 X43.757 Y73.336 E40.21008\nG1 X27.649 Y80.802 E44.94053\nG1 X10.345 Y84.776 E49.67108\nG1 X-7.407 Y85.086 E54.40166\nG1 X-24.838 Y81.718 E59.13191\nG1 X-41.198 Y74.819 E63.86265\nG1 X-55.778 Y64.686 E68.59345\nG1 X-67.947 Y51.758 E73.32398\nG1 X-77.179 Y36.593 E78.05439\nG1 X-83.077 Y19.846 E82.78515\nG1 X-85.383 Y2.241 E87.51594\nG1 X-84.001 Y-15.458 E92.24605\nG1 X-78.988 Y-32.490 E96.97657\nG1 X-70.562 Y-48.119 E101.70744\nG1 X-59.086 Y-61.666 E106.43796\nG1 X-45.057 Y-72.548 E111.16858\nG1 X-29.081 Y-80.294 E115.89920\nG1 X-11.848 Y-84.570 E120.63003\nG1 X-3.392 Y-85.306 E122.88852\nG92 E0

Maybe to to print less of a circle, you could remove half of the G1 calls as they are probably specifying the coordinates for the circle? As G1 is the command code for linear move… and there are a lot of them! Only problem with doing that may be that it appears to be gradually ramping the extrude rate up, so if you were to delete the bottom half of the list, it would only ramp up so far… :wink:


#13

It’s probably a full circle, but because of ooze and retraction, the extruder may not always immediately start laying down plastic for a distance. If you’re seeing 3/4 of a loop, it’s probably still priming for the first 1/4-turn.

The skirt’s really handy for making sure extrusion’s (and first layer adhesion) is going the way it should. I usually use a 3-loop.

Skirt is controlled in the Advanced settings, on the Expert tab in FLUX studio. The parameters you want are:

skirt_distance (distance from the model the skirt is laid down)
skirt_height (how many layers the skirt extends up)
skirts (how many loops the skirt consists of)

In Cura, similar options are on the Print | Structures tab. In Slic3r, Print Settings | Skirt and brim.


#14

The print head only moves roughly 3/4 of a circle… so you usually get less than that, and possibly some initial clinking and under extrusion due to the retraction and ooze. I know other people don’t like this, but it seems to be effective and results in no issues in the first layer due to insufficient priming. Make it an option for sure, but don’t please disable it completely!


#15

I would also like the option to reduce the size of the circle. I think it’s nice to have, but a 3/4 perimeter is a little excessive for me. Has anyone tried modifying the code?


#16

yes i did but… it made no difference. im horrible at expert settings, thats why i have this post for expert settings in a more user friendly manner! the name is: not so professional FS?


#17

Well, what you want to do is an “expert” thing. A standard user has no need to remove it.

It is something required for you to have a good print, which is why it is something that should not be turned off.


#18

[quote=“pfeerick, post:12, topic:2486, full:true”]
The skirt is only the shape it draws around your print… this priming 3/4 circle is a different thing entirely. I haven’t fiddled it with it, but I believe it’s part of the start gcode when using cura2. In other words, part of this block from the expert settings:[/quote]

Ohhh, I’ve never used Cura, so I wasn’t aware of this feature, which I presume is really more of a filament prime than a skirt. That’s not a feature of FLUX Studio or Slic3r, as far as I know.

Didn’t mean to cause confusion.


#19

Hey, I’m not certain on that either… it’s just someone else stated that it didn’t happen when they used the slic3r engine instead, so I went it must be part of the new cura2 settings. Having said that… I can’t say for certain I’m using that, or the older cura option, so it might be all a load of :poop: :open_mouth: !

Just in case you didn’t know, you can (currently) choose in Flux Studio to use slic3r, cura, or cura2 as your rendering engine on the first page of the Advanced settings.


#20

yes its cura 2, cura doesn’t do that. :stuck_out_tongue: