Print Head falls off every time I try to print


#1

I have the original Delta. In December the print head filled itself with molten PLA and I had to send it back for repair, but it immediately (two prints later) did the same thing. At that point I was out of warranty so I had to buy the new head with metal face. I have only been able to get one successful print out of this head - every other time it simply falls off the magnets. It will run through the movement tests fine, it will calibrate, and then start to print and in trying to print the brim circle around the edge it always falls off. To make matters worse, I have the upgrade kit all installed now, and so when it falls off it burns a hole or drags the hot end right through the nice print mat.

So far I’ve tried the following:

  1. Installed the oil sponges thinking maybe there was too much friction, but that seemed to actually make it worse, so I have since removed.
  2. Slowed travel speed down to a crawl. I have the travel speed set to 90, which is barely faster than infill speeds. My thought was there was more weight in the new head, so the high speeds were getting too much momentum going and the sudden change of directions were breaking the connection. So far, even moving to creeeping speeds hasn’t helped.
  3. I haven’t examined the ball ends under a microscope, but upon examination they all still look smooth. I have tried lots of oil and very little oil, but neither seem to help.

I’m at the point of just thinking I should toss this thing. I’ve poured hours of time into repairs and tinkering, and have very few successful prints to show for it. If anyone has a helpful suggestion on how to get the magnets to not detach please let me know! I still have the old (dead) print head…maybe I should just swap the magnets from there.


#2

Just 1 comment on #2: my travel speed is 100, my fastest print speed , infill is 50, all my print other speeds are usually less than maximum 55. 1st layer is less than 30 and the rest 40. Can you try these speeds and see what happens?


#3

When you say your old head filled itself with PLA… has it melted itself completely… or is it just that it keeps doing it now? And are you able to tell if the leak is coming from behind the heat block? It’s possible the heat-break isn’t screwed in tightly, and it is leaking plastic… that is what mine tried to do, but it’s cured of that ailment for good now :wink:


#4

All good suggestions. Before you bin it, let us try to help you. By the way, FLUX Support should not have let you purchase a print head for a defective one just a couple days out of warranty like that. :frowning:

Another question, are you still using the original mini-USB-C cable that came with your machine or at some point did you switch to a new one?

I’m starting to wonder if FLUX got a bad batch of ring magnets…


#5

that happened to me… alot… you should try boiling the tube in water, (just kidding(not that i want to give you any ideas)) :wink: you should run some movement tests and assembling it again if it disassembles, keep doing it again and again and the tube will adapt to it, do it about 20 times or until it starts working, if that doesn’t work just rotate the tool head 60 degrees by removing it from the the rods and rotating. Hope this helps! :slight_smile: oh and i was also thinking that my magnets were defective, maybe they are but the problem went away for me


#6

I’ll take a look at the other speeds. i had dropped the travel speed significantly after a software update, but I don’t think my other settings match yours.


#7

@BoozeKashi- I have the new cable that came with the upgrade kit, but the problem existed with both cables.

@pfeerick - the old head overheated after the last PLA overflow incident, and the machine no longer recognizes it at all.

@aw1 - I haven’t ever changed the bowden tube, so maybe it is time. The machine always succeeds on motion test and calibration, it just fails when actually printing. No idea why that would make a difference, but it seems to be the case thus far.

Thanks for the suggestions. I’ll keep fiddling for now…it doesn’t sound like this is a widespread issue.


#8

It may not be widespread, but there is at least one other machine that falls apart like that in almost exactly the same way as yours. He was posting video of it, but it was the same. It would pass movement test, then go to start print and the rods would suddenly go 17 different directions and the whole thing would come apart.

We have not (at least that I am aware of) heard from him again after he contacted FLUX Support, so they may have resolved the issue or he may have given up. Please don’t give up. There are not too many things that can cause this, and apart from an actual firmware issue on one of the boards it is most likely something you can figure out and fix.

The quick test you should do right now is download the oldest FLUX Studio available (0.6.3 I believe) and install that. If you want to dual install or overwrite is up to you, it won’t matter much in the long run. That older version does not have the 3/4 circle priming extrusion before printing. If you can successfully print with that version, then it is completely a perimeter issue and we can narrow it down to the specific bit of hardware causing the problem.