Micro USB port get pulled out


#9

@Jimustanguitar, I will advise my friend to get that, he is lucky enough to get the printer later than me haha.

@Simon, I received your message from Kickstarter, and was about to send back the printer. But then if you have plan to move away from micro USB, I don’t mind keeping it and go for the WIFI/USB stick solution. Sending it back and forth just too costly and troublesome. :sweat_smile: Shall look forward for the solution for us with broken micro-usb port.


#10

@wayne_lian
Check this link >>


#11

@Simon, thank you so much! I will give it a try after work. :+1:


#12

Happy to report that the magnetic USB connection works great. Looks nice, too.


#13

Our USB just broke off today and fell into the flux…

We are not having any luck with the config and special software… The flux doesn’t get on the wifi.

We have tried cabling the flux with a use-ethernet cable but while we are able to get the flux on the network and ping it we are unable to see it in the flux studio.
We have windows 10.

@wayne_lian if you get the config file working please let is know.


#14

My USB Port hasn’t broken and I hope it does not.

Because my Flux dedicated laptop failed today, I had to attempt to install Flux Studio on a spare. The installation, using “install as administrator” went fine, but that’s all that went fine.

As with your situation, Sashagg, I can see the device on the network, I can ping it, but it shows nothing in Studio device window. I attempted to set it as a wifi station, with apparent success. I was able to connect the laptop to the wifi node, but that was peculiar too. I had entered a password, yet the network station appears as unprotected and does not require a password to connect.

It matters not, however, as the Studio did not see the printer using that method either.

I’ve sent off a support request and am hopeful to get working again soon. I am now stagnating in the middle of a project that was starting to be fun and interesting.


USB device not connecting
#15

I got it working!

So after a nights rest i tried again.
Downloaded the special wifi firmware/config again(just to be sure)
ONLY changed “your wifi name” and “your wifi password” to match out network.
Firewall turned off.
Plug the usb in and unconnected and reconnected the power cord.
When it started scanning for the wifi I activated the hotspot on my phone - Steady green light!
Made sure I had the studio 0.2.12
checked the IP for the flux through the router
tried the new diagnosis tool - didn’t show up(i could ping it in cmd)
Opened Flux studio and there the printer was even though it didn’t show up on the diagnosis tool.

my pc is windows 10.
It was connected with the firewall on before so I will update when I have steady connection to the studio while firewall is activated.


#16

Hi @Sashagg, sorry I was bit tight up and haven’t got chance to test it out. Glad that it’s working for you, I probably only have time to test it tomorrow. :sweat_smile:


#17

Same thing JUST happened to me. FRUSTRATING…waited a year and broke in less than a week.

SASHAGG… What did you special wifi firmware/config file did you download? What did you do to get it working without MicroUSB?


#18

Link doesn’t work and I am looking for a solution to this problem, unless you want to send me a new Flux 3D Machine that has the microUSB enforced better…[quote=“Simon, post:10, topic:718, full:true”]

@wayne_lian
Check this link >>


[/quote]


#19

From another thread:

Dear all,

Sorry for the inconvenience for so long… we’ve released the v0.2.17 version with IP direct connection. If you config the WiFi with usb again, FLUX Studio will automatically get the IP of your machine. Or if you are able to get the IP of Delta through your router admin interface, you can enter the IP in File > Preferences.


#20

Thanks for the help. I was able to get it working with that workaround.

Just an FYI from a newbie, the Flux Studio needs more description for each of the options in the configuration in order to understand it better. I had to google most of the stuff and that was timeconsuming.

I have other questions but not for this. This question has been answered and solved, thank you.


#21

My USB port fell in the machine as well. I am unable to get v0.2.17 to detect my printer. Unfortunately, regardless of which version of Flux Studio I try (0.2.17 and 0.2.12 and pre-betas) the software forgets my printer… even when connected to USB, requiring to set up again via the USB.

Any suggestions?


#22

Hi,


This might help. We are working for another solution. If anyone still have this issue, please report.


#23

I have followed the steps and flashed the printer. Flux Studio still does not see the printer.

I also tried a static IP by doing the following (which didn’t work)

method=static
ip=192.168.1.23


#24

Similar story here: couldn’t connect to the printer via USB. Went to change the cable and the port guts of the plug snapped off and fell into the printer base. Upon closer inspection, it was just a tiny surface mount part placed directly on the board without sufficient strain relief. Those MicroUSB ports are tricky! The handful of tiny solder joints just weren’t strong enough to withstand plugging and unplugging.

Fortunately the USB thumb drive configuration option worked and I was able to get my device on the wifi with little trouble.


#25

@knubie

Does the green LED light up?


#26

@Jim Yes. I’ve also looked in my router DHCP table. It says the raspberry pi is at 192.168.1.105. I’ve tried entering this address in the advanced settings. Didn’t work.

I tried pinging the IP address. No response.

I’ve also scanned my entire network and it’s not appearing at any address.

Can I enter a static IP address in the config file? If so, are there instructions on how to do so?

What else can I try? Thanks for the help btw.


#27

After rebooting the printer again, i can finally see the printer in Flux Studio.

However, it’s asking for a password, neither the password in the config file “flux”, nor my previous password works.


#28

I ran into a similar problem until I used a file finder program (everything search, voidtools.com) to remove all file references to flux from the machine, during a re-install. I knew I had the correct password, but it always rejected it. Once the program was removed (manually) and the registry cleaned (may not be required) and the file remnants purged, all was good again.