Flux studio - screen rendering issue


#1

Hi all

I was happily running on Flux studio 0.6.3, Windows 10 x64 I decided to upgrade to latest stable version 0.7.6

Flux studio has a problem screen rendering e.g The menu’s, dialog boxes don’t appear on the screen or only partially. It’s very odd. I downgraded to previous versions, 0.7.5, 0.7.4 and got the same problem. So back to what was working 0.6.3 and it’s still doing it.

Something to do with the Visual studio C++ I think. I tried reinstalling that too, with no luck.

Anyone had similar issues? See pic, no menu of left, and a partial dialog box


#2

I seem to recall someone mentioned issues with the antialiasing features causing things to not render like that.

There is something for that in the Settings menu, try turning that off or on. (I’m on Mac, so I can’t test.)


#3

Also try updating your computer graphics driver.


#4

I had the same issue. Like Matfink mentioned, update your graphics driver. That worked for me


#5

What year is your Mac? My MacBook Pro, late 2011, has a rendering problem if I turn anti-aliasing on. It is sort of Ok with anti-aliasing turned off.
@proclaim told me they don’t have an older Mac to check it. I hope they can resolve the issue. On my Mac, it started after FS v0.6 when they did some changes to video rendering process.


#6

@apspurgeon what kind of computer (hardware) are you using? have you tried upgrading your graphic card driver? is this issue fixed?


#7

Windows 10 x64, with ATI Radeon 7800, Driver 21.19.137.514 (21/11/2016). Windows told me this was the latest and wouldn’t update. Going to ATI’s website and pulling down latest manually fixed the issue.

Very odd since it worked perfectly with Flux studio 0.6.3 and after trying 0.7.6 and going back to 0.6.3 it still didn’t work.

Thanks all


#8

LOL Mac guys diagnosing and fixing Windows problems :laughing:


#9

Issue resolved.

@proclaim, I found out in MBP forums that in some odd cases, “Automatic graphics switching” setting in Energy Saver, in the Preferences, may interfere with screen renderings. This applied to my case with MBP late 2011, which has 2 graphics processors. Switching AGS OFF decreased battery life but FS screens render properly now with Anti-Aliasing ON.

I hope this will help other older MBPs with screen rendering issue.


#10

thanks for the help and for letting us know!