FLUX Studio 0.6.0 Change log


#1

FLUX Studio 0.6.0 Change log

New Features

  • Orthographic camera view in Preferences.

Changes

  • Uses Cura as default slicing engine
  • Improved toolpath previewing colors
  • Improved slicing algorithm for printing
  • Improved boundary calculation algorithm
  • Reduced device selection delay
  • Added Load filament button after unloading
  • Added more validation before binding machine to cloud

Bug Fixes

  • Fixed tutorial not able to run under certain circumstances
  • Fixed fresh installed studio with first laser job will stall the program
  • Removed redundant auto reslicing
  • Fixed Cura Z Offset parameter
  • Fixed Pause At Layers

About the App

  • For iOS users, you can now join the testflight program by submitting your apple id here https://flux3dp.typeform.com/to/n7mAzp, and install an app called “testflight”. After receiving the email invitation, you can install the beta version of the FLUX iOS App.

Downloads

p.s. We started using Amazon Web Services S3 as the repository for software installers, some users may encounter new downloading issues, please report if it happens.

Simple benchmarks on the latest version


Logging me in to a random persons account. Flux mobile app
Camera rotated on Delta
#2

#3

Hello,

I’m glad you fixed the z-offset issue. I noticed that the other day, that only the non cura slicer engine was working with the parameter. I also tried 5.0 last night, and did the ctrl-d did not work, but the menu option works. Thank you for keep releasing better and better software. :slight_smile: I’ll try 6.0 tonight!!


#4

I needed the “Reset” function for new functions to show up including “cura = default”

Kind regards,
Hayo


FluxStudio install/re-install
#5

Just checked “Pause_at_layers” function and it is working well, no more filament dumps or air-printed layers. I just wish the toolhead lifted higher than it does presently, very tight clearance to insert nuts or magnets, but better than none I suppose!


#6

They should add an option of z-height when the pause occurs depending on what you want to insert.


#7

That would be very nice but I think at some point they said it would be very difficult. I am not sure if that is still the case.

@Simon, can you comment on this issue, is it possible to define the pause height? Maybe in the Expert mode to include “Pause_height_offset”, if nothing is input continue as it is now, if not use the input. Thanks


#8

@mc_ott
Yes, we’re implementing the feature of custom pausing height.


#9

I tested with 6.0, Select the object, and then press CTRL + D, does not work :frowning:


#10

I have some points to make about this version. I downloaded running Win10, 64bit. I missed out on V0.5 and have jumped from 0.4.3 to V0.6.

  1. Cntrl+D doesn’t work for me either.
  2. The software update option in the menu does not work for me. It simply does nothing when I click on that menu item. I tried returning to V0.4.3 and resetting everything to defaults and reinstalling V0.6 but still nothing. I installed the delta firmware by USB stick instead.
  3. I tried to log into the cloud and bind the printer but it took about half an hour and about 15 re-tries before if bound after trying other things like restarting studio and the computer and clicking through the various modes and options and then it just started to work.
  4. I have had no link to an IOS app sent to me yet after >24hours waiting so I can’t test out the remote monitoring. (I am supposed to just wait arn’t I?)
  5. I tried out the pause at height option, setting it to pause at layers 4 and 24 and it worked great! I then ran another print and forgot I had left the option set and of course I had to hang around the printer, waiting for it to pause so I could un-pause it again. I wish the Studio software would tell you which layer was printing, or even better, I wish there was a manual override control panel where I could turn off the optional pause function while running.
  6. The estimated weight of filament and estimated time before starting are both very useful!

Other than that, I am really happy with the prints coming out of this machine! Thanks!


#11

Can’t sign-in Flux Cloud…stuck at “Processing…”…


#12

I just remarqued an “issue”. If i slice a model in simplify3d, the estimated time when i import is almost the same in studio. But then, near the end of the print, it shows just like 70, 80% completed with a estimated time of some minutes or hours (depends on the estimated print time of the whole print) while in fact is almost finished.

Anyone else?


#13

me too, but this issue has been on flux studio for several versions before, some other users had mention this but, still without fix.


#14

For me, it was the first time in version 0.6.0 when i see this


#15

I just did another test print - it went from 65% to 100% time left was 1min 35 seconds. The whole test print was 5 minutes 20 seconds in original total. So it was off.


#16

I posted the remaining time issue for the Cura engine in my v.0.4.3 bugs report and it is still with us.


#17

I yet again had to fight with Norton 360 which immediately deleted your executable indicating lack of trust worthyness.

Also, would really like the mobile app to cache my login info for a reasonable period of time…constantly having to log in is very painful (I have strong passwords).

Unfortunately, recent prints (I’ve tried with both slicers) seem to not have the same level of quality as earlier versions of the software…not sure what the problem is. Possibly I’ve made adjustments to Advanced Settings…what’s the easiest way to revert Advanced Settings to their current defaults?


#18

disable the virus checker, before you install.


#19

That is not going to happen. No offense, but only an idiot would turn off Virus Checking for any reason…especially not just before a software install. No source is 100% safe as a vector for a virus.


#20

lol… really? You’re prefer to have the virus checker tell you what to do and just delete the file you didn’t want it to delete because it was stupid and there was a false positive? I’d be feeling pretty confident that the file is safe after having some 30 or so virus scanners report it as being clean… using a site like VirusTotal to do the multi-AV scan. It happens… so either add the file to the excluded list, whitelist it, tell your AV to snooze for 10 minutes, or go sulk! :smiley: Ok… maybe a bit too harsh… but you get the drift… :laughing:

And going back to the main discussion of late in this thread… I’ve had the same issue… with this version more than earlier ones… to the point where just pmbroth said it was ~60+% complete in flux studio when I heard the printer finish the print… hm… something fishy going on there!