FLUX Studio 0.5.0 Change log + Firmware 1.5b10


#21

The flux app works on my samsung galaxy s5 without any problems. It is exactly what i need :smiley:


#22

@proclaim

Hello,
(This was my experience with my window s10 box, I did not have a chance to use my MACBOOK PRO)
Well I started to use the software and found the following with using my glass plate and a buildtak skin

  1. I always had to have the offset at 0…5, then after last flux version the z-offset I had to change to 0.3. With the new version 5.0, I had to change the zoffset to 0, otherwise the filament did not stick to plate. I do not know if you change the calibration routine, to take into account z-offset or not.
  2. On several occasions, the software gets stuck on the import screen, just like the person above, with small size stl (One that I use for all of my testing , a small cube)
  3. On several occasions, after importing, and the slicer does its business, I press start to print, and the screen flashes and nothing happens. I press start several times, still nothing happens. I have to cancel out of the program and restart it, then it will work. This has happened more with this version, than with versions in the past.
  4. If I cancel a print from the machine side, pressing the button. The software on my computer gets the communication that the print was canceled., I then will try to reprint, and nothing happens, the print box may sometimes come up, but everything is greyed out, and then I must restart the application.

#23

Just updated Flux Studio, Flux Firmware and Toolhead Firmware. Then installed Flux App on my phone and started a small print.
Realy happy with the result. Everything works like a charm. Now I can controll the print with my phone. Thank you Flux-Team.

Using:
FS 0.5.0
Firmware: 1.5b10
Toolhead: 1.2.7
Slicer: Simplify3D

Devices:
PC: Linux Manjaro (Arch based)
Phone: Oneplus One


#24

@proclaim - FYI - I was able to register all 3 of my printers with the cloud service, however, it kept timing out, I eventually was able to register them all after multiple tries.

Looks like a nice addition, can’t wait to play with the new app!

update: okay, I love the app!!!


#25

@proclaim
Hello

I just noticed CTRL-D does not work again.

Thanks

BR-


#26

Has anyone else got NW.JS screen coming up? I have had it happen on two machines with different versions of Flux Studio. I have reported to support but I thought to see if anyone else has seen this.


#27

I have had this happen 2 times so far. I’m also getting a.lot of the app just freezing, and you can’t do anything, but have to exit and reload. (WINDOWS 10 x64) *OSX I do not have any issues.


#28

I am on Windows 10 x64 too. Might try one of my Windows XP virtual machines or spin up a Windows 7 one.


#29

same here, on windows 10 x64, even performing a auto leveling gives me freezes


#30

Mine is working fine, no freezing, are you running as administrator on your machine?
Windows 10 x64 here.


#31

Yes runnig as admin on a 8 core, 32 gigs of ram, dual video card hi end machine…


#32

thanks for the report / update. We’ll continue to investigate / improve on what was found


#33

thanks for the report,

  1. we did not change the calibration routine for this release, however, there’s a new print preset that came with it. I’m not sure if you’ve updated to the latest print preset.

  2. when you clicked the hex button “start” and the screen flash, it’s taking a snapshot of your current view, then it’ll try to communicate with the machine. If it failed, it will not display anything. However, I do feel that this process should be improved, letting user know what it’s doing now (adding this task to future release)

  3. I tested the ctrl + d and it’s working. I’ll try to see what might be the other cause of your issue.

@rfage
are you on windows? or mac? what version are they?


#34

@proclaim
One machine is Windows 8.1 Pro and the other is Windows 10 Pro. The 8.1 PC only started acting up on the latest build. I had not updated Flux in a while. Both machines have Visual Studio 2015 on if that may cause a conflict.


#35

#36

Looks like the culprit is the new firmware 1.5.b10 in my case, i tried reverting back to version 1.3.b8 and everything is working fine again.
with firmware 1.5.b10, performing anything gives me error, for example, tried loading filament and the head temp stays “- c”, performing auto leveling gives me “unknown error”


#37

Hi @Jun_Yan,
Can you repeat the process and send the bugreport ( by using help > bug report ) to our support? It seems to be more like a hardware issue.


#38

Hello Simon, reupdated to firmware 1.5b10 to trigger the error and submitted bug report to support as requested. hope we can sort this out :smiley:


#39

I tried the new flux studio and I having some slow down problems on my prints like @noreflexness said.

The print start good but on some cases it slow down too much I don’t know why. I’m using simplify3d for my slicing and I never had this problem before.


#40

Did you try 0.5.0 or 0.6.0?