FLUX Studio 0.5.0 Change log + Firmware 1.5b10


#1

FLUX Studio 0.5.0 Change log

New Features

  • FLUX Cloud - now you can create an account, bind devices and control it through your mobile phone (requires FLUX App)

Changes

  • Flux-monitor middle button’s behavior, changed from disappearing to disable
  • Updated device list format

Bug Fixes

  • Fixed device list displays wrong progress status
  • Fixed unable to turn off camera
  • Fixed double slicing command fired when imported a file
  • Updated .svg close path processing

Other Improvements

  • Added time and filament cost information
  • Updated IP format pattern
  • Update menu rendering process for faster speed

FLUX Firmware 1.5b10 Change log

  • Fixed bugs of setting names and wifi

FLUX Firmware 1.5b9 Change log

  • Added supports for Cloud Monitoring
  • Added pre-extrusion to filament unloading process
  • Fixed LED wave delay bug
  • Changed LED in AP mode to blinking

Note 1

In order to use FLUX cloud, you need to use firmware 1.5+ with FS 0.5.0+

Note 2

The iOS app is in the review stage by Apple. And Android beta version can be downloaded at https://play.google.com/store/apps/details?id=com.flux.app


Where is the Android APK file?
#2

#3

Installed v0.5.0, but the menus were not working correclty (not properly rendering…no items). Could not close the app either.

A reboot seemed to resolve the issues.

Currently waiting for the verification email so I can get logged into the Cloud and test the Android app.


#4

which menu item was not rendered correctly? device? which platform?


#5

I’ve tried having the verification email resent…still nothing (and nothing in my SPAM folder either)…jammed up at your end?


#6

All the menus I tried, definitely Device and File.

Win7 64 bit


#7

just double checked, they rendered ok on our win 7 x64 machine. However, we found that when first start, the screen gets stuck for no reason, a second restart resolved this issue.


#8

A restart of the machine, not the app, yes.

Though after the initial install, I was able to use Task Manager to kill one instance of the app, there were about 4 others (along with a flux_api instance) that I could not kill at all…hence the reboot.

Any idea when the verification email is going to be actually sent?

Thanks.


#9

investigating on the AWS server


#10

just cleared it, you should receive it by now @cmeans


#11

Unfortunately, all three came in together, and by the time I’d got to them, each link said it was expired.


#12

I tried again, and this time the verification email came straight away, however, now I appear to be just sitting at the “Bind” dialog…what is it supposed to be doing here? How long should the “Binding…” take?


#13

@cmeans Binding would take less than two minutes, if you encountered some hanging screen, please PM me your serial number.


#14

Works on my two computers - Windows 10x64 (Had to reboot after app loaded, first run just hung), OSX - Sierra no issues.

I like the new settings on the device area

Great job. It gets better with every release.
The binding worked perfectly - no issues.


#15

Serial # has been sent.


#16

@simon, I don’t know if you did something, but after multiple restarts of the app, binding did eventually work.

Possibly, it’s an issue with the Symantec/Norton Anti-Virus blocking some network/UDP traffic…but not sure.


#17

@proclaim
Any update on scanning feature in the near future or it will be under the rug for TBD…


#18

Tried about 6-7 times and (while starting to write this message that it doesn’t bind) it successfully binded my Flux printer.
So note for others… try multiple times if it doesn’t bind.


#19

Haven’t tried the Android app yet, but FS 0.5.0 and FW 1.5b10 are working without issue on my MacOS Sierra computer… several prints completed and it just seems to be working smoother and a bit faster than before. Good job Flux Team!

Update: Just bound the printer to the computer… on the first try! The app seems to be working. Looking forward to further developments.


#20

This is a nice update. I feel the it has become much faster in many ways. The mobile app is working and the binding process had a few fail (it said it was due to network problems) but third time was a success.

Issues i am experiencing:

  1. Had some crashes -> bugreport
  2. When finished printing I cannot give the printer a new job
    2.1 When changing filament. The popup window where i can choose load/unload does not appear when clicking the context menu “Change Printing Material”.
    2.2 When staring a printjob by clicking the Start hexbutton (in preview mode); the viewing angle jumps changes (showing the rendered model) and changes back (showing the preview toolpath) and the background goes from light gray to a darker grey but no device dashboard appears.
    2.3 After a restart of FS this works again.
  3. I’m experiencing false filament runout errors
  4. when working with multiple objects on the buildplate:
    4.1 there is a significant slowdown with 3 or more objects (even though the objects are simple)
    4.2 some actions like duplicate and import becomes unresponsive and rarely succeeds.

Example: Im trying to print http://www.thingiverse.com/thing:1097511 -> 10 blobby eyes and 4 blobby eyes 75% but when importing the 75% eye objects the import stalls

It would be nice if one could turn off the automated printing calculations until the build plate is populated and positioned to ones satisfaction. When only working with one object the automation is great.

Example: Im trying to print http://www.thingiverse.com/thing:1097511 -> after duplicating 5 times the background calculations stall completly and no further commands like duplicate are processed.

UPDATE:
After using it a couple of days now i havnt really been able to recreate many of my issues that i reported above. Maybe its was just a couple of flukes… though on the day i did struggle alot… now its running pretty smooth.

Using:
FS 0.5.0
Firmware: 1.5b9
Toolhead: 1.2.7