FLUX Studio 0.4.1 / Frimware 1.3.b8 Changelog


#21

first of all, thank you for your feedback, here’re couple clarifications

  1. GA is used to track user interactions so we can improve our UI accordingly. We are sorry that we should have informed all the users about sending feedbacks. We will do so very CLEARLY on our next release and the user should have the right to turn it off completely.

  2. We’ve not seen any LIBRARY_NOT_FOUND and we’re looking into it.

  3. as for the empty screen @bkerler, did you mean windows x64?

  4. one more thing, if you’re not using FS, we suggest closing it instead of putting the computer to sleep with it. It still has memory leak problems and we will be fixing it gradually. (as I encounter OSX app freeze sometimes too).


#22

The empty screen happens because it crashes due to an invalid certificate of google analytics, as “ga” isn’t defined. I could confirm it for both windows x86 and x64.

LIBRARY_NOT_FOUND might happen if there is another python installation or broken python installation (environment settings)


#23

Has anyone had issues uploading the toolhead firmware 1.2.2 to the extruder toolhead? I can get it to upload into the laser/pen older module without issue, but I get an “UH-OH Update Fail” error when trying to upload to the extruder module.


#24

Do you (or anyone else here) know if Python 2 or 3 is needed in this instance?
https://wiki.python.org/moin/Python2orPython3


#25

@MarioSpeedwagon
sorry for the late reply, do you still experience this problem? it seems like the C++ library is not installed in your windows system. You can download this library in the download section

or perhaps you can send me a bug report and I’ll take a look

do let me know how it goes


#26

have you tried to upload it again?


#27

Also I just noticed in 0.4.1 , if you have no device connected and click on the scan tab, the software endlessly tries to connect to the printer and gives you no option to have it stop trying to connect to the printer, see attached image.


#28

noted it down.

actually there’s a very quick way to restart FS

windows and ubuntu
ctrl + r

mac
cmd + r


#29

So far, this update went well, and the three test prints at the 3 defined quality levels all came out as expected.

It does seem like the calibration now consistently runs through each point twice as much as it did before (on average), but I’m OK with that.


#30

Small problem?
I just rebooted and Norton 360 is now reporting that the Flux 0.4.1 install has a virus…hoping it’s a false positive…I assume I got a recent update from Norton as it didn’t flag it when I first downloaded the ZIP.

I clicked “No”, but I do already have 0.4.1 installed…I’m now going to rerun my system scan to see if anything else shows up.


#32

@proclaim
First time, I’m able to unloaded and loaded filament this morning, without restart FS after the printing job is finished late last night.


#33

@proclaim

  1. Firmware 1.3.b8 can’t connect to my wireless network, green LED is blinking, after few days power-off. Printer boot sequence is fine. I connect the printer on PC via USB, Silicon lab USB to serial on COM7. I start on setting up WIFI by using FS 0.4.1 adding new device but FS can’t detect COM port.
  2. Restart PC and printer, then I try to add a new device and no response of detecting the printer from USB connection from FS.
  3. Print from USB flash drive is OK.
    Please advice.


#34

@proclaim
After I cam home from work and left the printer on all day, the printer WIFI is connected on to my network. If I try to add a new device, the FS keeps trying and never connected.
However, Flux MUST have either WIFI or USB as an alternative connections. USB is supposed to be more reliable as a backup but not in my case.


#35

there are several cases that user’s device can not connect to wifi, are you able to reset your device through USB cable? we’re in development that you can get away with wifi and use the USB cable for direct communication / printing / laser / work

we’ll continue to keep you guys updated.


#36

I did use the USB cable for direct connect but it doesn’t work. If you can see on the my device manager, the printer is connected but Flux Studio (see picture below).
Now I turn off and on the printer and it’s over 25 min is still not connected onto my WIFI network. It did connect onto WIFI once (see message above).


#37

so the green light is on / off, assuming that the device is not connected, also pulling out the menu from the top right corner (device-list) doesn’t show any device.

  1. make sure the mini USB still works (some users broke it by pushing it too hard, it’s quite fragile)
  2. connect the mini USB on the device
  3. power off the device
  4. power on the device

see if this will work, and then use “add new device” to reset the wifi of FLUX-Delta

if the USB does not work, you may request for a “special” cable that can connect directly to the board through the filament compartment (through help desk)

worse, all failed, please open a ticket


#38

Yes, it does.

Yes, the cable is worked because it shows as "Silicon Labs CP2109x USB to UART Bridge (COM 7) on Windows Device Managers.

This won’t work because Flux Studio 0.4.1 fails to connect but not the Windows.
However, I will try to roll back firmware and FS to early version to see that will work. Now, I’m sure the bug are on the Flux Studio and firmware. BUT it has been working since Flux released the update!!! Any clue!?!


#39

@proclaim
I restart the WIFI router and the printer WIFI connection is working. Sorry for all the trouble. Lastly, I test the USB connection again and it doesn’t work on Flux Studio. My printer has a connection at COM 7.